aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-12-13 14:58:08 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-12-13 14:58:08 +0000
commitc4cc383eb91d181cfd792d42cb98114ff0cf025c (patch)
treeb37028dd2b3f9dcbc4488d55b683b15945c46ee8 /sysutils
parentc7ce233cc9f4c95c554d5c8f3de1db225d6ff71a (diff)
downloadports-c4cc383eb91d181cfd792d42cb98114ff0cf025c.tar.gz
ports-c4cc383eb91d181cfd792d42cb98114ff0cf025c.zip
Convert a few ports to GH_TUPLE.
Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=428493
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/envconsul/Makefile101
1 files changed, 33 insertions, 68 deletions
diff --git a/sysutils/envconsul/Makefile b/sysutils/envconsul/Makefile
index 3f52e72bd936..ed508f53b1a4 100644
--- a/sysutils/envconsul/Makefile
+++ b/sysutils/envconsul/Makefile
@@ -14,33 +14,39 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/bin/go:lang/go
USE_GITHUB= yes
-GH_ACCOUNT= armon:gometrics,goradix aws:awssdkgo coreos:etcd fatih:structs \
- go-ini:ini go-sql-driver:mysql hashicorp:DEFAULT,consul,consultemplate \
- hashicorp:errwrap,gocleanhttp,gogatedio,gomsgpack \
- hashicorp:gomultierror,gosyslog,gouuid,golanglru,hcl,logutils \
- hashicorp:serf,vault jmespath:gojmespath lib:pq \
- mitchellh:copystructure,iochan,mapstructure,reflectwalk \
- samuel:gozookeeper golang:crypto,net
-GH_PROJECT= go-metrics:gometrics go-radix:goradix aws-sdk-go:awssdkgo \
- etcd:etcd structs:structs ini:ini mysql:mysql consul:consul \
- consul-template:consultemplate errwrap:errwrap \
- go-cleanhttp:gocleanhttp go-gatedio:gogatedio \
- go-msgpack:gomsgpack go-multierror:gomultierror \
- go-syslog:gosyslog go-uuid:gouuid golang-lru:golanglru hcl:hcl \
- logutils:logutils serf:serf vault:vault go-jmespath:gojmespath \
- pq:pq copystructure:copystructure iochan:iochan \
- mapstructure:mapstructure reflectwalk:reflectwalk \
- go-zookeeper:gozookeeper crypto:crypto net:net
-GH_TAGNAME= 6c5fa0d:gometrics fbd82e8:goradix 308eaa6:awssdkgo 6afd8e4:etcd \
- a9f7daa:structs aea5e9f:ini 527bcd5:mysql 809ed36:consul \
- ec11b92:consultemplate c2a1a65:envconsul 7554cd9:errwrap \
- 875fb67:gocleanhttp 8b8de10:gogatedio fa3f638:gomsgpack \
- d30f099:gomultierror 42a2b57:gosyslog 2951e8b:gouuid \
- 17e3543:golanglru 4de5195:hcl 0dc08b1:logutils 8d36400:serf \
- 97820e2:vault bbaa094:gojmespath ffe986a:pq \
- 6fc6626:copystructure 87b45ff:iochan 281073e:mapstructure \
- eecf4c7:reflectwalk 913027e:gozookeeper c8b9e63:crypto \
- 271cfc1:net
+GH_ACCOUNT= hashicorp
+GH_TUPLE= \
+ armon:go-metrics:6c5fa0d:gometrics/src/github.com/armon/go-metrics \
+ armon:go-radix:fbd82e8:goradix/src/github.com/armon/go-radix \
+ aws:aws-sdk-go:308eaa6:awssdkgo/src/github.com/aws/aws-sdk-go \
+ coreos:etcd:6afd8e4:etcd/src/github.com/coreos/etcd \
+ fatih:structs:a9f7daa:structs/src/github.com/fatih/structs \
+ go-ini:ini:aea5e9f:ini/src/github.com/go-ini/ini \
+ go-sql-driver:mysql:527bcd5:mysql/src/github.com/go-sql-driver/mysql \
+ hashicorp:consul:809ed36:consul/src/github.com/hashicorp/consul \
+ hashicorp:consul-template:ec11b92:consultemplate/src/github.com/hashicorp/consul-template \
+ hashicorp:errwrap:7554cd9:errwrap/src/github.com/hashicorp/errwrap \
+ hashicorp:go-cleanhttp:875fb67:gocleanhttp/src/github.com/hashicorp/go-cleanhttp \
+ hashicorp:go-gatedio:8b8de10:gogatedio/src/github.com/hashicorp/go-gatedio \
+ hashicorp:go-msgpack:fa3f638:gomsgpack/src/github.com/hashicorp/go-msgpack \
+ hashicorp:go-multierror:d30f099:gomultierror/src/github.com/hashicorp/go-multierror \
+ hashicorp:go-syslog:42a2b57:gosyslog/src/github.com/hashicorp/go-syslog \
+ hashicorp:go-uuid:2951e8b:gouuid/src/github.com/hashicorp/go-uuid \
+ hashicorp:golang-lru:17e3543:golanglru/src/github.com/hashicorp/golang-lru \
+ hashicorp:hcl:4de5195:hcl/src/github.com/hashicorp/hcl \
+ hashicorp:logutils:0dc08b1:logutils/src/github.com/hashicorp/logutils \
+ hashicorp:serf:8d36400:serf/src/github.com/hashicorp/serf \
+ hashicorp:vault:97820e2:vault/src/github.com/hashicorp/vault \
+ jmespath:go-jmespath:bbaa094:gojmespath/src/github.com/jmespath/go-jmespath \
+ lib:pq:ffe986a:pq/src/github.com/lib/pq \
+ mitchellh:copystructure:6fc6626:copystructure/src/github.com/mitchellh/copystructure \
+ mitchellh:iochan:87b45ff:iochan/src/github.com/mitchellh/iochan \
+ mitchellh:mapstructure:281073e:mapstructure/src/github.com/mitchellh/mapstructure \
+ mitchellh:reflectwalk:eecf4c7:reflectwalk/src/github.com/mitchellh/reflectwalk \
+ samuel:go-zookeeper:913027e:gozookeeper/src/github.com/samuel/go-zookeeper \
+ golang:crypto:c8b9e63:crypto/src/golang.org/x/crypto \
+ golang:net:271cfc1:net/src/golang.org/x/net \
+ hashicorp:envconsul:c2a1a65:envconsul
PLIST_FILES= bin/envconsul
@@ -58,47 +64,6 @@ post-patch:
@${MV} ${WRKSRC}/${src} \
${WRKSRC}/src/github.com/hashicorp/envconsul
.endfor
- @${MKDIR} ${WRKSRC}/src/github.com/armon
- @${MKDIR} ${WRKSRC}/src/github.com/aws
- @${MKDIR} ${WRKSRC}/src/github.com/coreos
- @${MKDIR} ${WRKSRC}/src/github.com/fatih
- @${MKDIR} ${WRKSRC}/src/github.com/go-ini
- @${MKDIR} ${WRKSRC}/src/github.com/go-sql-driver
- @${MKDIR} ${WRKSRC}/src/github.com/jmespath
- @${MKDIR} ${WRKSRC}/src/github.com/lib
- @${MKDIR} ${WRKSRC}/src/github.com/mitchellh
- @${MKDIR} ${WRKSRC}/src/github.com/samuel
- @${MKDIR} ${WRKSRC}/src/golang.org/x
- @${MV} ${WRKSRC_gometrics} ${WRKSRC}/src/github.com/armon/go-metrics
- @${MV} ${WRKSRC_goradix} ${WRKSRC}/src/github.com/armon/go-radix
- @${MV} ${WRKSRC_awssdkgo} ${WRKSRC}/src/github.com/aws/aws-sdk-go
- @${MV} ${WRKSRC_etcd} ${WRKSRC}/src/github.com/coreos/etcd
- @${MV} ${WRKSRC_structs} ${WRKSRC}/src/github.com/fatih/structs
- @${MV} ${WRKSRC_ini} ${WRKSRC}/src/github.com/go-ini/ini
- @${MV} ${WRKSRC_mysql} ${WRKSRC}/src/github.com/go-sql-driver/mysql
- @${MV} ${WRKSRC_consul} ${WRKSRC}/src/github.com/hashicorp/consul
- @${MV} ${WRKSRC_consultemplate} ${WRKSRC}/src/github.com/hashicorp/consul-template
- @${MV} ${WRKSRC_errwrap} ${WRKSRC}/src/github.com/hashicorp/errwrap
- @${MV} ${WRKSRC_gocleanhttp} ${WRKSRC}/src/github.com/hashicorp/go-cleanhttp
- @${MV} ${WRKSRC_gogatedio} ${WRKSRC}/src/github.com/hashicorp/go-gatedio
- @${MV} ${WRKSRC_gomsgpack} ${WRKSRC}/src/github.com/hashicorp/go-msgpack
- @${MV} ${WRKSRC_gomultierror} ${WRKSRC}/src/github.com/hashicorp/go-multierror
- @${MV} ${WRKSRC_gosyslog} ${WRKSRC}/src/github.com/hashicorp/go-syslog
- @${MV} ${WRKSRC_gouuid} ${WRKSRC}/src/github.com/hashicorp/go-uuid
- @${MV} ${WRKSRC_golanglru} ${WRKSRC}/src/github.com/hashicorp/golang-lru
- @${MV} ${WRKSRC_hcl} ${WRKSRC}/src/github.com/hashicorp/hcl
- @${MV} ${WRKSRC_logutils} ${WRKSRC}/src/github.com/hashicorp/logutils
- @${MV} ${WRKSRC_serf} ${WRKSRC}/src/github.com/hashicorp/serf
- @${MV} ${WRKSRC_vault} ${WRKSRC}/src/github.com/hashicorp/vault
- @${MV} ${WRKSRC_gojmespath} ${WRKSRC}/src/github.com/jmespath/go-jmespath
- @${MV} ${WRKSRC_pq} ${WRKSRC}/src/github.com/lib/pq
- @${MV} ${WRKSRC_copystructure} ${WRKSRC}/src/github.com/mitchellh/copystructure
- @${MV} ${WRKSRC_iochan} ${WRKSRC}/src/github.com/mitchellh/iochan
- @${MV} ${WRKSRC_mapstructure} ${WRKSRC}/src/github.com/mitchellh/mapstructure
- @${MV} ${WRKSRC_reflectwalk} ${WRKSRC}/src/github.com/mitchellh/reflectwalk
- @${MV} ${WRKSRC_gozookeeper} ${WRKSRC}/src/github.com/samuel/go-zookeeper
- @${MV} ${WRKSRC_crypto} ${WRKSRC}/src/golang.org/x/crypto
- @${MV} ${WRKSRC_net} ${WRKSRC}/src/golang.org/x/net
do-build:
@cd ${WRKSRC}/src/github.com/hashicorp/envconsul; ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} go build -o bin/envconsul