aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorJuraj Lutter <otis@FreeBSD.org>2020-12-21 15:23:01 +0000
committerJuraj Lutter <otis@FreeBSD.org>2020-12-21 15:23:01 +0000
commitdca4f12df319549650bf8e35aaa8682b896c1d09 (patch)
treefd565c0d2d4bceec53a002502c2c89ea706269cb /sysutils
parentd5822e83e91fc91d05fcc4ad14539104d0859c4b (diff)
downloadports-dca4f12df319549650bf8e35aaa8682b896c1d09.tar.gz
ports-dca4f12df319549650bf8e35aaa8682b896c1d09.zip
sysutils/e2fsprogs: Fix pkg-install
Fix pkg-install script where a closing ']' was missing. Submitted by: Giacomo Olgeni Reviewed by: osa (mentor), mandree Approved by: osa (mentor), mandree Differential Revision: https://reviews.freebsd.org/D27693
Notes
Notes: svn path=/head/; revision=558838
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/e2fsprogs/Makefile2
-rw-r--r--sysutils/e2fsprogs/pkg-install2
2 files changed, 2 insertions, 2 deletions
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index 8be707803f81..5a9ea99bb9ab 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= e2fsprogs
PORTVERSION= 1.45.6
-PORTREVISION?= 4
+PORTREVISION?= 5
CATEGORIES?= sysutils
MASTER_SITES= KERNEL_ORG/linux/kernel/people/tytso/${PORTNAME}/v${PORTVERSION}
diff --git a/sysutils/e2fsprogs/pkg-install b/sysutils/e2fsprogs/pkg-install
index ab1e42d59f23..125148c7bc9c 100644
--- a/sysutils/e2fsprogs/pkg-install
+++ b/sysutils/e2fsprogs/pkg-install
@@ -10,7 +10,7 @@ POST-INSTALL)
# symbolic links by hard links if possible (pkg ships them as symlinks)
d1=${PKG_ROOTDIR}/sbin/ ; dev1=$(stat -Lf %Xd "$d1")
d2=${PKG_ROOTDIR}${PKG_PREFIX}/sbin/ ; dev2=$(stat -Lf %Xd "$d2")
- if [ "$dev1" = "$dev2" ] && [ "$(realpath "$d1")" != "$(realpath "$d2")"; then
+ if [ "$dev1" = "$dev2" ] && [ "$(realpath "$d1")" != "$(realpath "$d2")" ]; then
for i in e2fsck fsck_ext2fs ; do
ln -fhP ${d1}${i} ${d2}${i}
done