aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2021-09-29 10:22:29 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2021-11-09 08:53:49 +0000
commitdfd3f7e23b6a08182b5aebc142685ae8df10485a (patch)
tree1f61ba301deddcfaf5494fa9ad3de9a61aaf7127 /sysutils
parentcb4a79442c93ec652ac85534add6c1609a02948b (diff)
downloadports-dfd3f7e23b6a08182b5aebc142685ae8df10485a.tar.gz
ports-dfd3f7e23b6a08182b5aebc142685ae8df10485a.zip
sysutils/edk2: Remove aarch64-none-elf-gcc on aarch64
We can use the native gcc (from USE_GCC) to build the ports so don't add another build dep.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/edk2/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/sysutils/edk2/Makefile b/sysutils/edk2/Makefile
index 503ff8fe42f7..65152f193e29 100644
--- a/sysutils/edk2/Makefile
+++ b/sysutils/edk2/Makefile
@@ -104,7 +104,9 @@ MAKE_ENV+= WORKSPACE=${WRKDIR} \
PYTHON_COMMAND=python3 \
PYTHONHASHSEED=1
-.if ${PLAT_ARCH} == AARCH64
+.include <bsd.port.pre.mk>
+
+.if ${PLAT_ARCH} == AARCH64 && ${ARCH} != aarch64
BUILD_DEPENDS+= aarch64-none-elf-gcc:devel/aarch64-none-elf-gcc
MAKE_ENV+= GCC5_AARCH64_PREFIX=aarch64-none-elf-
.endif
@@ -131,4 +133,4 @@ do-install:
${MKDIR} ${STAGEDIR}/${PREFIX}/share/${PORTNAME}-${PLAT}/
${INSTALL_DATA} ${WRKDIR}/Build/${PLAT_RESULT} ${STAGEDIR}/${PREFIX}/share/${PORTNAME}-${PLAT}/${PLAT_FILENAME}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>