aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorDonald Burr <dburr@FreeBSD.org>1998-07-15 09:56:31 +0000
committerDonald Burr <dburr@FreeBSD.org>1998-07-15 09:56:31 +0000
commiteea1e4a351981e4fec200116835b55bff6ea09a8 (patch)
tree687a010d7a7e0253f78a8eb08337cbe5ec20cc60 /sysutils
parentc06631a7f2c0c7296d5e636aa549868316d601bb (diff)
downloadports-eea1e4a351981e4fec200116835b55bff6ea09a8.tar.gz
ports-eea1e4a351981e4fec200116835b55bff6ea09a8.zip
Import of new port sysutils/no-login, a replacement for /sbin/nologin
that also logs user login attempts to syslog. [I had to name the directory `no-login' because easy-import complained that there's already a "nologin" module.]
Notes
Notes: svn path=/head/; revision=11922
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/no-login/Makefile31
-rw-r--r--sysutils/no-login/distinfo2
-rw-r--r--sysutils/no-login/pkg-comment1
-rw-r--r--sysutils/no-login/pkg-descr4
-rw-r--r--sysutils/no-login/pkg-plist2
5 files changed, 40 insertions, 0 deletions
diff --git a/sysutils/no-login/Makefile b/sysutils/no-login/Makefile
new file mode 100644
index 000000000000..95ca6479c4f3
--- /dev/null
+++ b/sysutils/no-login/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: nologin
+# Version required: 1.0
+# Date created: 15 Jul 1998
+# Whom: Donald Burr <dburr@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= nologin
+PKGNAME= nologin-1.0
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.xmission.com/pub/users/s/softweyr/pub/
+DISTFILES= nologin.c nologin.8
+
+MAINTAINER= dburr@FreeBSD.ORG
+
+DIST_SUBDIR= nologin
+NO_WRKSUBDIR= YES
+ALL_TARGET= nologin
+
+MAN8= nologin.8
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ for FILE in ${DISTFILES} ; do ${CP} ${DISTDIR}/${DIST_SUBDIR}/$${FILE} ${WRKDIR}/$${FILE} ; done
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKDIR}/nologin ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKDIR}/nologin.8 ${PREFIX}/man/man8
+
+.include <bsd.port.mk>
diff --git a/sysutils/no-login/distinfo b/sysutils/no-login/distinfo
new file mode 100644
index 000000000000..af656860b8de
--- /dev/null
+++ b/sysutils/no-login/distinfo
@@ -0,0 +1,2 @@
+MD5 (nologin/nologin.c) = 2888eccf810cb95a502415659defd298
+MD5 (nologin/nologin.8) = 848f37aaa605581e79e15ce8e9993aff
diff --git a/sysutils/no-login/pkg-comment b/sysutils/no-login/pkg-comment
new file mode 100644
index 000000000000..2c477103b116
--- /dev/null
+++ b/sysutils/no-login/pkg-comment
@@ -0,0 +1 @@
+Refuse a login to a user, and make a note of it in syslog.
diff --git a/sysutils/no-login/pkg-descr b/sysutils/no-login/pkg-descr
new file mode 100644
index 000000000000..5cddf3ee50aa
--- /dev/null
+++ b/sysutils/no-login/pkg-descr
@@ -0,0 +1,4 @@
+This program will refuse login to a user, and make a note of it in the
+system logs (syslog). This is suitable for use as a "login shell" for
+a user that you want to temporarily deny access to. Just set that user's
+shell to /usr/local/sbin/nologin.
diff --git a/sysutils/no-login/pkg-plist b/sysutils/no-login/pkg-plist
new file mode 100644
index 000000000000..bd1bde2bece9
--- /dev/null
+++ b/sysutils/no-login/pkg-plist
@@ -0,0 +1,2 @@
+sbin/nologin
+man/man8/nologin.8.gz