aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-09-10 03:57:12 +0000
committerJohn Marino <marino@FreeBSD.org>2016-09-10 03:57:12 +0000
commitf9d14e1b8241d8b9a2883954716d3e88f2343d04 (patch)
tree5aa4f8d600bc7dd7830d0954440309a08d20a849 /sysutils
parenteadf46628f40c176ca59bf8fa875893dc6197045 (diff)
downloadports-f9d14e1b8241d8b9a2883954716d3e88f2343d04.tar.gz
ports-f9d14e1b8241d8b9a2883954716d3e88f2343d04.zip
sysutils/sbsigntool: document SSL requirement and set flags accordingly
Notes
Notes: svn path=/head/; revision=421657
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/sbsigntool/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/sysutils/sbsigntool/Makefile b/sysutils/sbsigntool/Makefile
index f3aab1a65f9d..fa1321713c78 100644
--- a/sysutils/sbsigntool/Makefile
+++ b/sysutils/sbsigntool/Makefile
@@ -17,18 +17,18 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libgnuefi.a:devel/gnu-efi \
LIB_DEPENDS= libuuid.so:misc/e2fsprogs-libuuid
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
-CONFIGURE_ENV= libcrypto_CFLAGS=-lcrypto libcrypto_LIBS=-lcrypto LOCALBASE=${LOCALBASE} ac_cv_header_bfd_h=yes
-USES= gmake pkgconfig
+CONFIGURE_ENV= libcrypto_CFLAGS=-lcrypto \
+ libcrypto_LIBS=-lcrypto \
+ LOCALBASE=${LOCALBASE} \
+ ac_cv_header_bfd_h=yes
+USES= gmake localbase pkgconfig ssl
+LDFLAGS+= -L${OPENSSLLIB}
+CFLAGS+= -I${OPENSSLINC}
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
-BROKEN= This port works only on FreeBSD 10 and newer
-.endif
+BROKEN_FreeBSD_9= requires FreeBSD 10 or later
post-patch:
@${REINPLACE_CMD} -e 's|<endian.h>|<sys/endian.h>|' ${WRKSRC}/configure ${WRKSRC}/lib/ccan/ccan/hash/hash.c
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>