aboutsummaryrefslogtreecommitdiff
path: root/textproc/UCD
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2016-11-26 21:48:54 +0000
committerThierry Thomas <thierry@FreeBSD.org>2016-11-26 21:48:54 +0000
commitf334a7c6fa06f00541ac25486de9ddf61e6109b3 (patch)
treeb533e6abd1618fc79f10390eb1afd38b49565e7b /textproc/UCD
parent8bd98823ec0b8fa3a5d86e4f9f55e23b31c37ece (diff)
downloadports-f334a7c6fa06f00541ac25486de9ddf61e6109b3.tar.gz
ports-f334a7c6fa06f00541ac25486de9ddf61e6109b3.zip
The Unicode Character Database (UCD) consists of a number of data files listing
Unicode character properties and related data. It also includes data files containing test data for conformance to several important Unicode algorithms. WWW: http://unicode.org/ucd/
Notes
Notes: svn path=/head/; revision=427184
Diffstat (limited to 'textproc/UCD')
-rw-r--r--textproc/UCD/Makefile33
-rw-r--r--textproc/UCD/distinfo5
-rw-r--r--textproc/UCD/pkg-descr5
-rw-r--r--textproc/UCD/pkg-plist62
4 files changed, 105 insertions, 0 deletions
diff --git a/textproc/UCD/Makefile b/textproc/UCD/Makefile
new file mode 100644
index 000000000000..89e37dae24e9
--- /dev/null
+++ b/textproc/UCD/Makefile
@@ -0,0 +1,33 @@
+# Created by: Thierry Thomas <thierry@pompo.net>
+# $FreeBSD$
+
+PORTNAME= UCD
+PORTVERSION= 9.0.0
+CATEGORIES= textproc
+MASTER_SITES= http://www.unicode.org/Public/zipped/${PORTVERSION}/:src\
+ ftp://www.unicode.org/Public/zipped/${PORTVERSION}/:src \
+ http://www.unicode.org/:lic
+DISTFILES= ${PORTNAME}.zip:src \
+ copyright.html:lic
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+EXTRACT_ONLY=
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Unicode Character Database
+
+LICENSE= Unicode_License_Agreement
+LICENSE_NAME= Unicode License Agreement
+LICENSE_FILE= ${_DISTDIR}/copyright.html
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+DATADIR= ${PREFIX}/share/unicode/ucd
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${STAGEDIR}${DATADIR} && \
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/${PORTNAME}.zip ${EXTRACT_AFTER_ARGS})
+
+.include <bsd.port.mk>
diff --git a/textproc/UCD/distinfo b/textproc/UCD/distinfo
new file mode 100644
index 000000000000..0a67e0cfcbfb
--- /dev/null
+++ b/textproc/UCD/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1480192452
+SHA256 (UCD-9.0.0/UCD.zip) = df9e028425816fd5117eaea7173704056f88f7cd030681e457c6f3827f9390ec
+SIZE (UCD-9.0.0/UCD.zip) = 5655592
+SHA256 (UCD-9.0.0/copyright.html) = de57d1cc3cee5a514557ea6e79a09eea5324ac777b9e802bbb6d1da9cca9cd6d
+SIZE (UCD-9.0.0/copyright.html) = 16571
diff --git a/textproc/UCD/pkg-descr b/textproc/UCD/pkg-descr
new file mode 100644
index 000000000000..02ffd1a40dfb
--- /dev/null
+++ b/textproc/UCD/pkg-descr
@@ -0,0 +1,5 @@
+The Unicode Character Database (UCD) consists of a number of data files listing
+Unicode character properties and related data. It also includes data files
+containing test data for conformance to several important Unicode algorithms.
+
+WWW: http://unicode.org/ucd/
diff --git a/textproc/UCD/pkg-plist b/textproc/UCD/pkg-plist
new file mode 100644
index 000000000000..fa8db050aef0
--- /dev/null
+++ b/textproc/UCD/pkg-plist
@@ -0,0 +1,62 @@
+%%DATADIR%%/ArabicShaping.txt
+%%DATADIR%%/BidiBrackets.txt
+%%DATADIR%%/BidiCharacterTest.txt
+%%DATADIR%%/BidiMirroring.txt
+%%DATADIR%%/BidiTest.txt
+%%DATADIR%%/Blocks.txt
+%%DATADIR%%/CJKRadicals.txt
+%%DATADIR%%/CaseFolding.txt
+%%DATADIR%%/CompositionExclusions.txt
+%%DATADIR%%/DerivedAge.txt
+%%DATADIR%%/DerivedCoreProperties.txt
+%%DATADIR%%/DerivedNormalizationProps.txt
+%%DATADIR%%/EastAsianWidth.txt
+%%DATADIR%%/EmojiSources.txt
+%%DATADIR%%/HangulSyllableType.txt
+%%DATADIR%%/Index.txt
+%%DATADIR%%/IndicPositionalCategory.txt
+%%DATADIR%%/IndicSyllabicCategory.txt
+%%DATADIR%%/Jamo.txt
+%%DATADIR%%/LineBreak.txt
+%%DATADIR%%/NameAliases.txt
+%%DATADIR%%/NamedSequences.txt
+%%DATADIR%%/NamedSequencesProv.txt
+%%DATADIR%%/NamesList.html
+%%DATADIR%%/NamesList.txt
+%%DATADIR%%/NormalizationCorrections.txt
+%%DATADIR%%/NormalizationTest.txt
+%%DATADIR%%/PropList.txt
+%%DATADIR%%/PropertyAliases.txt
+%%DATADIR%%/PropertyValueAliases.txt
+%%DATADIR%%/ReadMe.txt
+%%DATADIR%%/ScriptExtensions.txt
+%%DATADIR%%/Scripts.txt
+%%DATADIR%%/SpecialCasing.txt
+%%DATADIR%%/StandardizedVariants.html
+%%DATADIR%%/StandardizedVariants.txt
+%%DATADIR%%/TangutSources.txt
+%%DATADIR%%/USourceData.txt
+%%DATADIR%%/USourceGlyphs.pdf
+%%DATADIR%%/UnicodeData.txt
+%%DATADIR%%/auxiliary/GraphemeBreakProperty.txt
+%%DATADIR%%/auxiliary/GraphemeBreakTest.html
+%%DATADIR%%/auxiliary/GraphemeBreakTest.txt
+%%DATADIR%%/auxiliary/LineBreakTest.html
+%%DATADIR%%/auxiliary/LineBreakTest.txt
+%%DATADIR%%/auxiliary/SentenceBreakProperty.txt
+%%DATADIR%%/auxiliary/SentenceBreakTest.html
+%%DATADIR%%/auxiliary/SentenceBreakTest.txt
+%%DATADIR%%/auxiliary/WordBreakProperty.txt
+%%DATADIR%%/auxiliary/WordBreakTest.html
+%%DATADIR%%/auxiliary/WordBreakTest.txt
+%%DATADIR%%/extracted/DerivedBidiClass.txt
+%%DATADIR%%/extracted/DerivedBinaryProperties.txt
+%%DATADIR%%/extracted/DerivedCombiningClass.txt
+%%DATADIR%%/extracted/DerivedDecompositionType.txt
+%%DATADIR%%/extracted/DerivedEastAsianWidth.txt
+%%DATADIR%%/extracted/DerivedGeneralCategory.txt
+%%DATADIR%%/extracted/DerivedJoiningGroup.txt
+%%DATADIR%%/extracted/DerivedJoiningType.txt
+%%DATADIR%%/extracted/DerivedLineBreak.txt
+%%DATADIR%%/extracted/DerivedNumericType.txt
+%%DATADIR%%/extracted/DerivedNumericValues.txt