aboutsummaryrefslogtreecommitdiff
path: root/textproc/apertium/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2011-01-27 13:41:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2011-01-27 13:41:20 +0000
commit2bccbd69bb5db6eefae4b169fa41d09d3907a9cd (patch)
tree4051f8ee4d8b54654424d860dfa09ebce9d7c644 /textproc/apertium/Makefile
parent10cac0158873136ad76213dd374d7f064a00ed41 (diff)
downloadports-2bccbd69bb5db6eefae4b169fa41d09d3907a9cd.tar.gz
ports-2bccbd69bb5db6eefae4b169fa41d09d3907a9cd.zip
- Update to 3.2.0
PR: ports/154224 Submitted by: Mykola Dzham <i@levsha.me> (maintainer) Feature safe: yes
Notes
Notes: svn path=/head/; revision=268290
Diffstat (limited to 'textproc/apertium/Makefile')
-rw-r--r--textproc/apertium/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/textproc/apertium/Makefile b/textproc/apertium/Makefile
index d6cfa6e61092..7c88f0d58432 100644
--- a/textproc/apertium/Makefile
+++ b/textproc/apertium/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= apertium
-PORTVERSION= 3.1.1
+PORTVERSION= ${APVER}.${APREV}
CATEGORIES= textproc
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/3.1
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${APVER}
MAINTAINER= i@levsha.me
COMMENT= A toolbox to build shallow-transfer machine translation systems
@@ -20,10 +20,18 @@ LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
lttoolbox3:${PORTSDIR}/textproc/lttoolbox \
pcre:${PORTSDIR}/devel/pcre
+APVER= 3.2
+APREV= 0
+
MAKE_JOBS_UNSAFE= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
USE_GNOME= gnomehack pkgconfig
+USE_LDCONFIG= yes
+
+PLIST_SUB+= APVER="${APVER}"
MAN1= apertium-deshtml.1 apertium-desodt.1 apertium-despptx.1 \
apertium-desrtf.1 apertium-destxt.1 apertium-deswxml.1 \
@@ -42,6 +50,6 @@ MAN1= apertium-deshtml.1 apertium-desodt.1 apertium-despptx.1 \
apertium-validate-interchunk.1 apertium-validate-modes.1 \
apertium-validate-postchunk.1 apertium-validate-tagger.1\
apertium-validate-transfer.1 apertium-unformat.1 \
- apertium.1
+ apertium.1 apertium-desmediawiki.1 apertium-remediawiki.1
.include <bsd.port.mk>