aboutsummaryrefslogtreecommitdiff
path: root/textproc/apertium
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-08-31 11:01:04 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-08-31 11:01:04 +0000
commitc4611eed4c1b8d974056a3f46471a4c6419da118 (patch)
tree91cf81b7e9f1055b199f0a59960fd771cdfde5ad /textproc/apertium
parent4b7b75f07610d58373cd7701dd8efe85828693e7 (diff)
downloadports-c4611eed4c1b8d974056a3f46471a4c6419da118.tar.gz
ports-c4611eed4c1b8d974056a3f46471a4c6419da118.zip
textproc/lttoolbox, textproc/apertium: 3.2.0 -> 3.3.0
- lttoolbox -has two new tools: lt-trim and lt-print - apertium has a new deformatter: apertium-deslatex - lextor is deprecated, the code is still there but is not built - apertium has a new m4 macro that supports using language packages from /languages/ PR: 192886
Notes
Notes: svn path=/head/; revision=366744
Diffstat (limited to 'textproc/apertium')
-rw-r--r--textproc/apertium/Makefile22
-rw-r--r--textproc/apertium/distinfo4
-rw-r--r--textproc/apertium/files/patch-apertium__hmm.cc80
-rw-r--r--textproc/apertium/files/patch-apertium__lextor.cc47
-rw-r--r--textproc/apertium/pkg-plist36
5 files changed, 31 insertions, 158 deletions
diff --git a/textproc/apertium/Makefile b/textproc/apertium/Makefile
index 8cd70a5fc4a3..533b38b15637 100644
--- a/textproc/apertium/Makefile
+++ b/textproc/apertium/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= apertium
-PORTVERSION= 3.2.0
-PORTREVISION= 4
+PORTVERSION= 3.3.0
CATEGORIES= textproc
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}
@@ -13,11 +12,11 @@ COMMENT= Toolbox to build shallow-transfer machine translation systems
LICENSE= GPLv2 # (or later)
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
-LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre \
- liblttoolbox3.so:${PORTSDIR}/textproc/lttoolbox
+LIB_DEPENDS= liblttoolbox3.so:${PORTSDIR}/textproc/lttoolbox \
+ libpcre.so:${PORTSDIR}/devel/pcre
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
-USES= libtool pathfix pkgconfig
+USES= pathfix pkgconfig libtool
USE_GNOME= libxml2 libxslt
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -30,16 +29,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= APVER="${PORTVERSION:R}"
post-patch:
- @${REINPLACE_CMD} -e \
- 's| -ansi | | ; \
- s| -march=.* | | ; \
- s| -mtune=.* | | ; \
- s| -O3 | | ; \
- s|pcre_info|pcre_fullinfo|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
- 's|\([[:blank:]]\)\($$(modesdir)\)|\1$$(DESTDIR)\2|' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e \
- 's|_C_|_H_|' ${WRKSRC}/apertium/tmx_aligner_tool.h
+
+ @${REINPLACE_CMD} -e 's/pcre_info/pcre_fullinfo/g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/textproc/apertium/distinfo b/textproc/apertium/distinfo
index 9eced9f91e5b..659c75c1b80b 100644
--- a/textproc/apertium/distinfo
+++ b/textproc/apertium/distinfo
@@ -1,2 +1,2 @@
-SHA256 (apertium-3.2.0.tar.gz) = 6ce2fdc85da5d1e50d69da2e50cc97a87b689476f2c83417765636d9a4b7e9ac
-SIZE (apertium-3.2.0.tar.gz) = 767311
+SHA256 (apertium-3.3.0.tar.gz) = 9c2ff5b4f3cb99cd1b2f09c585fd86469ad32fb9d651ccd5c25c1848eca55a0d
+SIZE (apertium-3.3.0.tar.gz) = 1100389
diff --git a/textproc/apertium/files/patch-apertium__hmm.cc b/textproc/apertium/files/patch-apertium__hmm.cc
deleted file mode 100644
index 7059b053f305..000000000000
--- a/textproc/apertium/files/patch-apertium__hmm.cc
+++ /dev/null
@@ -1,80 +0,0 @@
---- apertium/hmm.cc.orig
-+++ apertium/hmm.cc
-@@ -141,7 +141,7 @@
- int N = td->getN();
- int M = td->getM();
- int i, j, k, k1, k2, nw=0;
--#ifdef __GNUC__
-+#if defined(__GNUC__) && !defined(__clang__)
- double classes_ocurrences[M]; //M = Number of ambiguity classes
- double classes_pair_ocurrences[M][M];
- double tags_estimate[N]; //N = Number of tags (states)
-@@ -159,7 +159,7 @@
-
- TaggerWord *word=NULL;
-
--#ifdef __GNUC__
-+#if defined(__GNUC__) && !defined(__clang__)
- for(k=0; k<M; k++) {
- classes_ocurrences[k]=1;
- for (k2=0; k2<M; k2++)
-@@ -204,7 +204,7 @@
-
- //Estimation of the number of time each tags occurs in the training text
- for(i=0; i<N; i++) {
--#ifdef __GNUC__
-+#if defined(__GNUC__) && !defined(__clang__)
- tags_estimate[i]=0;
- #endif
- for(k=0; k<M; k++) {
-@@ -214,7 +214,7 @@
- }
- }
-
--#ifdef __GNUC__
-+#if defined(__GNUC__) && !defined(__clang__)
- //Estimation of the number of times each tag pair occurs
- for(i=0; i<N; i++)
- for(j=0; j<N; j++)
-@@ -270,7 +270,7 @@
- int i, j, k, nw=0;
- int N = td->getN();
- int M = td->getM();
--#ifdef __GNUC__
-+#if defined(__GNUC__) && !defined(__clang__)
- double tags_pair[N][N];
- double emission[N][M];
- #else
-@@ -288,7 +288,7 @@
-
- set<TTag> tags;
-
--#ifdef __GNUC__
-+#if defined(__GNUC__) && !defined(__clang__)
- // Init counters - each event appears at least once.
- // Espected likelihood estimate (ELE) with a fixed initial count of 1
- for(i=0; i<N; i++) {
-@@ -750,12 +750,12 @@
-
- double prob, loli, x;
- int N = td->getN();
--#ifdef __GNUC__
-+#if defined(__GNUC__) && !defined(__clang__)
- double alpha[2][N];
- vector<TTag> best[2][N];
- #else
- vector <vector <double> > alpha(2, vector<double>(N));
-- vector <vector <vector<TTag>> > best(2, vector<vector<TTag>>(N));
-+ vector <vector <vector<TTag> > > best(2, vector<vector<TTag> >(N));
- #endif
-
- vector <TaggerWord> wpend;
-@@ -799,7 +799,7 @@
-
- k = output[tags]; //Ambiguity class the word belongs to
-
--#ifdef __GNUC__
-+#if defined(__GNUC__) && !defined(__clang__)
- clear_array_double(alpha[nwpend%2], N);
- clear_array_vector(best[nwpend%2], N);
- #endif
diff --git a/textproc/apertium/files/patch-apertium__lextor.cc b/textproc/apertium/files/patch-apertium__lextor.cc
deleted file mode 100644
index 402138515133..000000000000
--- a/textproc/apertium/files/patch-apertium__lextor.cc
+++ /dev/null
@@ -1,47 +0,0 @@
---- apertium/lextor.cc.orig
-+++ apertium/lextor.cc
-@@ -277,7 +277,7 @@
- //Note: Words in the context can also be ambiguous (with more than one lexical choice)
- //In that case the count will come from all the possible
- //translations
--#ifdef __GNUC__
-+#if defined(__GNUC__) && !defined(__clang__)
- vector<wstring> translation_buffer[buffer_max_size];
- wstring reduced_buffer[buffer_max_size];
- #else
-@@ -340,7 +340,7 @@
- //The counts of the TL co-occurrence model are transferred to the SL. If the SL word is ambiguous
- //it will have more than one translation into TL, so we need to normalize using the frequency of words
- //in the TL
--#ifdef __GNUC__
-+#if defined(__GNUC__) && !defined(__clang__)
- double translation_weighs[translation_buffer[i].size()];
- #else
- vector <double> translation_weighs(translation_buffer[i].size());
-@@ -686,7 +686,7 @@
-
- int
- LexTor::estimate_winner_lch_voting(deque<LexTorWord>& window, int word_index, double weigth_exponent) {
--#ifdef __GNUC__
-+#if defined(__GNUC__) && !defined(__clang__)
- double lexchoices_count[window[word_index].n_lexical_choices()];
- #else
- vector <double> lexchoices_count(window[word_index].n_lexical_choices());
-@@ -879,7 +879,7 @@
- exit(EXIT_FAILURE);
- }
-
--#ifdef __GNUC__
-+#if defined(__GNUC__) && !defined(__clang__)
- double lexchoices_count[window[word_index].n_lexical_choices()];
- vector<wstring> translation_window[window.size()];
- wstring reduced_window[window.size()];
-@@ -935,7 +935,7 @@
- //If the SL word is ambiguous it will have more than one
- //translation into TL, so we need to normalize using the
- //frequency of words in the TL
--#ifdef __GNUC__
-+#if defined(__GNUC__) && !defined(__clang__)
- double translation_weighs[translation_window[k].size()];
- #else
- vector <double> translation_weighs(translation_window[k].size());
diff --git a/textproc/apertium/pkg-plist b/textproc/apertium/pkg-plist
index 97480252b850..f22304d4690c 100644
--- a/textproc/apertium/pkg-plist
+++ b/textproc/apertium/pkg-plist
@@ -1,5 +1,6 @@
bin/apertium
bin/apertium-deshtml
+bin/apertium-deslatex
bin/apertium-desmediawiki
bin/apertium-desodt
bin/apertium-despptx
@@ -10,21 +11,19 @@ bin/apertium-desxlsx
bin/apertium-desxpresstag
bin/apertium-filter-ambiguity
bin/apertium-gen-deformat
-bin/apertium-gen-lextorbil
-bin/apertium-gen-lextormono
bin/apertium-gen-modes
bin/apertium-gen-reformat
-bin/apertium-gen-stopwords-lextor
-bin/apertium-gen-wlist-lextor
-bin/apertium-gen-wlist-lextor-translation
bin/apertium-interchunk
-bin/apertium-lextor
bin/apertium-multiple-translations
+bin/apertium-prelatex
bin/apertium-postchunk
-bin/apertium-preprocess-corpus-lextor
+bin/apertium-postlatex
+bin/apertium-postlatex-raw
bin/apertium-preprocess-transfer
bin/apertium-pretransfer
bin/apertium-rehtml
+bin/apertium-rehtml-noent
+bin/apertium-relatex
bin/apertium-remediawiki
bin/apertium-reodt
bin/apertium-repptx
@@ -35,9 +34,11 @@ bin/apertium-rexlsx
bin/apertium-rexpresstag
bin/apertium-tagger
bin/apertium-tagger-apply-new-rules
+bin/apertium-tagger-readwords
bin/apertium-tmxbuild
bin/apertium-transfer
bin/apertium-unformat
+bin/apertium-utils-fixlatex
bin/apertium-validate-acx
bin/apertium-validate-dictionary
bin/apertium-validate-interchunk
@@ -52,15 +53,19 @@ include/apertium-%%APVER%%/apertium/endian_double_util.h
include/apertium-%%APVER%%/apertium/hmm.h
include/apertium-%%APVER%%/apertium/interchunk.h
include/apertium-%%APVER%%/apertium/interchunk_word.h
+include/apertium-%%APVER%%/apertium/latex_accentsmap.h
include/apertium-%%APVER%%/apertium/lextor.h
include/apertium-%%APVER%%/apertium/lextor_data.h
include/apertium-%%APVER%%/apertium/lextor_eval.h
include/apertium-%%APVER%%/apertium/lextor_word.h
+include/apertium-%%APVER%%/apertium/lswpost.h
include/apertium-%%APVER%%/apertium/morpho_stream.h
include/apertium-%%APVER%%/apertium/postchunk.h
include/apertium-%%APVER%%/apertium/string_utils.h
include/apertium-%%APVER%%/apertium/tagger.h
include/apertium-%%APVER%%/apertium/tagger_data.h
+include/apertium-%%APVER%%/apertium/tagger_data_hmm.h
+include/apertium-%%APVER%%/apertium/tagger_data_lsw.h
include/apertium-%%APVER%%/apertium/tagger_utils.h
include/apertium-%%APVER%%/apertium/tagger_word.h
include/apertium-%%APVER%%/apertium/tmx_align_parameters.h
@@ -93,9 +98,9 @@ lib/libapertium3-%%APVER%%.so.0
lib/libapertium3-%%APVER%%.so.0.0.0
lib/libapertium3.a
lib/libapertium3.so
-libdata/pkgconfig/apertium-%%APVER%%.pc
-man/man1/apertium.1.gz
+libdata/pkgconfig/apertium.pc
man/man1/apertium-deshtml.1.gz
+man/man1/apertium-deslatex.1.gz
man/man1/apertium-desmediawiki.1.gz
man/man1/apertium-desodt.1.gz
man/man1/apertium-despptx.1.gz
@@ -116,10 +121,14 @@ man/man1/apertium-interchunk.1.gz
man/man1/apertium-lextor.1.gz
man/man1/apertium-multiple-translations.1.gz
man/man1/apertium-postchunk.1.gz
+man/man1/apertium-postlatex-raw.1.gz
+man/man1/apertium-postlatex.1.gz
+man/man1/apertium-prelatex.1.gz
man/man1/apertium-preprocess-corpus-lextor.1.gz
man/man1/apertium-preprocess-transfer.1.gz
man/man1/apertium-pretransfer.1.gz
man/man1/apertium-rehtml.1.gz
+man/man1/apertium-relatex.1.gz
man/man1/apertium-remediawiki.1.gz
man/man1/apertium-reodt.1.gz
man/man1/apertium-repptx.1.gz
@@ -131,6 +140,7 @@ man/man1/apertium-tagger-apply-new-rules.1.gz
man/man1/apertium-tagger.1.gz
man/man1/apertium-transfer.1.gz
man/man1/apertium-unformat.1.gz
+man/man1/apertium-utils-fixlatex.1.gz
man/man1/apertium-validate-acx.1.gz
man/man1/apertium-validate-dictionary.1.gz
man/man1/apertium-validate-interchunk.1.gz
@@ -138,10 +148,10 @@ man/man1/apertium-validate-modes.1.gz
man/man1/apertium-validate-postchunk.1.gz
man/man1/apertium-validate-tagger.1.gz
man/man1/apertium-validate-transfer.1.gz
-%%DATADIR%%/acx.rng
+man/man1/apertium.1.gz
+share/aclocal/apertium.m4
%%DATADIR%%/apertium-createmodes.awk
%%DATADIR%%/deformat.xsl
-%%DATADIR%%/dix.dtd
%%DATADIR%%/format.dtd
%%DATADIR%%/interchunk.dtd
%%DATADIR%%/lexchoice.xsl
@@ -154,7 +164,7 @@ man/man1/apertium-validate-transfer.1.gz
%%DATADIR%%/reformat.xsl
%%DATADIR%%/tagger.dtd
%%DATADIR%%/transfer.dtd
-@dirrm %%DATADIR%%/modes
-@dirrm %%DATADIR%%
@dirrm include/apertium-%%APVER%%/apertium
@dirrm include/apertium-%%APVER%%
+@dirrm %%DATADIR%%/modes
+@dirrm %%DATADIR%%