aboutsummaryrefslogtreecommitdiff
path: root/textproc/aspell/Makefile.inc
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-07-15 14:28:44 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-07-15 14:28:44 +0000
commit8d1905f7041773dd6073d984f6e6ccd1d712e712 (patch)
tree8893373dbfdaaedace71935e09ae9fb483090676 /textproc/aspell/Makefile.inc
parent2fdadf42a218b825a5a2242f3e99367dbffa612b (diff)
downloadports-8d1905f7041773dd6073d984f6e6ccd1d712e712.tar.gz
ports-8d1905f7041773dd6073d984f6e6ccd1d712e712.zip
All dictionaries can be installed separately:
- by default, textproc/aspell installs the English dictionaries (no change); - thereafter you can install any foreign dictionary; - when you install a foreign dictionary, i.e. french/aspell or textproc/da-aspell, it installs only the dictionaries, and depends upon textproc/aspell for the programs; - if you don't need the English dictionaries, you can define WITHOUT_DICTEN or install textproc/aspell-without-dicten; - add a new port for textproc/en-aspell: if aspell had been installed without the English dictionaries, they can be added thereafter; - add a missing port for german/alt-aspell; - foreign dictionaries are almost independent from textproc/aspell, and their maintainership is available. Credits: special thanks to Serge Gagnon <ser_gagnon (at) sympatico.ca>
Notes
Notes: svn path=/head/; revision=167900
Diffstat (limited to 'textproc/aspell/Makefile.inc')
-rw-r--r--textproc/aspell/Makefile.inc23
1 files changed, 23 insertions, 0 deletions
diff --git a/textproc/aspell/Makefile.inc b/textproc/aspell/Makefile.inc
new file mode 100644
index 000000000000..eacbbf1e86bb
--- /dev/null
+++ b/textproc/aspell/Makefile.inc
@@ -0,0 +1,23 @@
+# $FreeBSD$
+# To be included by dictionaries ports.
+
+MASTER_SITES?= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR?= aspell/dict/${DICT}
+DISTNAME?= aspell${DISTVERSION}
+
+.if ${PORTNAME} == "en-aspell" || defined(WITHOUT_DICTEN)
+LIB_DEPENDS= aspell:${PORTSDIR}/textproc/aspell-without-dicten
+.else
+LIB_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
+.endif
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+
+PLIST_SUB= VER=${VER}
+
+.include <bsd.port.pre.mk>
+.if exists(${LOCALBASE}/etc/aspell.ver)
+. include "${LOCALBASE}/etc/aspell.ver"
+.endif