aboutsummaryrefslogtreecommitdiff
path: root/textproc/bat/Makefile
diff options
context:
space:
mode:
authorLuca Pizzamiglio <pizzamig@FreeBSD.org>2022-03-02 13:42:39 +0000
committerLuca Pizzamiglio <pizzamig@FreeBSD.org>2022-03-02 13:42:39 +0000
commit758766537152830ec785ebe4c7bf6d3a5250732b (patch)
treec5a9073f7f9a22a4344605038243b28a2d13cc00 /textproc/bat/Makefile
parentbfacd10e33090f9b779ec7333d981aac0d70dc15 (diff)
downloadports-758766537152830ec785ebe4c7bf6d3a5250732b.tar.gz
ports-758766537152830ec785ebe4c7bf6d3a5250732b.zip
textproc/bat: Update to 0.20.0
Diffstat (limited to 'textproc/bat/Makefile')
-rw-r--r--textproc/bat/Makefile23
1 files changed, 11 insertions, 12 deletions
diff --git a/textproc/bat/Makefile b/textproc/bat/Makefile
index 7d327ef8a9d1..0630fb886342 100644
--- a/textproc/bat/Makefile
+++ b/textproc/bat/Makefile
@@ -1,7 +1,7 @@
PORTNAME= bat
DISTVERSIONPREFIX= v
-DISTVERSION= 0.19.0
-PORTREVISION= 2
+DISTVERSION= 0.20.0
+PORTREVISION= 0
CATEGORIES= textproc
MAINTAINER= pizzamig@FreeBSD.org
@@ -23,9 +23,9 @@ PLIST_FILES= bin/bat \
CARGO_CRATES= adler-1.0.2 \
aho-corasick-0.7.18 \
- ansi_colours-1.0.4 \
+ ansi_colours-1.1.1 \
ansi_term-0.12.1 \
- assert_cmd-2.0.2 \
+ assert_cmd-2.0.4 \
atty-0.2.14 \
autocfg-1.0.1 \
base64-0.13.0 \
@@ -35,6 +35,8 @@ CARGO_CRATES= adler-1.0.2 \
bitflags-1.3.2 \
bstr-0.2.17 \
bugreport-0.4.1 \
+ bytemuck-1.7.3 \
+ bytesize-1.1.0 \
cc-1.0.72 \
cfg-if-1.0.0 \
clap-2.34.0 \
@@ -56,6 +58,7 @@ CARGO_CRATES= adler-1.0.2 \
encoding-index-tradchinese-1.20141219.5 \
encoding_index_tests-0.1.4 \
fancy-regex-0.7.1 \
+ fastrand-1.7.0 \
flate2-1.0.22 \
float-cmp-0.9.0 \
fnv-1.0.7 \
@@ -101,30 +104,26 @@ CARGO_CRATES= adler-1.0.2 \
percent-encoding-2.1.0 \
pkg-config-0.3.24 \
plist-1.3.1 \
- ppv-lite86-0.2.16 \
predicates-2.1.0 \
predicates-core-1.0.2 \
predicates-tree-1.0.4 \
proc-macro-hack-0.5.19 \
proc-macro2-1.0.36 \
quote-1.0.14 \
- rand-0.8.4 \
- rand_chacha-0.3.1 \
- rand_core-0.6.3 \
- rand_hc-0.3.1 \
redox_syscall-0.2.10 \
redox_users-0.4.0 \
regex-1.5.4 \
regex-automata-0.1.10 \
regex-syntax-0.6.25 \
remove_dir_all-0.5.3 \
+ rgb-0.8.31 \
ryu-1.0.9 \
safemem-0.3.3 \
same-file-1.0.6 \
scopeguard-1.1.0 \
semver-1.0.4 \
- serde-1.0.133 \
- serde_derive-1.0.133 \
+ serde-1.0.136 \
+ serde_derive-1.0.136 \
serde_json-1.0.74 \
serde_yaml-0.8.23 \
serial_test-0.5.1 \
@@ -137,7 +136,7 @@ CARGO_CRATES= adler-1.0.2 \
syn-1.0.85 \
syntect-4.6.0 \
sys-info-0.9.1 \
- tempfile-3.2.0 \
+ tempfile-3.3.0 \
term_size-0.3.2 \
termcolor-1.1.2 \
terminal_size-0.1.17 \