aboutsummaryrefslogtreecommitdiff
path: root/textproc/bsdsort
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-11-22 19:24:06 +0000
committerJohn Marino <marino@FreeBSD.org>2014-11-22 19:24:06 +0000
commitaf9e7689c66234a1102b98d104c5899f8e17917e (patch)
tree216e8d70d5fca9b57ab433bbf6def21259fa8db0 /textproc/bsdsort
parent7493532a0fc4ff970e2133b4f93c19a014457eaf (diff)
downloadports-af9e7689c66234a1102b98d104c5899f8e17917e.tar.gz
ports-af9e7689c66234a1102b98d104c5899f8e17917e.zip
textproc/bsdsort: Fix install error, remove OVERWRITE_BASE option
This port was using pkg-plist tricks to install install symlinks in a post-install phase. These were now needed due to how pkg works. However, between the complication added by overwriting base and the general trend to frown on such days, I just removed the option entirely. I also moved the now much shorter plist into the Makefile. PR: 194814 Submitted by: lidl (pix.net) Fixed by: marino
Notes
Notes: svn path=/head/; revision=373093
Diffstat (limited to 'textproc/bsdsort')
-rw-r--r--textproc/bsdsort/Makefile21
-rw-r--r--textproc/bsdsort/pkg-plist9
2 files changed, 9 insertions, 21 deletions
diff --git a/textproc/bsdsort/Makefile b/textproc/bsdsort/Makefile
index f2a8538d5324..7fbb274a503f 100644
--- a/textproc/bsdsort/Makefile
+++ b/textproc/bsdsort/Makefile
@@ -24,24 +24,21 @@ USES= uidfix
CFLAGS+= -std=c99
-OPTIONS_DEFINE= THREADS NLS OVERWRITE_BASE
-OVERWRITE_BASE_DESC= Replace base GNU sort
+PLIST_FILES= bin/sort \
+ bin/bsdsort \
+ bin/gnusort \
+ man/man1/sort.1.gz
+
+OPTIONS_DEFINE= THREADS NLS
OPTIONS_DEFAULT= THREADS NLS
OPTIONS_SUB= yes
NLS_MAKE_ENV_OFF= WITHOUT_NLS=yes
+NLS_PLIST_FILES= share/nls/hu_HU.ISO8859-2/sort.cat
THREADS_MAKE_ENV= WITH_THREADS=yes
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MOVERWRITE_BASE}
-PREFIX= /usr
-.endif
-
post-install:
- ${LN} -s ${PREFIX}/bin/sort ${STAGEDIR}${PREFIX}/bin/bsdsort
-.if empty(OVERWRITE_BASE)
+ (cd ${STAGEDIR}${PREFIX}/bin && ${LN} -s sort bsdsort)
${LN} -s /usr/bin/sort ${STAGEDIR}${PREFIX}/bin/gnusort
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/bsdsort/pkg-plist b/textproc/bsdsort/pkg-plist
deleted file mode 100644
index e57595067d52..000000000000
--- a/textproc/bsdsort/pkg-plist
+++ /dev/null
@@ -1,9 +0,0 @@
-@exec /bin/ln -s %%PREFIX%%/bin/sort %%PREFIX%%/bin/bsdsort
-%%NO_OVERWRITE_BASE%%@exec /bin/ln -s /usr/bin/sort %%PREFIX%%/bin/gnusort
-%%OVERWRITE_BASE%%@exec /bin/mv %%PREFIX%%/bin/sort %%PREFIX%%/bin/gnusort || true
-%%OVERWRITE_BASE%%@unexec /bin/cp %%PREFIX%%/bin/gnusort %%PREFIX%%/bin/sort || true
-bin/bsdsort
-bin/gnusort
-man/man1/sort.1.gz
-%%NO_OVERWRITE_BASE%%bin/sort
-%%NLS%%share/nls/hu_HU.ISO8859-2/sort.cat