aboutsummaryrefslogtreecommitdiff
path: root/textproc/catdoc
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-03-20 13:53:47 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-03-20 13:53:47 +0000
commit2c3fca5551f9be672a086926828b78c09423b0b5 (patch)
tree29d76ebec357cc64f598495d3681a30c66e4e176 /textproc/catdoc
parent7b0af36d4d8f85e074ee7bbe6e7ebbf06f877e6f (diff)
downloadports-2c3fca5551f9be672a086926828b78c09423b0b5.tar.gz
ports-2c3fca5551f9be672a086926828b78c09423b0b5.zip
- Update checksum (looks like several bugs were fixed and distfile rerolled
without version bump), bump PORTVERSION. While I'm here: - Respect CFLAGS; - if tk8{0,1,2,3} is installed then make it a dependency. Submitted by: bento (checksum)
Notes
Notes: svn path=/head/; revision=40107
Diffstat (limited to 'textproc/catdoc')
-rw-r--r--textproc/catdoc/Makefile22
-rw-r--r--textproc/catdoc/distinfo2
-rw-r--r--textproc/catdoc/files/patch-ac10
-rw-r--r--textproc/catdoc/files/patch-src::Makefile.in23
4 files changed, 35 insertions, 22 deletions
diff --git a/textproc/catdoc/Makefile b/textproc/catdoc/Makefile
index a195f7d43c73..649557062f40 100644
--- a/textproc/catdoc/Makefile
+++ b/textproc/catdoc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= catdoc
PORTVERSION= 0.91.4
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_TEX_CTAN} \
ftp://ftp.ice.ru/pub/vitus/
@@ -14,22 +15,21 @@ MASTER_SITE_SUBDIR= support/catdoc
MAINTAINER= brion@queeg.com
-WRKSRC= ${WRKDIR}/catdoc
-
GNU_CONFIGURE= yes
MAN1= catdoc.1 xls2csv.1
-.if exists(${PREFIX}/bin/wish8.0)
-CONFIGURE_ARGS+= --with-wish=${PREFIX}/bin/wish8.0
-.elseif exists(${PREFIX}/bin/wish8.1)
-CONFIGURE_ARGS+= --with-wish=${PREFIX}/bin/wish8.1
-.else
-CONFIGURE_ARGS+= --disable-wordview
-.endif
-
.if !defined(LANG) || ${LANG} != ru_RU.KOI8-R
# Remove the below line to get Cyrillic code page support instead
CFLAGS+= -DLATIN1=1
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.for i in 0 1 2 3
+.if exists(${LOCALBASE}/bin/wish8.${i})
+CONFIGURE_ARGS= --with-wish=${LOCALBASE}/bin/wish8.${i}
+RUN_DEPENDS= ${LOCALBASE}/bin/wish8.${i}:${PORTSDIR}/x11-toolkits/tk8${i}
+.endif
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/textproc/catdoc/distinfo b/textproc/catdoc/distinfo
index 5135cad55f48..52c117c9ecd6 100644
--- a/textproc/catdoc/distinfo
+++ b/textproc/catdoc/distinfo
@@ -1 +1 @@
-MD5 (catdoc-0.91.4.tar.gz) = bfc146724ad45ba1287eb5466882670a
+MD5 (catdoc-0.91.4.tar.gz) = 7ca7feaea0fe3d047eaa3d9aa3d467d1
diff --git a/textproc/catdoc/files/patch-ac b/textproc/catdoc/files/patch-ac
deleted file mode 100644
index 56e8db82dcf7..000000000000
--- a/textproc/catdoc/files/patch-ac
+++ /dev/null
@@ -1,10 +0,0 @@
---- ../catdoc/doc/Makefile.in Tue Oct 19 14:50:02 1999
-+++ doc/Makefile.in Fri Sep 8 14:42:09 2000
-@@ -21,6 +21,7 @@
- install: catdoc.1 xls2csv.1
- ../mkinstalldirs $(installroot)$(mandir)
- $(INSTALL) -m 644 catdoc.1 $(installroot)$(mandir)/catdoc$(manext)
-+ $(INSTALL) -m 644 xls2csv.1 $(installroot)$(mandir)/xls2csv$(manext)
- # Following rules are primarily for developers use. I doubt that you
- # need to rebuild these versions of documentation
- distclean: catdoc.1 catdoc.txt catdoc.ps xls2csv.1 xls2csv.txt xls2csv.ps
diff --git a/textproc/catdoc/files/patch-src::Makefile.in b/textproc/catdoc/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..668f6fceb7e5
--- /dev/null
+++ b/textproc/catdoc/files/patch-src::Makefile.in
@@ -0,0 +1,23 @@
+
+$FreeBSD$
+
+--- src/Makefile.in.orig Thu Dec 30 16:24:35 1999
++++ src/Makefile.in Tue Mar 20 15:36:35 2001
+@@ -18,7 +18,7 @@
+ install_targets = @installtargets@
+ # Flags to pass to your C compilier
+ # remove -O2 on HP/UX 9. It is known to cause problems
+-FLAGS=-Wall -O2 -g
++#FLAGS=-Wall -O2 -g
+
+ #Compile-time configuration of catdoc itself. Edit according to taste
+
+@@ -61,7 +61,7 @@
+ -DREPL_EXT=\"$(REPL_EXT)\" -DUNKNOWN_CHAR=\'$(UNKNOWN_CHAR)\'\
+ -DSOURCE_CHARSET=\"$(SOURCE_CHARSET)\" -DTARGET_CHARSET=\"$(TARGET_CHARSET)\"
+
+-CFLAGS=$(FLAGS) $(DEFINES) @DEFS@
++CFLAGS=$(FLAGS) $(DEFINES) @DEFS@ @CFLAGS@
+ OBJ=catdoc.o charsets.o substmap.o reader.o writer.o fileutil.o\
+ confutil.o analyze.o rtfreader.o
+