aboutsummaryrefslogtreecommitdiff
path: root/textproc/cdif/Makefile
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2017-04-01 08:55:16 +0000
committerHiroki Sato <hrs@FreeBSD.org>2017-04-01 08:55:16 +0000
commit3e6d065642c2f9770eeabe4475b21774489c14b8 (patch)
tree49c64eb331d457a4e7a08564c5f5109b67d06572 /textproc/cdif/Makefile
parent2a336dca48c092a5436faff69cbf6c4bc321e7ff (diff)
downloadports-3e6d065642c2f9770eeabe4475b21774489c14b8.tar.gz
ports-3e6d065642c2f9770eeabe4475b21774489c14b8.zip
Update to a snapshot as of 2017/04/01.
Notes
Notes: svn path=/head/; revision=437399
Diffstat (limited to 'textproc/cdif/Makefile')
-rw-r--r--textproc/cdif/Makefile36
1 files changed, 22 insertions, 14 deletions
diff --git a/textproc/cdif/Makefile b/textproc/cdif/Makefile
index bf30289bdc6d..b0c3c36d1a51 100644
--- a/textproc/cdif/Makefile
+++ b/textproc/cdif/Makefile
@@ -1,27 +1,35 @@
# Created by: Yoshiro MIHIRA <sanpei@sanpei.org>
# $FreeBSD$
-PORTNAME= cdif
-PORTVERSION= 1.19
-CATEGORIES= textproc
-MASTER_SITES= LOCAL/sanpei
-EXTRACT_SUFX= # empty
+PORTNAME= cdif
+PORTVERSION= 2.14.20170401
+DISTVERSIONPREFIX= v
+CATEGORIES= textproc
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Word context diff
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Word context visualizer of DIFF output
-USES= perl5 shebangfix
-SHEBANG_FILES= ${DISTNAME}
+LICENSE= GREPLE
+LICENSE_NAME= GREPLE License
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-NO_WRKSUBDIR= yes
-NO_BUILD= yes
+RUN_DEPENDS= ${SITE_PERL}/Getopt/EX.pm:devel/p5-Getopt-EX
+USES= perl5 shebangfix
+SHEBANG_FILES= ${PORTNAME}
+USE_GITHUB= yes
+GH_ACCOUNT= kaz-utashiro
+GH_TAGNAME= 2f4de90
+NO_BUILD= yes
+NO_ARCH= yes
PLIST_FILES= bin/cdif
-do-extract:
- ${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}/${DISTNAME}
+post-extract:
+ cd ${WRKSRC} && \
+ ${SED} -n "/^# COPYRIGHT/,//p" README.md > LICENSE
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${STAGEDIR}${PREFIX}/bin/cdif
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/cdif
.include <bsd.port.mk>