aboutsummaryrefslogtreecommitdiff
path: root/textproc/consul-template
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2016-08-10 15:31:45 +0000
committerSteve Wills <swills@FreeBSD.org>2016-08-10 15:31:45 +0000
commit5a7483b4229e3e109ad53349e9ce6abaaafeca16 (patch)
tree34d5d5e1532cf92d892455e633d9d50288c37555 /textproc/consul-template
parent4abdcf3da9b76336aaebc33f49937019676e42a9 (diff)
downloadports-5a7483b4229e3e109ad53349e9ce6abaaafeca16.tar.gz
ports-5a7483b4229e3e109ad53349e9ce6abaaafeca16.zip
textproc/consul-template: Update to 0.15.0 and add rc.d script
PR: 211492 Submitted by: Douglas Thrift <douglas@douglasthrift.net>
Notes
Notes: svn path=/head/; revision=420033
Diffstat (limited to 'textproc/consul-template')
-rw-r--r--textproc/consul-template/Makefile18
-rw-r--r--textproc/consul-template/distinfo6
-rw-r--r--textproc/consul-template/files/consul-template.in50
3 files changed, 64 insertions, 10 deletions
diff --git a/textproc/consul-template/Makefile b/textproc/consul-template/Makefile
index 3d8b3e450fdc..30b9170f10cb 100644
--- a/textproc/consul-template/Makefile
+++ b/textproc/consul-template/Makefile
@@ -2,13 +2,15 @@
# $FreeBSD$
PORTNAME= consul-template
-PORTVERSION= 0.14.0
+PORTVERSION= 0.15.0
DISTVERSIONPREFIX= v
CATEGORIES= textproc
MAINTAINER= swills@FreeBSD.org
COMMENT= Generic template rendering and notifications with Consul
+LICENSE= MPL
+
BUILD_DEPENDS= ${LOCALBASE}/bin/go:lang/go
USE_GITHUB= yes
@@ -16,18 +18,20 @@ GH_ACCOUNT= hashicorp
PLIST_FILES= bin/consul-template
+USE_RC_SUBR= consul-template
+
STRIP= # stripping can break go binaries
post-extract:
@${MV} ${WRKSRC}/vendor ${WRKSRC}/src
@${MKDIR} ${WRKSRC}/src/github.com/hashicorp/consul-template
@cd ${WRKSRC} ; \
- ${MV} .gitignore .travis.yml CHANGELOG.md Godeps LICENSE Makefile \
- README.md brain.go brain_test.go cli.go cli_test.go config.go \
- config_test.go dedup.go dedup_test.go dependency flags.go logging \
- main.go runner.go runner_test.go scripts template.go \
- template_functions.go template_functions_test.go template_test.go test \
- watch \
+ ${MV} .gitignore .travis.yml CHANGELOG.md LICENSE Makefile README.md \
+ brain.go brain_test.go cli.go cli_test.go config.go config_test.go \
+ dedup.go dedup_test.go dependency flags.go logging main.go \
+ mapstructure.go mapstructure_test.go runner.go runner_test.go scripts \
+ template.go template_functions.go template_functions_test.go \
+ template_test.go test watch \
${WRKSRC}/src/github.com/hashicorp/consul-template
do-build:
diff --git a/textproc/consul-template/distinfo b/textproc/consul-template/distinfo
index 11c89e24d452..363db11ab077 100644
--- a/textproc/consul-template/distinfo
+++ b/textproc/consul-template/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1463835548
-SHA256 (hashicorp-consul-template-v0.14.0_GH0.tar.gz) = 8e4ee468f79c806db0bdea6432bd990f11089539910b751dac8b168b022a090b
-SIZE (hashicorp-consul-template-v0.14.0_GH0.tar.gz) = 1567282
+TIMESTAMP = 1469936531
+SHA256 (hashicorp-consul-template-v0.15.0_GH0.tar.gz) = cbcce6b163c673a1743285781703ec02079081c2691d94c97b13572321ae5587
+SIZE (hashicorp-consul-template-v0.15.0_GH0.tar.gz) = 1715150
diff --git a/textproc/consul-template/files/consul-template.in b/textproc/consul-template/files/consul-template.in
new file mode 100644
index 000000000000..1309b1d203c4
--- /dev/null
+++ b/textproc/consul-template/files/consul-template.in
@@ -0,0 +1,50 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: consul_template
+# REQUIRE: LOGIN
+# KEYWORD: shtudown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# consul_template_enable (bool): Set to NO by default.
+# Set it to YES to enable consul-template.
+# consul_template_user (user): Set user to run consul-template.
+# Default is "root".
+# consul_template_group (group): Set group to run consul-template.
+# Default is "wheel".
+# consul_template_env (string): Set environment variables used with consul-template.
+# Default is "".
+# consul_template_args (string): Set flags used with consul-template.
+# Default is "".
+
+. /etc/rc.subr
+
+name=consul_template
+rcvar=consul_template_enable
+
+load_rc_config $name
+
+: ${consul_template_enable:="NO"}
+: ${consul_template_user:="root"}
+: ${consul_template_group:="wheel"}
+: ${consul_template_env:=""}
+: ${consul_template_args:=""}
+
+pidfile=/var/run/consul-template.pid
+procname="%%PREFIX%%/bin/consul-template"
+command="/usr/sbin/daemon"
+command_args="-f -p ${pidfile} /usr/bin/env ${consul_template_env} ${procname} -config=%%PREFIX%%/etc/consul-template.d ${consul_template_args}"
+
+start_precmd=consul_template_startprecmd
+
+consul_template_startprecmd()
+{
+ if [ ! -e ${pidfile} ]; then
+ install -o ${consul_template_user} -g ${consul_template_group} /dev/null ${pidfile}
+ fi
+}
+
+run_rc_command "$1"