aboutsummaryrefslogtreecommitdiff
path: root/textproc/csvq
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-03-08 10:37:32 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-03-08 10:37:32 +0000
commit5db254a4626420a43943c7dcf0788689b99cd6bf (patch)
tree2feb3c5dabceefda6eb88331d18a52eca64d0af0 /textproc/csvq
parent2654d184c9a60a8b0cd96782aa7af1c9b293691a (diff)
downloadports-5db254a4626420a43943c7dcf0788689b99cd6bf.tar.gz
ports-5db254a4626420a43943c7dcf0788689b99cd6bf.zip
New port: textproc/csvq: SQL-like query language for csv
Command line tool to operate CSV files. You can read, update, delete CSV records with SQL-like query. You can also execute multiple operations sequentially in managed transactions by passing a procedure or using the interactive shell. In the multiple operations, you can use variables, cursors, temporary tables, and other features. WWW: https://mithrandie.github.io/csvq/ PR: 244663 Submitted by: Lewis Cook <vulcan@wired.sh>
Notes
Notes: svn path=/head/; revision=528023
Diffstat (limited to 'textproc/csvq')
-rw-r--r--textproc/csvq/Makefile36
-rw-r--r--textproc/csvq/distinfo21
-rw-r--r--textproc/csvq/pkg-descr12
3 files changed, 69 insertions, 0 deletions
diff --git a/textproc/csvq/Makefile b/textproc/csvq/Makefile
new file mode 100644
index 000000000000..d2d96a145ebd
--- /dev/null
+++ b/textproc/csvq/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= csvq
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.12.4
+CATEGORIES= textproc
+
+MAINTAINER= vulcan@wired.sh
+COMMENT= SQL-like query language for csv
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+USE_GITHUB= yes
+GH_ACCOUNT= mithrandie
+GH_TUPLE= golang:crypto:3d3f9f413869:golang_crypto/vendor/golang.org/x/crypto \
+ golang:sys:f43be2a4598c:golang_sys/vendor/golang.org/x/sys \
+ golang:text:v0.3.1:golang_text/vendor/golang.org/x/text \
+ mitchellh:go-homedir:v1.0.0:mitchellh_go_homedir/vendor/github.com/mitchellh/go-homedir \
+ mithrandie:go-file:v2.0.2:mithrandie_go_file/vendor/github.com/mithrandie/go-file/v2 \
+ mithrandie:go-text:v1.3.1:mithrandie_go_text/vendor/github.com/mithrandie/go-text \
+ mithrandie:readline-csvq:v1.1.1:mithrandie_readline_csvq/vendor/github.com/mithrandie/readline-csvq \
+ mithrandie:ternary:v1.1.0:mithrandie_ternary/vendor/github.com/mithrandie/ternary \
+ urfave:cli:v1.20.0:urfave_cli/vendor/github.com/urfave/cli
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= CHANGELOG.md README.md
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/csvq/distinfo b/textproc/csvq/distinfo
new file mode 100644
index 000000000000..95876474de9a
--- /dev/null
+++ b/textproc/csvq/distinfo
@@ -0,0 +1,21 @@
+TIMESTAMP = 1583620125
+SHA256 (mithrandie-csvq-v1.12.4_GH0.tar.gz) = 4633acb904301099bc421a23a6be2272e9a9d09a4a9045385a6ce4fd808ae6ab
+SIZE (mithrandie-csvq-v1.12.4_GH0.tar.gz) = 1378627
+SHA256 (golang-crypto-3d3f9f413869_GH0.tar.gz) = 350f3e37a30bad009d90aa4b2df7d239c363865557788368a402492dc14c899e
+SIZE (golang-crypto-3d3f9f413869_GH0.tar.gz) = 1644694
+SHA256 (golang-sys-f43be2a4598c_GH0.tar.gz) = 120cfab17111e93b3513a42bf0db20634552c85ae48d1fd3c5d7859fc5603356
+SIZE (golang-sys-f43be2a4598c_GH0.tar.gz) = 1513901
+SHA256 (golang-text-v0.3.1_GH0.tar.gz) = a206eef1db13748de879331d2e0e2c1d17c51a6d50526a02823b62d849912755
+SIZE (golang-text-v0.3.1_GH0.tar.gz) = 6592124
+SHA256 (mitchellh-go-homedir-v1.0.0_GH0.tar.gz) = ab2c930759869efe565a658b86e1a38ca2e2a0ea71635601ddcff1171aaff10a
+SIZE (mitchellh-go-homedir-v1.0.0_GH0.tar.gz) = 3247
+SHA256 (mithrandie-go-file-v2.0.2_GH0.tar.gz) = ed2abbf4351d09e0242fa3b9731e342fe7ff47ccd637c71ad11a40526946c301
+SIZE (mithrandie-go-file-v2.0.2_GH0.tar.gz) = 5801
+SHA256 (mithrandie-go-text-v1.3.1_GH0.tar.gz) = a5ee2ca67023752b7671cb09dd289f1eb58cbe210616e18c26f27f306647737a
+SIZE (mithrandie-go-text-v1.3.1_GH0.tar.gz) = 51510
+SHA256 (mithrandie-readline-csvq-v1.1.1_GH0.tar.gz) = 032e876f359c7ab8ec54670fe2688739aa1f7f95e6072023de54a061aaed1ba1
+SIZE (mithrandie-readline-csvq-v1.1.1_GH0.tar.gz) = 39043
+SHA256 (mithrandie-ternary-v1.1.0_GH0.tar.gz) = 69f8c645e7709e6ae90e4c913ac7ea773948463f4551d0957ac3f9855717a7c6
+SIZE (mithrandie-ternary-v1.1.0_GH0.tar.gz) = 5010
+SHA256 (urfave-cli-v1.20.0_GH0.tar.gz) = c5ba59f5742c99618b5ba34211699287cd3e80c41488bb267035ce0163e3bade
+SIZE (urfave-cli-v1.20.0_GH0.tar.gz) = 58397
diff --git a/textproc/csvq/pkg-descr b/textproc/csvq/pkg-descr
new file mode 100644
index 000000000000..29cf782b02eb
--- /dev/null
+++ b/textproc/csvq/pkg-descr
@@ -0,0 +1,12 @@
+Command line tool to operate CSV files.
+You can read, update, delete CSV records
+with SQL-like query.
+
+You can also execute multiple operations
+sequentially in managed transactions by
+passing a procedure or using the interactive
+shell. In the multiple operations, you can
+use variables, cursors, temporary tables,
+and other features.
+
+WWW: https://mithrandie.github.io/csvq/