aboutsummaryrefslogtreecommitdiff
path: root/textproc/dict/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-04-11 02:38:42 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-04-11 02:38:42 +0000
commitac5c6c500061bc489532b4baa2e7784a7c19444c (patch)
treecf1060d7c11973f4710b9be7f94acfecf9cd61f5 /textproc/dict/Makefile
parenta116e6c77f422e1a5d82a6adfcb47141dcbb704c (diff)
downloadports-ac5c6c500061bc489532b4baa2e7784a7c19444c.tar.gz
ports-ac5c6c500061bc489532b4baa2e7784a7c19444c.zip
- update to 1.10.8
- I'll maintain it for a while
Notes
Notes: svn path=/head/; revision=189735
Diffstat (limited to 'textproc/dict/Makefile')
-rw-r--r--textproc/dict/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/textproc/dict/Makefile b/textproc/dict/Makefile
index 2cb40b7808fd..4d246c909d88 100644
--- a/textproc/dict/Makefile
+++ b/textproc/dict/Makefile
@@ -7,23 +7,23 @@
#
PORTNAME= dict
-PORTVERSION= 1.10.4
-PORTREVISION= 1
+PORTVERSION= 1.10.8
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= dict
DISTNAME= ${PORTNAME}d-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= clsung@FreeBSD.org
COMMENT= Dictionary Server Protocol (RFC2229) client
USE_BISON= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-local-zlib --with-cflags="${CFLAGS}" \
- --with-etcdir=${PREFIX}/etc
+ --with-etcdir=${PREFIX}/etc --mandir="${PREFIX}/man"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
ALL_TARGET= dict
INSTALL_TARGET= install.dict
MAN1= dict.1 dictl.1
@@ -31,6 +31,9 @@ MAN1= dict.1 dictl.1
post-patch:
${REINPLACE_CMD} -e 's|/etc/|${PREFIX}/etc/|g' ${WRKSRC}/dict.1.in
+post-configure:
+ ${REINPLACE_CMD} -e 's|^ mkdir| mkdir|g' ${WRKSRC}/Makefile
+
post-install:
${INSTALL_DATA} ${FILESDIR}/dict.conf ${PREFIX}/etc/dict.conf.sample
if [ ! -f ${PREFIX}/etc/dict.conf ]; then \