aboutsummaryrefslogtreecommitdiff
path: root/textproc/docbook-420
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-01-03 08:20:44 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-01-03 08:20:44 +0000
commit7ef90db4b1cae3a3d5f4dd3b16bf64069c9bdee6 (patch)
treec8cd791512f2184f53e39c8e28c5304d9b67adfa /textproc/docbook-420
parent767db68131716dd9d453fa6c99c6681fe47c3ff1 (diff)
downloadports-7ef90db4b1cae3a3d5f4dd3b16bf64069c9bdee6.tar.gz
ports-7ef90db4b1cae3a3d5f4dd3b16bf64069c9bdee6.zip
new port: textproc/docbook-420
This port contains the SGML version of DocBook 4.2. Note that DocBook 4.2 includes the XML DocBook DTD as part of the SGML DTD distribution. This port is a superset of textproc/docbook-xml, which includes only the XML DTD. PR: ports/58695 Submitted by: Michael Edenfield <kutulu@kutulu.org>
Notes
Notes: svn path=/head/; revision=97192
Diffstat (limited to 'textproc/docbook-420')
-rw-r--r--textproc/docbook-420/Makefile52
-rw-r--r--textproc/docbook-420/distinfo1
-rw-r--r--textproc/docbook-420/files/catalog85
-rw-r--r--textproc/docbook-420/pkg-descr15
-rw-r--r--textproc/docbook-420/pkg-plist19
5 files changed, 172 insertions, 0 deletions
diff --git a/textproc/docbook-420/Makefile b/textproc/docbook-420/Makefile
new file mode 100644
index 000000000000..5937333cd069
--- /dev/null
+++ b/textproc/docbook-420/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: docbook-420
+# Date created: 29 Oct 2003
+# Whom: kutulu
+#
+# Based on murray's docbook-410 port
+# which is based on niks' docbook-310 port
+#
+# $FreeBSD$
+#
+
+PORTNAME= docbook
+PORTVERSION= 4.2
+CATEGORIES= textproc
+MASTER_SITES= http://www.docbook.org/sgml/4.2/
+EXTRACT_ONLY= # empty
+
+MAINTAINER= kutulu@kutulu.org
+COMMENT= V4.2 of the DocBook DTD, designed for technical documentation
+
+RUN_DEPENDS= ${ISOCAT}:${PORTSDIR}/textproc/iso8879 \
+ ${XMLCATMGR}:${PORTSDIR}/textproc/xmlcatmgr
+
+USE_ZIP= yes
+NO_MTREE= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+PLIST_SUB= DTD_NAME=${PORTNAME}
+PLIST_SUB+= DTD_VERSION=${PORTVERSION}
+PLIST_SUB+= XMLCATMGR=${XMLCATMGR}
+PLIST_SUB+= CATALOG_PORTS_SGML=${CATALOG_PORTS_SGML}
+
+INSTDIR= ${PREFIX}/share/sgml/docbook
+ISOCAT= ${PREFIX}/share/sgml/iso8879/catalog
+XMLCATMGR= ${LOCALBASE}/bin/xmlcatmgr
+CATALOG_PORTS_SGML= ${PREFIX}/share/sgml/catalog.ports
+
+LATEST_LINK= docbook-420
+
+pre-install:
+ @[ -d ${INSTDIR}/${PORTVERSION} ] || ${MKDIR} ${INSTDIR}/${PORTVERSION}
+
+do-install:
+ @unzip -a -q -o ${DISTDIR}/${DISTFILES} -d ${INSTDIR}/${PORTVERSION}
+ @${INSTALL_DATA} ${FILESDIR}/catalog ${INSTDIR}/${PORTVERSION}/catalog
+ @${ECHO_CMD} "CATALOG \"${ISOCAT}\"" >> ${INSTDIR}/${PORTVERSION}/catalog
+ @${CHMOD} ${SHAREMODE} ${INSTDIR}/${PORTVERSION}/*
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${INSTDIR}
+
+post-install:
+ @${XMLCATMGR} -sc ${CATALOG_PORTS_SGML} add CATALOG ${PORTNAME}/${PORTVERSION}/catalog
+
+.include <bsd.port.mk>
diff --git a/textproc/docbook-420/distinfo b/textproc/docbook-420/distinfo
new file mode 100644
index 000000000000..5efb3c8fc733
--- /dev/null
+++ b/textproc/docbook-420/distinfo
@@ -0,0 +1 @@
+MD5 (docbook-4.2.zip) = 0dfeb94569334dd22a62d90d99fc0630
diff --git a/textproc/docbook-420/files/catalog b/textproc/docbook-420/files/catalog
new file mode 100644
index 000000000000..0e60f0d88386
--- /dev/null
+++ b/textproc/docbook-420/files/catalog
@@ -0,0 +1,85 @@
+ -- ...................................................................... --
+ -- Catalog data for DocBook V4.2 ........................................ --
+ -- File docbook.cat ..................................................... --
+
+ -- Please direct all questions, bug reports, or suggestions for
+ changes to the docbook@lists.oasis-open.org mailing list. For more
+ information, see http://www.oasis-open.org/.
+ --
+
+ -- This is the catalog data file for DocBook V4.2. It is provided as
+ a convenience in building your own catalog files. You need not use
+ the filenames listed here, and need not use the filename method of
+ identifying storage objects at all. See the documentation for
+ detailed information on the files associated with the DocBook DTD.
+ See SGML Open Technical Resolution 9401 for detailed information
+ on supplying and using catalog data.
+ --
+
+ -- ...................................................................... --
+ -- DocBook driver file .................................................. --
+
+PUBLIC "-//OASIS//DTD DocBook V4.2//EN" "docbook.dtd"
+
+PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN" "docbookx.dtd"
+
+ -- ...................................................................... --
+ -- DocBook modules ...................................................... --
+
+PUBLIC "-//OASIS//DTD DocBook CALS Table Model V4.2//EN" "calstblx.dtd"
+
+PUBLIC "-//OASIS//DTD XML Exchange Table Model 19990315//EN" "soextblx.dtd"
+
+PUBLIC "-//OASIS//ELEMENTS DocBook Information Pool V4.2//EN" "dbpoolx.mod"
+
+PUBLIC "-//OASIS//ELEMENTS DocBook Document Hierarchy V4.2//EN" "dbhierx.mod"
+
+PUBLIC "-//OASIS//ENTITIES DocBook Additional General Entities V4.2//EN" "dbgenent.mod"
+
+PUBLIC "-//OASIS//ENTITIES DocBook Notations V4.2//EN" "dbnotnx.mod"
+
+PUBLIC "-//OASIS//ENTITIES DocBook Character Entities V4.2//EN" "dbcentx.mod"
+
+ -- ...................................................................... --
+ -- ISO entity sets ...................................................... --
+
+PUBLIC "ISO 8879:1986//ENTITIES Diacritical Marks//EN" "iso-dia.gml"
+
+PUBLIC "ISO 8879:1986//ENTITIES Numeric and Special Graphic//EN" "iso-num.gml"
+
+PUBLIC "ISO 8879:1986//ENTITIES Publishing//EN" "iso-pub.gml"
+
+PUBLIC "ISO 8879:1986//ENTITIES General Technical//EN" "iso-tech.gml"
+
+PUBLIC "ISO 8879:1986//ENTITIES Added Latin 1//EN" "iso-lat1.gml"
+
+PUBLIC "ISO 8879:1986//ENTITIES Added Latin 2//EN" "iso-lat2.gml"
+
+PUBLIC "ISO 8879:1986//ENTITIES Greek Letters//EN" "iso-grk1.gml"
+
+PUBLIC "ISO 8879:1986//ENTITIES Monotoniko Greek//EN" "iso-grk2.gml"
+
+PUBLIC "ISO 8879:1986//ENTITIES Greek Symbols//EN" "iso-grk3.gml"
+
+PUBLIC "ISO 8879:1986//ENTITIES Alternative Greek Symbols//EN" "iso-grk4.gml"
+
+PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Arrow Relations//EN" "iso-amsa.gml"
+
+PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Binary Operators//EN" "iso-amsb.gml"
+
+PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Delimiters//EN" "iso-amsc.gml"
+
+PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Negated Relations//EN" "iso-amsn.gml"
+
+PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Ordinary//EN" "iso-amso.gml"
+
+PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Relations//EN" "iso-amsr.gml"
+
+PUBLIC "ISO 8879:1986//ENTITIES Box and Line Drawing//EN" "iso-box.gml"
+
+PUBLIC "ISO 8879:1986//ENTITIES Russian Cyrillic//EN" "iso-cyr1.gml"
+
+PUBLIC "ISO 8879:1986//ENTITIES Non-Russian Cyrillic//EN" "iso-cyr2.gml"
+
+ -- End of catalog data for DocBook V4.2 ................................. --
+ -- ...................................................................... --
diff --git a/textproc/docbook-420/pkg-descr b/textproc/docbook-420/pkg-descr
new file mode 100644
index 000000000000..509588730d20
--- /dev/null
+++ b/textproc/docbook-420/pkg-descr
@@ -0,0 +1,15 @@
+The DocBook DTD defines structural and content-based SGML markup
+for computer documentation, with a primary emphasis on software
+documentation and related classes of technical documents. Its
+main high-level hierarchical structures are for books, reference
+entries (for example, ``man pages''), and articles. It is
+maintained by the DocBook Technical Committee of OASIS.
+
+This port contains DocBook 4.2. Note that DocBook 4.2 includes
+the XML DocBook DTD as part of the SGML DTD distribution. If
+you do not need SGML DTD you should install:
+ textproc/docbook-xml
+instead. There are no conflicts if both ports are installed
+but you will have duplicates of most of the files.
+
+WWW: http://www.oasis-open.org/docbook/
diff --git a/textproc/docbook-420/pkg-plist b/textproc/docbook-420/pkg-plist
new file mode 100644
index 000000000000..f9bdddb45683
--- /dev/null
+++ b/textproc/docbook-420/pkg-plist
@@ -0,0 +1,19 @@
+share/sgml/docbook/4.2/ChangeLog
+share/sgml/docbook/4.2/calstblx.dtd
+@unexec %%XMLCATMGR%% -sc %%CATALOG_PORTS_SGML%% remove %%DTD_NAME%%/%%DTD_VERSION%%/catalog
+share/sgml/docbook/4.2/catalog
+share/sgml/docbook/4.2/catalog.xml
+@exec %%XMLCATMGR%% -sc %%CATALOG_PORTS_SGML%% add CATALOG %%DTD_NAME%%/%%DTD_VERSION%%/catalog
+share/sgml/docbook/4.2/dbcentx.mod
+share/sgml/docbook/4.2/dbgenent.mod
+share/sgml/docbook/4.2/dbhierx.mod
+share/sgml/docbook/4.2/dbnotnx.mod
+share/sgml/docbook/4.2/dbpoolx.mod
+share/sgml/docbook/4.2/docbook.cat
+share/sgml/docbook/4.2/docbook.dcl
+share/sgml/docbook/4.2/docbook.dtd
+share/sgml/docbook/4.2/docbookx.dtd
+share/sgml/docbook/4.2/soextblx.dtd
+share/sgml/docbook/4.2/README
+@dirrm share/sgml/docbook/4.2
+@unexec rmdir %D/share/sgml/docbook 2>/dev/null || true