aboutsummaryrefslogtreecommitdiff
path: root/textproc/docproj
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2015-08-22 17:48:35 +0000
committerHiroki Sato <hrs@FreeBSD.org>2015-08-22 17:48:35 +0000
commit27470e1676e69455acf06ae25ebd42ebd5bdecdb (patch)
tree445c3e315f03aa972de87391f921c655e4634f60 /textproc/docproj
parentcb9ed09fda5119f533f6a0b50796a275dfe64587 (diff)
downloadports-27470e1676e69455acf06ae25ebd42ebd5bdecdb.tar.gz
ports-27470e1676e69455acf06ae25ebd42ebd5bdecdb.zip
- Split ghostscript into X11-independent and -dependent parts:
* print/ghostscript{7,8,9,9-agpl}-base Installs Ghostscript binary, libgs, and related files. These ports do not depend on X11 libraries (i.e. x11* devices are not available). USES=ghostscript will set dependency on one of them depending on GHOSTSCRIPT_DEFAULT. The default device is set to "display" or "bbox". * print/ghostscript{7,8,9,9-agpl}-x11 Installs a shared library which provides X11 support to the installed Ghostscript binaries. x11* devices will be enabled when the library is available. This depends on *-base (RUN_DEPENDS). USES=ghostscript:x11 will set dependency on one of them. - Fix integer overflow reported as CVE-2015-3228. - Update Uses/ghostscript.mk: * Add x11 keyword. nox11 keyword is now obsolete. * Use packagename in *_DEPENDS line to prevent relationship between -base and -x11 packages from being broken. - Fix x11/nox11 keyword and bump PORTREVISION in ports using USES=ghostscript to update dependency of pre-compiled packages.
Notes
Notes: svn path=/head/; revision=395047
Diffstat (limited to 'textproc/docproj')
-rw-r--r--textproc/docproj/Makefile21
1 files changed, 4 insertions, 17 deletions
diff --git a/textproc/docproj/Makefile b/textproc/docproj/Makefile
index b7e9b35c7408..8093cca6be16 100644
--- a/textproc/docproj/Makefile
+++ b/textproc/docproj/Makefile
@@ -3,17 +3,12 @@
PORTNAME= docproj
PORTVERSION= 2.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= textproc
-MASTER_SITES= # empty
-DISTFILES= # empty
-EXTRACT_ONLY= # empty
MAINTAINER= doceng@FreeBSD.org
COMMENT= The "meta-port" for the FreeBSD Documentation Project
-# This dependency list should be kept in sync with the list of
-# required ports in src/release/Makefile.inc.docports.
RUN_DEPENDS= links:${PORTSDIR}/www/links1 \
pngtopnm:${PORTSDIR}/graphics/netpbm \
scr2png:${PORTSDIR}/graphics/scr2png \
@@ -28,13 +23,11 @@ RUN_DEPENDS= links:${PORTSDIR}/www/links1 \
p5-XML-Parser>=2.41:${PORTSDIR}/textproc/p5-XML-Parser \
zip:${PORTSDIR}/archivers/zip
-USES= ghostscript:run perl5
+USES= ghostscript:run metaport perl5
USE_PERL5= run
-DEPENDS_ARGS+= BATCH=yes
-NO_BUILD= yes
-OPTIONS_DEFINE= X11 CJK SVN IGOR FOP JING DBLATEX
-OPTIONS_DEFAULT= X11 CJK IGOR
+OPTIONS_DEFINE= CJK SVN IGOR FOP JING DBLATEX
+OPTIONS_DEFAULT= CJK IGOR
.if !exists(/usr/bin/svnlite)
OPTIONS_DEFAULT+= SVN
.endif
@@ -70,16 +63,10 @@ RUN_DEPENDS+= ${FONTS_CJK}
.endif
.endif
-.if !${PORT_OPTIONS:MX11}
-DEPENDS_ARGS+= OPTIONS_UNSET_FORCE+=X11
-.endif
-
# generate MINIMALDOCPORTS for src/release/Makefile.inc.docports.
# (XXX: incomplete yet)
minimaldocports:
@${ECHO_CMD} "MINIMALDOCPORTS= \\"
@${MAKE} all-depends-list | ${SED} -e 's,^${PORTSDIR}/, ,' -e 's,$$, \\,'
-do-install: # empty
-
.include <bsd.port.mk>