aboutsummaryrefslogtreecommitdiff
path: root/textproc/dwdiff
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-10-07 16:17:50 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-10-07 16:17:50 +0000
commit8b3c859c2a1538f8199c39b5bfc5134ede2b670b (patch)
tree4736b7328b04c7e7f8fa1dd69535535b17435cbf /textproc/dwdiff
parent667deb983424030425a765589baebfdf32956a53 (diff)
downloadports-8b3c859c2a1538f8199c39b5bfc5134ede2b670b.tar.gz
ports-8b3c859c2a1538f8199c39b5bfc5134ede2b670b.zip
Add dwdiff 1.2, a delimited word diff program.
PR: ports/103840 Submitted by: Alexander Logvinov <ports at logvinov.com>
Notes
Notes: svn path=/head/; revision=174804
Diffstat (limited to 'textproc/dwdiff')
-rw-r--r--textproc/dwdiff/Makefile47
-rw-r--r--textproc/dwdiff/distinfo3
-rw-r--r--textproc/dwdiff/pkg-descr15
3 files changed, 65 insertions, 0 deletions
diff --git a/textproc/dwdiff/Makefile b/textproc/dwdiff/Makefile
new file mode 100644
index 000000000000..09ded448b9c8
--- /dev/null
+++ b/textproc/dwdiff/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: dwdiff
+# Date created: 30 September 2006
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+
+PORTNAME= dwdiff
+PORTVERSION= 1.2
+CATEGORIES= textproc
+MASTER_SITES= http://os.ghalkes.nl/dist/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@logvinov.com
+COMMENT= A delimited word diff program
+
+HAS_CONFIGURE= yes
+
+OPTIONS= GETTEXT "Build with gettext support" on
+
+MAN1= dwdiff.1
+PORTDOCS= COPYING Changelog README
+PLIST_FILES= bin/dwdiff
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_GETTEXT)
+USE_GETTEXT= yes
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+.else
+CONFIGURE_ARGS+=--without-gettext
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/${MAN1} ${MAN1PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in COPYING Changelog README
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/dwdiff/distinfo b/textproc/dwdiff/distinfo
new file mode 100644
index 000000000000..1f252c41d23b
--- /dev/null
+++ b/textproc/dwdiff/distinfo
@@ -0,0 +1,3 @@
+MD5 (dwdiff-1.2.tgz) = 4e811fa2c209e6adb0bd2a9c8eab025d
+SHA256 (dwdiff-1.2.tgz) = e803fe8a6288f698b10516c329c902e1b384c61b3638e94c2f09b70231ccf15e
+SIZE (dwdiff-1.2.tgz) = 26165
diff --git a/textproc/dwdiff/pkg-descr b/textproc/dwdiff/pkg-descr
new file mode 100644
index 000000000000..d770cb80a444
--- /dev/null
+++ b/textproc/dwdiff/pkg-descr
@@ -0,0 +1,15 @@
+dwdiff is a front-end for the diff program that operates at the word level
+instead of the line level. It is different from wdiff in that it allows the
+user to specify what should be considered whitespace, and in that it takes an
+optional list of characters that should be considered delimiters. Delimiters
+are single characters that are treated as if they are words, even when there
+is no whitespace separating them from preceding words or delimiters. dwdiff
+is mostly commandline compatible with wdiff. Only the --autopager, --terminal
+and --avoid-wraps options are not supported.
+
+The default output from dwdiff is the new text, with the deleted and inserted
+parts annotated with markers. Command line options are available to change
+both what is printed, and the markers.
+
+Author: Gertjan Halkes <dwdiff@ghalkes.nl>
+WWW: http://os.ghalkes.nl/dwdiff.html