aboutsummaryrefslogtreecommitdiff
path: root/textproc/enchant/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-07-25 12:45:16 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-07-25 12:45:16 +0000
commitaf4412ffcc2d3f85a188aa405ef0884fea6f7d7b (patch)
tree85df5c2bc508a92c159a352e00c6d4a28716e0ae /textproc/enchant/Makefile
parentf62dd21d6e0035f74a0708756ae759c59a7c2941 (diff)
downloadports-af4412ffcc2d3f85a188aa405ef0884fea6f7d7b.tar.gz
ports-af4412ffcc2d3f85a188aa405ef0884fea6f7d7b.zip
Update to 1.6.0.
Add some backend options. [1] Submitted by: makc@ [1]
Notes
Notes: svn path=/head/; revision=258226
Diffstat (limited to 'textproc/enchant/Makefile')
-rw-r--r--textproc/enchant/Makefile63
1 files changed, 40 insertions, 23 deletions
diff --git a/textproc/enchant/Makefile b/textproc/enchant/Makefile
index c753c5bc76e5..d964e11026ee 100644
--- a/textproc/enchant/Makefile
+++ b/textproc/enchant/Makefile
@@ -3,11 +3,11 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/textproc/enchant/Makefile,v 1.1 2006/03/12 02:08:58 mezz Exp $
+# $MCom: ports-stable/textproc/enchant/Makefile,v 1.3 2010/07/20 07:48:41 kwm Exp $
#
PORTNAME= enchant
-PORTVERSION= 1.4.2
+PORTVERSION= 1.6.0
CATEGORIES= textproc gnome
MASTER_SITES= http://www.abisource.com/downloads/${PORTNAME}/${PORTVERSION}/
DIST_SUBDIR= gnome2
@@ -19,34 +19,24 @@ USE_GMAKE= yes
USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
USE_GNOME= gnomehack gnometarget glib20 ltverhack
-CONFIGURE_ARGS= --disable-hspell \
- --disable-uspell
+CONFIGURE_ARGS= --disable-uspell \
+ --disable-voikko
+MAKE_JOBS_SAFE= yes
+
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= enchant.1
-OPTIONS= ASPELL "Enable aspell support" on \
+OPTIONS= ASPELL "Enable Aspell backend" on \
+ HSPELL "Enable Hspell backend" off \
+ HUNSPELL "Enable Hunspell backend" off \
+ ISPELL "Enable Ispell backend" off \
ZEMBEREK "Enable zemberek backend (requires DBUS)" off
-
.include <bsd.port.pre.mk>
-# Disable, it needs hspell 0.9 or above.
-#.if exists(${LOCALBASE}/bin/hspell)
-#WITH_HSPELL= yes
-#.endif
-#
-#.if defined(WITH_HSPELL)
-#BUILD_DEPENDS+= hspell:${PORTSDIR}/hebrew/hspell
-#CONFIGURE_ARGS+=--enable-hspell
-#PLIST_SUB+= HSPELL=""
-#.else
-#CONFIGURE_ARGS+=--disable-hspell
-#PLIST_SUB+= HSPELL="@comment "
-#.endif
-
-.ifndef(WITHOUT_ASPELL)
+.if defined(WITH_ASPELL)
LIB_DEPENDS+= pspell.16:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+=--enable-aspell \
--with-aspell-prefix=${LOCALBASE}
@@ -56,13 +46,40 @@ CONFIGURE_ARGS+=--disable-aspell
PLIST_SUB+= ASPELL="@comment "
.endif
+.if defined(WITH_HSPELL)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libhspell.a:${PORTSDIR}/hebrew/hspell
+CONFIGURE_ARGS+=--enable-hspell
+PLIST_SUB+= HSPELL=""
+.else
+CONFIGURE_ARGS+=--disable-hspell
+PLIST_SUB+= HSPELL="@comment "
+.endif
+
+.if defined(WITH_HUNSPELL)
+LIB_DEPENDS+= hunspell-1.2.0:${PORTSDIR}/hungarian/hunspell
+CONFIGURE_ARGS+=--enable-myspell
+PLIST_SUB+= HUNSPELL=""
+.else
+CONFIGURE_ARGS+=--disable-myspell
+PLIST_SUB+= HUNSPELL="@comment "
+.endif
+
+.if defined(WITH_ISPELL)
+RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
+CONFIGURE_ARGS+=--enable-ispell
+PLIST_SUB+= ISPELL=""
+.else
+CONFIGURE_ARGS+=--disable-ispell
+PLIST_SUB+= ISPELL="@comment "
+.endif
+
.if defined(WITH_ZEMBEREK) && !defined(WITHOUT_DBUS)
LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
-CONFIGURE_ARGS+= --enable-zemberek
+CONFIGURE_ARGS+=--enable-zemberek
PLIST_SUB+= ZEMBEREK=""
.else
PLIST_SUB+= ZEMBEREK="@comment "
-CONFIGURE_ARGS+= --disable-zemberek
+CONFIGURE_ARGS+=--disable-zemberek
.endif
post-patch: