aboutsummaryrefslogtreecommitdiff
path: root/textproc/enchant
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2018-04-01 18:50:52 +0000
committerKoop Mast <kwm@FreeBSD.org>2018-04-01 18:50:52 +0000
commitc2bbf93dfcacd27ca6d2d8bd1976252dcb29ae0a (patch)
treeecae6842be7ad55d370c5095794ae1e9f16cadf1 /textproc/enchant
parent1523527acdee7a36786b45b7f7cf0311acf09e7b (diff)
downloadports-c2bbf93dfcacd27ca6d2d8bd1976252dcb29ae0a.tar.gz
ports-c2bbf93dfcacd27ca6d2d8bd1976252dcb29ae0a.zip
Copy enchant to enchant2 for the new version with shared library bump.
Fix typo in ZEMBEREK lib depends line and add missing dependancy. Rename sorting file in textproc/enchant to fix conflict with textproc/enchant2. PR: 215083 (based on) Submitted by: thierry@FreeBSD.org
Notes
Notes: svn path=/head/; revision=466176
Diffstat (limited to 'textproc/enchant')
-rw-r--r--textproc/enchant/Makefile9
-rw-r--r--textproc/enchant/files/patch-configure6
-rw-r--r--textproc/enchant/files/patch-src_enchant.c11
-rw-r--r--textproc/enchant/files/patch-src_myspell_myspell__checker.cpp2
-rw-r--r--textproc/enchant/pkg-plist2
5 files changed, 23 insertions, 7 deletions
diff --git a/textproc/enchant/Makefile b/textproc/enchant/Makefile
index 357acb23fde1..0c4c11345926 100644
--- a/textproc/enchant/Makefile
+++ b/textproc/enchant/Makefile
@@ -3,7 +3,7 @@
PORTNAME= enchant
PORTVERSION= 1.6.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= textproc gnome
MASTER_SITES= http://www.abisource.com/downloads/${PORTNAME}/${PORTVERSION}/
DIST_SUBDIR= gnome2
@@ -47,11 +47,16 @@ HUNSPELL_CONFIGURE_ON= --with-system-myspell=yes \
ISPELL_RUN_DEPENDS= ispell:textproc/aspell-ispell
ISPELL_CONFIGURE_ENABLE= ispell
-ZEMBEREK_LIb_DEPENDS= libdbus-glib-1.so:devel/dbus-glib
+ZEMBEREK_LIB_DEPENDS= libdbus-1.so:devel/dbus \
+ libdbus-glib-1.so:devel/dbus-glib
ZEMBEREK_CONFIGURE_ENABLE= zemberek
post-patch:
@${REINPLACE_CMD} -e 's|MKDIRPROG-mkdir|MKDIRPROG-mkdir -p|g' \
${WRKSRC}/install-sh
+post-install:
+ @cd ${STAGEDIR}${PREFIX}/share/enchant/ && \
+ ${MV} enchant.ordering enchant1.ordering
+
.include <bsd.port.mk>
diff --git a/textproc/enchant/files/patch-configure b/textproc/enchant/files/patch-configure
index 9c5605d3cdc8..4ce8c9bda89c 100644
--- a/textproc/enchant/files/patch-configure
+++ b/textproc/enchant/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2013-08-16 18:30:56.000000000 +0200
-+++ configure 2013-08-16 18:31:33.000000000 +0200
-@@ -18213,7 +18213,7 @@
+--- configure.orig 2010-04-01 20:56:39 UTC
++++ configure
+@@ -18213,7 +18213,7 @@ if test "x$ac_cv_lib_aspell_get_aspell_dict_info_list"
fi
diff --git a/textproc/enchant/files/patch-src_enchant.c b/textproc/enchant/files/patch-src_enchant.c
new file mode 100644
index 000000000000..2ed01794ab72
--- /dev/null
+++ b/textproc/enchant/files/patch-src_enchant.c
@@ -0,0 +1,11 @@
+--- src/enchant.c.orig 2018-04-01 15:42:47 UTC
++++ src/enchant.c
+@@ -1558,7 +1558,7 @@ enchant_load_provider_ordering (EnchantBroker * broker
+ for (iter = conf_dirs; iter; iter = iter->next)
+ {
+ char *ordering_file;
+- ordering_file = g_build_filename (iter->data, "enchant.ordering", NULL);
++ ordering_file = g_build_filename (iter->data, "enchant1.ordering", NULL);
+ enchant_load_ordering_from_file (broker, ordering_file);
+ g_free (ordering_file);
+ }
diff --git a/textproc/enchant/files/patch-src_myspell_myspell__checker.cpp b/textproc/enchant/files/patch-src_myspell_myspell__checker.cpp
index e761637ee338..7e492055c558 100644
--- a/textproc/enchant/files/patch-src_myspell_myspell__checker.cpp
+++ b/textproc/enchant/files/patch-src_myspell_myspell__checker.cpp
@@ -1,6 +1,6 @@
--- src/myspell/myspell_checker.cpp.orig 2010-04-01 20:53:37 UTC
+++ src/myspell/myspell_checker.cpp
-@@ -427,7 +427,7 @@ MySpellChecker::requestDictionary(const
+@@ -427,7 +427,7 @@ MySpellChecker::requestDictionary(const char *szLang)
if(myspell == NULL){
return false;
}
diff --git a/textproc/enchant/pkg-plist b/textproc/enchant/pkg-plist
index 386afd856c5a..aca5810dbf23 100644
--- a/textproc/enchant/pkg-plist
+++ b/textproc/enchant/pkg-plist
@@ -19,4 +19,4 @@ lib/libenchant.so.1
lib/libenchant.so.1.6.0
libdata/pkgconfig/enchant.pc
man/man1/enchant.1.gz
-%%DATADIR%%/enchant.ordering
+%%DATADIR%%/enchant1.ordering