aboutsummaryrefslogtreecommitdiff
path: root/textproc/evtx/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-30 21:26:32 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-30 21:28:17 +0000
commit043215b4a1f5adb1426440fbc2fc0f6a4a7ad647 (patch)
treeca9c9eb6084b0f91037b9a8be6bba6fb352f89a8 /textproc/evtx/Makefile
parent00c46f9fe7030e70c10ea2f69714c0b70b03a175 (diff)
downloadports-043215b4a1f5adb1426440fbc2fc0f6a4a7ad647.tar.gz
ports-043215b4a1f5adb1426440fbc2fc0f6a4a7ad647.zip
textproc/evtx: New port: A Fast parser for the Windows XML Event Log (EVTX) format
A cross-platform parser for the Windows XML EventLog format Features: - Implemented using 100% safe rust - and works on all platforms supported by rust (that have stdlib). - It's faster than any other implementation by order(s) of magnitude! - Multi-threaded. - Supports XML and JSON outputs, both being directly constructed from the token tree and independent of each other (no xml2json conversion is performed!) - Supports some basic recovery of missing records/chunks!
Diffstat (limited to 'textproc/evtx/Makefile')
-rw-r--r--textproc/evtx/Makefile199
1 files changed, 199 insertions, 0 deletions
diff --git a/textproc/evtx/Makefile b/textproc/evtx/Makefile
new file mode 100644
index 000000000000..e967968b8cab
--- /dev/null
+++ b/textproc/evtx/Makefile
@@ -0,0 +1,199 @@
+PORTNAME= evtx
+DISTVERSION= 0.8.1
+DISTVERSIONPREFIX= v
+CATEGORIES= textproc
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= A Fast parser for the Windows XML Event Log (EVTX) format
+WWW= https://github.com/omerbenamram/evtx
+
+LICENSE= MIT
+
+USES= cargo
+USE_GITHUB= yes
+GH_ACCOUNT= omerbenamram
+
+CARGO_CRATES= addr2line-0.19.0 \
+ adler-1.0.2 \
+ aho-corasick-0.7.20 \
+ android_system_properties-0.1.5 \
+ anyhow-1.0.69 \
+ assert_cmd-2.0.8 \
+ atty-0.2.14 \
+ autocfg-1.1.0 \
+ backtrace-0.3.67 \
+ bitflags-1.3.2 \
+ bstr-1.2.0 \
+ bumpalo-3.12.0 \
+ bytecount-0.6.3 \
+ byteorder-1.4.3 \
+ camino-1.1.2 \
+ cargo-platform-0.1.2 \
+ cargo_metadata-0.14.2 \
+ cast-0.3.0 \
+ cc-1.0.79 \
+ cfg-if-0.1.10 \
+ cfg-if-1.0.0 \
+ chrono-0.4.23 \
+ clap-2.34.0 \
+ clap-3.2.23 \
+ clap_lex-0.2.4 \
+ codespan-reporting-0.11.1 \
+ console-0.15.5 \
+ core-foundation-sys-0.8.3 \
+ crc32fast-1.3.2 \
+ criterion-0.3.6 \
+ criterion-plot-0.4.5 \
+ crossbeam-channel-0.5.6 \
+ crossbeam-deque-0.8.2 \
+ crossbeam-epoch-0.9.13 \
+ crossbeam-utils-0.8.14 \
+ csv-1.2.0 \
+ csv-core-0.1.10 \
+ ctor-0.1.26 \
+ cxx-1.0.91 \
+ cxx-build-1.0.91 \
+ cxxbridge-flags-1.0.91 \
+ cxxbridge-macro-1.0.91 \
+ dialoguer-0.10.3 \
+ diff-0.1.13 \
+ difflib-0.4.0 \
+ doc-comment-0.3.3 \
+ either-1.8.1 \
+ encode_unicode-0.3.6 \
+ encoding-0.2.33 \
+ encoding-index-japanese-1.20141219.5 \
+ encoding-index-korean-1.20141219.5 \
+ encoding-index-simpchinese-1.20141219.5 \
+ encoding-index-singlebyte-1.20141219.5 \
+ encoding-index-tradchinese-1.20141219.5 \
+ encoding_index_tests-0.1.4 \
+ env_logger-0.7.1 \
+ env_logger-0.9.3 \
+ error-chain-0.12.4 \
+ fastrand-1.9.0 \
+ float-cmp-0.9.0 \
+ gimli-0.27.2 \
+ glob-0.3.1 \
+ half-1.8.2 \
+ hashbrown-0.12.3 \
+ hermit-abi-0.1.19 \
+ hermit-abi-0.2.6 \
+ humantime-1.3.0 \
+ humantime-2.1.0 \
+ iana-time-zone-0.1.53 \
+ iana-time-zone-haiku-0.1.1 \
+ indexmap-1.9.2 \
+ indoc-1.0.9 \
+ insta-1.28.0 \
+ instant-0.1.12 \
+ itertools-0.10.5 \
+ itoa-1.0.5 \
+ jemalloc-sys-0.5.3+5.3.0-patched \
+ jemallocator-0.5.0 \
+ js-sys-0.3.61 \
+ lazy_static-1.4.0 \
+ libc-0.2.139 \
+ link-cplusplus-1.0.8 \
+ linked-hash-map-0.5.6 \
+ log-0.4.17 \
+ memchr-2.5.0 \
+ memoffset-0.7.1 \
+ miniz_oxide-0.6.2 \
+ nix-0.14.1 \
+ normalize-line-endings-0.3.0 \
+ num-derive-0.3.3 \
+ num-integer-0.1.45 \
+ num-traits-0.2.15 \
+ num_cpus-1.15.0 \
+ num_threads-0.1.6 \
+ object-0.30.3 \
+ once_cell-1.17.1 \
+ oorandom-11.1.3 \
+ os_str_bytes-6.4.1 \
+ output_vt100-0.1.3 \
+ pkg-config-0.3.26 \
+ plotters-0.3.4 \
+ plotters-backend-0.3.4 \
+ plotters-svg-0.3.3 \
+ predicates-2.1.5 \
+ predicates-core-1.0.5 \
+ predicates-tree-1.0.7 \
+ pretty_assertions-1.3.0 \
+ proc-macro2-1.0.51 \
+ pulldown-cmark-0.9.2 \
+ quick-error-1.2.3 \
+ quick-xml-0.24.1 \
+ quote-1.0.23 \
+ rayon-1.6.1 \
+ rayon-core-1.10.2 \
+ redox_syscall-0.2.16 \
+ regex-1.7.1 \
+ regex-automata-0.1.10 \
+ regex-syntax-0.6.28 \
+ remove_dir_all-0.5.3 \
+ rexpect-0.4.0 \
+ rpmalloc-0.2.2 \
+ rpmalloc-sys-0.2.3+b097fd0 \
+ rustc-demangle-0.1.21 \
+ ryu-1.0.12 \
+ same-file-1.0.6 \
+ scopeguard-1.1.0 \
+ scratch-1.0.3 \
+ semver-1.0.16 \
+ serde-1.0.152 \
+ serde_cbor-0.11.2 \
+ serde_derive-1.0.152 \
+ serde_json-1.0.93 \
+ shell-words-1.1.0 \
+ similar-2.2.1 \
+ simplelog-0.12.0 \
+ skeptic-0.13.7 \
+ strsim-0.10.0 \
+ syn-1.0.107 \
+ tempfile-3.3.0 \
+ termcolor-1.1.3 \
+ termtree-0.4.0 \
+ textwrap-0.11.0 \
+ textwrap-0.16.0 \
+ thiserror-1.0.38 \
+ thiserror-impl-1.0.38 \
+ time-0.1.45 \
+ time-0.3.19 \
+ time-core-0.1.0 \
+ time-macros-0.2.7 \
+ tinytemplate-1.2.1 \
+ unicase-2.6.0 \
+ unicode-ident-1.0.6 \
+ unicode-width-0.1.10 \
+ version_check-0.9.4 \
+ void-1.0.2 \
+ wait-timeout-0.2.0 \
+ walkdir-2.3.2 \
+ wasi-0.10.0+wasi-snapshot-preview1 \
+ wasm-bindgen-0.2.84 \
+ wasm-bindgen-backend-0.2.84 \
+ wasm-bindgen-macro-0.2.84 \
+ wasm-bindgen-macro-support-0.2.84 \
+ wasm-bindgen-shared-0.2.84 \
+ web-sys-0.3.61 \
+ winapi-0.3.9 \
+ winapi-i686-pc-windows-gnu-0.4.0 \
+ winapi-util-0.1.5 \
+ winapi-x86_64-pc-windows-gnu-0.4.0 \
+ windows-sys-0.42.0 \
+ windows_aarch64_gnullvm-0.42.1 \
+ windows_aarch64_msvc-0.42.1 \
+ windows_i686_gnu-0.42.1 \
+ windows_i686_msvc-0.42.1 \
+ windows_x86_64_gnu-0.42.1 \
+ windows_x86_64_gnullvm-0.42.1 \
+ windows_x86_64_msvc-0.42.1 \
+ winstructs-0.3.0 \
+ yaml-rust-0.4.5 \
+ yansi-0.5.1 \
+ zeroize-1.5.7
+
+PLIST_FILES= bin/evtx_dump
+
+.include <bsd.port.mk>