aboutsummaryrefslogtreecommitdiff
path: root/textproc/fixrtf/Makefile
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2006-03-16 07:50:15 +0000
committerXin LI <delphij@FreeBSD.org>2006-03-16 07:50:15 +0000
commitd6c39716159052b06f55e4896849b7ea4d6abee7 (patch)
tree98a61845e733d1e68a598f2d08d805199ec156bb /textproc/fixrtf/Makefile
parent7bf55dc55b759be66ba73d37bbcf4422edd0a39b (diff)
downloadports-d6c39716159052b06f55e4896849b7ea4d6abee7.tar.gz
ports-d6c39716159052b06f55e4896849b7ea4d6abee7.zip
Add fixrtf, an utility that is intended for use with the
Documentation Project, which can embed PNGs into RTF files. Obtained from: The FreeBSD Simplified Chinese Project Approved by: clive
Notes
Notes: svn path=/head/; revision=157386
Diffstat (limited to 'textproc/fixrtf/Makefile')
-rw-r--r--textproc/fixrtf/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/textproc/fixrtf/Makefile b/textproc/fixrtf/Makefile
new file mode 100644
index 000000000000..aa96fcd9474c
--- /dev/null
+++ b/textproc/fixrtf/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: fixrtf
+# Date created: 3 Mar 2006
+# Whom: Xin LI <delphij@FreeBSD.org>
+#
+# $FreeBSD$
+#
+# This port is self contained in the src directory.
+#
+
+PORTNAME= fixrtf
+PORTVERSION= 0.1.20060303
+CATEGORIES= textproc
+MASTER_SITES= # none
+DISTFILES= # none
+
+# Note: Updates from intron@intron.ac should also be
+# considered as maintainer updates.
+
+MAINTAINER= delphij@FreeBSD.org
+COMMENT= A patch making it possible to embed PNGs into RTFs
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+WRKSRC= ${WRKDIR}/src
+
+SRC= ${.CURDIR}/src
+
+do-fetch:
+ @${DO_NADA}
+
+pre-patch:
+ @${CP} -R ${SRC} ${WRKDIR}
+
+.include <bsd.port.mk>