aboutsummaryrefslogtreecommitdiff
path: root/textproc/fop/files
diff options
context:
space:
mode:
authorKiriyama Kazuhiko <kiri@FreeBSD.org>2002-08-10 12:41:31 +0000
committerKiriyama Kazuhiko <kiri@FreeBSD.org>2002-08-10 12:41:31 +0000
commit717e8f0a4ba4c40e178d01990db4b0f49bd9cc1f (patch)
treeb45fa4824ce65a0974ec16b1fe35bed721f3c752 /textproc/fop/files
parent114ce8a69d56b5a3b2850750333985caa620cf41 (diff)
downloadports-717e8f0a4ba4c40e178d01990db4b0f49bd9cc1f.tar.gz
ports-717e8f0a4ba4c40e178d01990db4b0f49bd9cc1f.zip
Update 0.20.3 -> 0.20.4. And additional modifications as follows:
o USE_JAVA=1.2+ and NO_BUILD_DEPENDS_JAVA o Fop installs DOCSDIR and DATADIR going around bsd.port.mk o fop.sh script suited to FreeBSD and install ${PREFIX}/bin/fop
Notes
Notes: svn path=/head/; revision=64331
Diffstat (limited to 'textproc/fop/files')
-rw-r--r--textproc/fop/files/patch-aa40
1 files changed, 40 insertions, 0 deletions
diff --git a/textproc/fop/files/patch-aa b/textproc/fop/files/patch-aa
new file mode 100644
index 000000000000..a864a5047a6f
--- /dev/null
+++ b/textproc/fop/files/patch-aa
@@ -0,0 +1,40 @@
+--- fop.sh.orig Sat Jul 6 03:06:22 2002
++++ fop.sh Sat Aug 3 14:45:50 2002
+@@ -1,5 +1,28 @@
+ #! /bin/sh
+ #
++# Common variables
++PREFIX=/usr/local
++
++# Default JAVACMD, JAVA_HOME, FOP_HOME
++JAVACMD=${JAVACMD:-`which javavm`}
++if [ -f ${PREFIX}/etc/javavms ]; then
++ JAVA_HOME=`head -1 /usr/local/etc/javavms | sed -e 's,/bin/java *#.*$,,'`
++elif [ -n "`echo ${PREFIX}/jdk*/bin/java 2> /dev/null`" ]; then
++ JAVA_HOME=`ls -d /usr/local/jdk*/bin/java | sort -r | head -1 | sed -e 's,/bin/java *$,,'`
++fi
++SHAREDIR=${PREFIX}/share
++FOP_HOME=${SHAREDIR}/fop
++DIRLIBS="\
++ ${FOP_HOME}/lib/xalan-2.3.1.jar
++ ${FOP_HOME}/lib/ant-1.4.1.jar
++ ${FOP_HOME}/lib/avalon-framework-cvs-20020315.jar
++ ${FOP_HOME}/lib/batik.jar
++ ${FOP_HOME}/lib/bsf.jar
++ ${FOP_HOME}/lib/buildtools.jar
++ ${FOP_HOME}/lib/stylebook.jar
++ ${FOP_HOME}/lib/xercesImpl-2.0.1.jar
++ ${FOP_HOME}/lib/xml-apis.jar"
++
+ # Shell script to run FOP, adapted from the Jakarta-Ant project.
+
+ if [ -f $HOME/.foprc ] ; then
+@@ -79,7 +102,7 @@
+ LOCALCLASSPATH=${FOP_HOME}/build/fop.jar:$LOCALCLASSPATH
+
+ # add in the dependency .jar files, which reside in $FOP_HOME/lib
+-DIRLIBS=${FOP_HOME}/lib/*.jar
++
+ for i in ${DIRLIBS}
+ do
+ # if the directory is empty, then it will return the input string