aboutsummaryrefslogtreecommitdiff
path: root/textproc/gnugrep/Makefile
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2010-08-15 00:51:33 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2010-08-15 00:51:33 +0000
commit03a3c6ca54f343d3df13b7bd20025b3e0ea4cda0 (patch)
tree386641f3d307846c214e73ef14071c336d883cf7 /textproc/gnugrep/Makefile
parentb7e72904e0e5a8baa5fca226a47c1091361cd5bb (diff)
downloadports-03a3c6ca54f343d3df13b7bd20025b3e0ea4cda0.tar.gz
ports-03a3c6ca54f343d3df13b7bd20025b3e0ea4cda0.zip
- Add support for NLS with the conventional WITHOUT_NLS knob to disable it
- Silence post-patch target - Bump PORTREVISION - Cosmetic changes PR: ports/149290 Submitted by: swell.k@gmail.com
Notes
Notes: svn path=/head/; revision=259248
Diffstat (limited to 'textproc/gnugrep/Makefile')
-rw-r--r--textproc/gnugrep/Makefile28
1 files changed, 18 insertions, 10 deletions
diff --git a/textproc/gnugrep/Makefile b/textproc/gnugrep/Makefile
index b83a38d36674..12730ea080c3 100644
--- a/textproc/gnugrep/Makefile
+++ b/textproc/gnugrep/Makefile
@@ -7,8 +7,8 @@
PORTNAME= grep
PORTVERSION= 2.6.3
-PORTREVISION= 2
-CATEGORIES= textproc
+PORTREVISION= 3
+CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMEPREFIX= gnu
@@ -16,25 +16,29 @@ PKGNAMEPREFIX= gnu
MAINTAINER= gabor@FreeBSD.org
COMMENT= GNU grep
-USE_GETTEXT= yes
+CONFLICTS= bsd-grep-*
+
+USE_XZ= yes
GNU_CONFIGURE= yes
+
MAN1= egrep.1 \
fgrep.1 \
grep.1
INFO= grep
-PLIST_FILES= bin/egrep \
- bin/fgrep \
- bin/grep
OPTIONS= PCRE "Compile with Perl-compatible regex support" off
-CONFLICTS= bsd-grep-*
-
-USE_XZ= yes
-
.include <bsd.port.pre.mk>
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+LDFLAGS+= -lintl -L${LOCALBASE}/lib
+PLIST_SUB+= NLS=
+.else
CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
.if defined(WITH_PCRE)
LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
@@ -43,6 +47,10 @@ CONFIGURE_ARGS+= --disable-perl-regexp
.endif
post-patch:
+.if defined(WITHOUT_NLS)
+ @${REINPLACE_CMD} '/install-exec-local:/s/install-exec-localcharset//' \
+ ${WRKSRC}/lib/Makefile.in
+.endif
@${REINPLACE_CMD} 's|mkinstalldirs = .*|mkinstalldirs = mkdir -p|g' \
${WRKSRC}/po/Makefile.in.in