aboutsummaryrefslogtreecommitdiff
path: root/textproc/gsed
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-02-17 20:53:56 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-02-17 20:53:56 +0000
commit5f1a08a32098b20944634c4ddfdd6a576bcc1648 (patch)
tree6bb1c217807f2bd3ecf257d5cb452bbbc490fa1c /textproc/gsed
parentf0cbf959baf100d245a80deaced1d8755c0e601e (diff)
downloadports-5f1a08a32098b20944634c4ddfdd6a576bcc1648.tar.gz
ports-5f1a08a32098b20944634c4ddfdd6a576bcc1648.zip
- Remove support for FreeBSD 4.x
Approved by: erwin (mentor, implicit)
Notes
Notes: svn path=/head/; revision=185392
Diffstat (limited to 'textproc/gsed')
-rw-r--r--textproc/gsed/Makefile6
-rw-r--r--textproc/gsed/files/extrapatch-lib-regexec.c43
2 files changed, 0 insertions, 49 deletions
diff --git a/textproc/gsed/Makefile b/textproc/gsed/Makefile
index 5ff12ce98072..c5d6426984a8 100644
--- a/textproc/gsed/Makefile
+++ b/textproc/gsed/Makefile
@@ -35,12 +35,6 @@ DOCSDIR= ${TARGETDIR}/share/doc/${PKGBASE}
.include <bsd.port.pre.mk>
-# Required for gcc 2.95 since it is pre-C99
-# and doesn't handle the 'bool' datatype properly.
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES= ${FILESDIR}/extrapatch-lib-regexec.c
-.endif
-
post-patch:
@${REINPLACE_CMD} 's,^\* sed:,* GNU sed:,' \
${WRKSRC}/doc/config.texi
diff --git a/textproc/gsed/files/extrapatch-lib-regexec.c b/textproc/gsed/files/extrapatch-lib-regexec.c
deleted file mode 100644
index a7842dc994e8..000000000000
--- a/textproc/gsed/files/extrapatch-lib-regexec.c
+++ /dev/null
@@ -1,43 +0,0 @@
-#
-# Required for gcc 2.95 since it is pre-C99
-# and doesn't handle the 'bool' datatype properly.
-#
---- lib/regexec.c.orig Sat Apr 15 20:53:36 2006
-+++ lib/regexec.c Sat Apr 15 21:17:03 2006
-@@ -3296,8 +3296,7 @@
- reg_errcode_t err;
- int i, j, ch, need_word_trtable = 0;
- bitset_word_t elem, mask;
-- bool dests_node_malloced = false;
-- bool dest_states_malloced = false;
-+ int dests_node_malloced = 0, dest_states_malloced = 0;
- int ndests; /* Number of the destination states from `state'. */
- re_dfastate_t **trtable;
- re_dfastate_t **dest_states = NULL, **dest_states_word, **dest_states_nl;
-@@ -3322,7 +3321,7 @@
- dests_alloc = re_malloc (struct dests_alloc, 1);
- if (BE (dests_alloc == NULL, 0))
- return 0;
-- dests_node_malloced = true;
-+ dests_node_malloced = 1;
- }
- dests_node = dests_alloc->dests_node;
- dests_ch = dests_alloc->dests_ch;
-@@ -3371,7 +3370,7 @@
- free (dests_alloc);
- return 0;
- }
-- dest_states_malloced = true;
-+ dest_states_malloced = 1;
- }
- dest_states_word = dest_states + ndests;
- dest_states_nl = dest_states_word + ndests;
-@@ -3576,7 +3575,7 @@
- {
- if (constraint & NEXT_NEWLINE_CONSTRAINT)
- {
-- bool accepts_newline = bitset_contain (accepts, NEWLINE_CHAR);
-+ int accepts_newline = bitset_contain (accepts, NEWLINE_CHAR);
- bitset_empty (accepts);
- if (accepts_newline)
- bitset_set (accepts, NEWLINE_CHAR);