aboutsummaryrefslogtreecommitdiff
path: root/textproc/htdig/Makefile
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2004-03-19 18:29:11 +0000
committerDoug Barton <dougb@FreeBSD.org>2004-03-19 18:29:11 +0000
commit07c597671fe163633f348056a98b6e5497f51325 (patch)
treefeacb82e9a37a31ad4d32f66f336ce301285fd0e /textproc/htdig/Makefile
parent67c5a731d1bb2006cda2e5511781f95f482dfa8a (diff)
downloadports-07c597671fe163633f348056a98b6e5497f51325.tar.gz
ports-07c597671fe163633f348056a98b6e5497f51325.zip
Major overhaul of the port to celebrate the upgrade to 3.2.0b5.
The 3.2.x series contains many enhanced features, most notably built in SSL capabilities. Changes for the port itself: 1. Add new MASTER_SITES. 2. Search for an apache binary, not a document directory. 3. The new version uses libtool, so add USE_LIBTOOL per portlint. 4. The new configure script is much more thorough, so use a more complete set of options, and sort them in "./configure --help" order. 5. CXXFLAGS hackery no longer needed in FreeBSD 5.x, but 6. A patch to include headers for select() is needed in RELENG_4. 7. Install PORTDOCS, especially the very thorough html help files. 8. Add SIZE to distinfo. 9. Make deletion of directories with user-configurable stuff conditional.
Notes
Notes: svn path=/head/; revision=104648
Diffstat (limited to 'textproc/htdig/Makefile')
-rw-r--r--textproc/htdig/Makefile53
1 files changed, 27 insertions, 26 deletions
diff --git a/textproc/htdig/Makefile b/textproc/htdig/Makefile
index 622e121c9fa1..b2281d962711 100644
--- a/textproc/htdig/Makefile
+++ b/textproc/htdig/Makefile
@@ -6,48 +6,49 @@
#
PORTNAME= htdig
-PORTVERSION= 3.1.6
+PORTVERSION= 3.2.0.b5
CATEGORIES= textproc www
-MASTER_SITES= http://www.htdig.org/files/ \
+MASTER_SITES= http://htdig.sourceforge.net/files/ \
+ http://www.htdig.org/files/ \
+ http://www.opdenbrouw.nl/htdig/files/ \
ftp://ftp.ntua.gr/pub/www/htdig/
+DISTNAME= htdig-3.2.0b5
MAINTAINER= DougB@FreeBSD.org
COMMENT= A www indexing and searching system
-RUN_DEPENDS= ${LOCALBASE}/share/doc/apache:${PORTSDIR}/${APACHE_PORT}
+RUN_DEPENDS= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/${APACHE_PORT}
+
+USE_LIBTOOL= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-cgi-bin-dir=${PREFIX}/share/apache/cgi-bin \
- --with-image-dir=${PREFIX}/share/apache/icons/htdig \
- --with-search-dir=${PREFIX}/share/apache/htdocs \
+CONFIGURE_ARGS= --with-config-dir=${PREFIX}/etc/htdig \
+ --with-default-config-file=${PREFIX}/etc/htdig/htdig.conf \
--with-common-dir=${PREFIX}/share/htdig/common \
--with-database-dir=${PREFIX}/share/htdig/database \
- --with-config-dir=${PREFIX}/etc/htdig \
- --with-default-config-file=${PREFIX}/etc/htdig/htdig.conf
+ --with-cgi-bin-dir=${PREFIX}/www/cgi-bin \
+ --with-search-dir=${PREFIX}/www/data \
+ --with-image-dir=${PREFIX}/www/icons/htdig \
+ --with-image-url-prefix=/icons/htdig \
+ --with-ssl \
+ --with-apache=${LOCALBASE}/sbin
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500037
-CONFIGURE_ENV+= CXXFLAGS=-Wno-deprecated CPPFLAGS=-Wno-deprecated
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES+= ${PATCHDIR}/RELENG_4-patch-htnet_SSLConnection.cc
.endif
-BUILD_TARGET= depends all
-
-post-patch:
-.for file in CONFIG CONFIG.in
- @ ${CP} ${WRKSRC}/${file} ${WRKSRC}/${file}.Dist
- @ ${SED} -e 's#/conf#/etc#' \
- -e 's#/common#/share/htdig#' \
- -e 's#/db#/share/htdig#' \
- ${WRKSRC}/${file}.Dist > ${WRKSRC}/${file}
+post-install:
+ @${MV} ${PREFIX}/etc/htdig/htdig.conf ${PREFIX}/etc/htdig/htdig.conf.sample
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}/html
+.for f in ChangeLog ChangeLog.0 README STATUS
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
-.for file in dist/configure dist/configure.in docs/ref/program/thread.html
- @ ${CP} ${WRKSRC}/db/${file} ${WRKSRC}/db/${file}.Dist
- @ ${SED} -e 's#-lc_r#${PTHREAD_LIBS:S/"//g}#g' \
- ${WRKSRC}/db/${file}.Dist > ${WRKSRC}/db/${file}
+.for f in *.html *.gif
+ @${INSTALL_DATA} ${WRKSRC}/htdoc/${f} ${DOCSDIR}/html
.endfor
-
-post-install:
- @ ${MV} ${PREFIX}/etc/htdig/htdig.conf ${PREFIX}/etc/htdig/htdig.conf.sample
+.endif
.include <bsd.port.post.mk>