aboutsummaryrefslogtreecommitdiff
path: root/textproc/iiimf-x
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-12-29 04:17:02 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-12-29 04:17:02 +0000
commit3dc8a49a429115a7f5fa06013babc24f2f02ba39 (patch)
tree8ff87e2ce45015285a92175dec045ada6f9d2c9e /textproc/iiimf-x
parent43916cb62fba4e0daebc0e383aeb44d744f166d5 (diff)
downloadports-3dc8a49a429115a7f5fa06013babc24f2f02ba39.tar.gz
ports-3dc8a49a429115a7f5fa06013babc24f2f02ba39.zip
New port: iiimf-*
IIIMF stands for Internet/Intranet Input Method Framework. IIIMF is designed to be the next generation of input method framework which provides the following capabilities; * Multiplatform, platform independent. * Multlingual and Full UNICODE support, but satisfactory for native speakers. * Windowing System Independent. * Multiple language engines concurrently run. * Multiuser. * Distributed, lightweight clients and scalable server. * Extensible in multiple means. * Input method protocol efficient enough to be used over low-speed modem connection. * Easy input method engine development with plugin API. * Easy input method enabling with libiiimcf, even on console apps. * Small core part to start from. WWW: http://www.openi18n.org/subgroups/im/IIIMF/ - Kuang-che Wu kcwu@csie.org PR: ports/60087 Submitted by: Kuang-che Wu <kcwu@csie.org>
Notes
Notes: svn path=/head/; revision=96816
Diffstat (limited to 'textproc/iiimf-x')
-rw-r--r--textproc/iiimf-x/Makefile66
-rw-r--r--textproc/iiimf-x/distinfo1
-rw-r--r--textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IMdkit_Makefile.in13
-rw-r--r--textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_watchdog.c47
-rw-r--r--textproc/iiimf-x/files/patch-iiimxcf_xiiimp.so_iiimp_Makefile.in22
-rw-r--r--textproc/iiimf-x/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpAux.c11
-rw-r--r--textproc/iiimf-x/pkg-descr21
-rw-r--r--textproc/iiimf-x/pkg-plist7
8 files changed, 188 insertions, 0 deletions
diff --git a/textproc/iiimf-x/Makefile b/textproc/iiimf-x/Makefile
new file mode 100644
index 000000000000..381589ee91e6
--- /dev/null
+++ b/textproc/iiimf-x/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: iiimf-x
+# Date created: 6 Dec 2003
+# Whom: Kuang-che Wu <kcwu@csie.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= iiimf-x
+PORTVERSION= ${IIIMF_VER:S/_/./:C/-.*//}
+CATEGORIES= textproc
+MASTER_SITES= http://www.openi18n.org/download/docs/im-sdk/
+DISTNAME= im-sdk
+DISTFILES= ${DISTNAME}.${IIIMF_VER:S/-/./}${EXTRACT_SUFX}
+
+MAINTAINER= kcwu@csie.org
+COMMENT= Internet/Intranet Input Method X Client Framework
+
+LIB_DEPENDS= iiimp.0:${PORTSDIR}/textproc/iiimf-protocol-lib \
+ iiimcf.2:${PORTSDIR}/textproc/iiimf-client-lib
+
+IIIMF_VER= r11_4-1467
+WRKSRC= ${WRKDIR}/${DISTNAME}-${IIIMF_VER}
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_XLIB= yes
+INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+HAS_CONFIGURE= yes
+USE_MOTIF= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+DIRS= iiimxcf/xiiimp.so iiimxcf/htt_xbe
+
+post-patch:
+.for DIR in ${DIRS}
+ ${REINPLACE_CMD} -e "s,-lpthread,-pthread,g" \
+ -e "s,-D_POSIX_C_SOURCE=199506L,,g" \
+ -e "s,has_xiccallback=no,has_xiccallback=yes,g" \
+ -e "s,/usr/lib/im,${LOCALBASE}/lib/im,g" \
+ -e "s,-I\$$(IM_INCLUDEDIR),-I${LOCALBASE}/include/iiimf,g" \
+ ${WRKSRC}/${DIR}/configure
+ ${REINPLACE_CMD} -e "s,/usr/lib/im,${PREFIX}/lib/im,g" \
+ ${WRKSRC}/iiimxcf/xiiimp.so/iiimp/Makefile.in \
+ ${WRKSRC}/iiimxcf/xiiimp.so/iiimp/iiimpAux.c \
+ ${WRKSRC}/iiimxcf/xiiimp.so/iiimp/iiimpIM.c \
+ ${WRKSRC}/iiimxcf/xiiimp.so/iiimp/iiimpConv.c \
+ ${WRKSRC}/iiimxcf/xiiimp.so/iiimp/csconv.h \
+ ${WRKSRC}/iiimxcf/htt_xbe/lib/IMdkit/common/XIMPublic.cpp \
+ ${WRKSRC}/iiimxcf/htt_xbe/src/watchdog.c
+.endfor
+
+do-configure:
+.for DIR in ${DIRS}
+ cd ${WRKSRC}/${DIR} && ${SH} configure ${CONFIGURE_ARGS}
+.endfor
+
+do-build:
+.for DIR in ${DIRS}
+ cd ${WRKSRC}/${DIR} && ${GMAKE} all
+.endfor
+
+do-install:
+.for DIR in ${DIRS}
+ cd ${WRKSRC}/${DIR} && ${GMAKE} install
+.endfor
+
+.include <bsd.port.mk>
diff --git a/textproc/iiimf-x/distinfo b/textproc/iiimf-x/distinfo
new file mode 100644
index 000000000000..4ec913af341f
--- /dev/null
+++ b/textproc/iiimf-x/distinfo
@@ -0,0 +1 @@
+MD5 (im-sdk.r11_4.1467.tar.bz2) = ca6b6ac7c41641db6eaa0fa395748f90
diff --git a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IMdkit_Makefile.in b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IMdkit_Makefile.in
new file mode 100644
index 000000000000..ce8a106a194e
--- /dev/null
+++ b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IMdkit_Makefile.in
@@ -0,0 +1,13 @@
+--- iiimxcf/htt_xbe/lib/IMdkit/Makefile.in.orig Sat Dec 6 05:14:14 2003
++++ iiimxcf/htt_xbe/lib/IMdkit/Makefile.in Sat Dec 6 05:52:09 2003
+@@ -74,8 +74,8 @@
+ LINKER = @LINKER@
+ RANLIB = @RANLIB@
+
+-CFLAGS = @CFLAGS@
+-CXXFLAGS = @CXXFLAGS@
++CFLAGS = @CFLAGS@ @X_CFLAGS@
++CXXFLAGS = @CXXFLAGS@ @X_CFLAGS@
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+
diff --git a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_watchdog.c b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_watchdog.c
new file mode 100644
index 000000000000..60dc3b52a363
--- /dev/null
+++ b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_watchdog.c
@@ -0,0 +1,47 @@
+--- iiimxcf/htt_xbe/src/watchdog.c.orig Sat Dec 6 05:54:41 2003
++++ iiimxcf/htt_xbe/src/watchdog.c Sat Dec 6 06:01:13 2003
+@@ -187,7 +187,11 @@
+ * Setup the signal handlers to monitor htt_server, htt_props
+ * abnormal termination
+ */
++#if defined(__FreeBSD__)
++ setsid();
++#else
+ grpid = setpgrp();
++#endif
+
+ #ifdef SunOS
+ sigset(SIGTERM, clean_up);
+@@ -309,7 +313,7 @@
+ XChangeProperty(display, httw_id, class_atom, XA_STRING, 8,
+ PropModeReplace, "htt", strlen("htt"));
+
+- XSetWMProtocols(display, httw_id, &htt_save_atom, 3);
++ XSetWMProtocols(display, httw_id, htt_save_atom, 3);
+
+ XSelectInput(display, httw_id, PropertyChangeMask | StructureNotifyMask);
+ XSetSelectionOwner(display, htt_atom, httw_id, CurrentTime);
+@@ -703,7 +707,11 @@
+ * most of the cases
+ */
+ sleep(1);
++#if defined(__FreeBSD__)
++ setsid();
++#else
+ setpgrp();
++#endif
+ #ifdef SunOS
+ if (flag == OPENWIN_PATH) {
+ putenv(OPENWIN_MOTIF_PRELOAD_ENV);
+@@ -734,7 +742,11 @@
+ perror("watchdog:fork\n");
+ exit(errno);
+ case 0:
++#if defined(__FreeBSD__)
++ setsid();
++#else
+ setpgrp();
++#endif
+ if (!my_rdb.respond_to_sm)
+ sleep(10);
+ execv(pathname, argv);
diff --git a/textproc/iiimf-x/files/patch-iiimxcf_xiiimp.so_iiimp_Makefile.in b/textproc/iiimf-x/files/patch-iiimxcf_xiiimp.so_iiimp_Makefile.in
new file mode 100644
index 000000000000..bacced162b1d
--- /dev/null
+++ b/textproc/iiimf-x/files/patch-iiimxcf_xiiimp.so_iiimp_Makefile.in
@@ -0,0 +1,22 @@
+--- iiimxcf/xiiimp.so/iiimp/Makefile.in.orig Sun Dec 7 20:00:38 2003
++++ iiimxcf/xiiimp.so/iiimp/Makefile.in Sun Dec 7 20:01:19 2003
+@@ -138,8 +138,7 @@
+ # you have to add the following by yourself to check undefined symbols.
+ # -Wl,-z -Wl,defs
+ xiiimp_la_LIBADD = $(X_LIBS) \
+- $(IM_LIBDIR)/iiimcf/libiiimcf.la \
+- $(IM_LIBDIR)/iiimp/libiiimp.la \
++ -L$(prefix)/lib -liiimcf -liiimp \
+ $(DLOPEN_LIBS) $(THREAD_LIBS)
+
+ xiiimp_la_SOURCES = \
+@@ -190,8 +189,7 @@
+ CONFIG_CLEAN_FILES =
+ LTLIBRARIES = $(module_LTLIBRARIES)
+
+-xiiimp_la_DEPENDENCIES = $(IM_LIBDIR)/iiimcf/libiiimcf.la \
+- $(IM_LIBDIR)/iiimp/libiiimp.la
++xiiimp_la_DEPENDENCIES =
+ am_xiiimp_la_OBJECTS = xiiimp_la-genutil.lo xiiimp_la-KeyMap.lo \
+ xiiimp_la-guiIMLookup.lo xiiimp_la-XeIMWrap.lo \
+ xiiimp_la-guiIMPre.lo xiiimp_la-lookup.lo xiiimp_la-XimpConv.lo \
diff --git a/textproc/iiimf-x/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpAux.c b/textproc/iiimf-x/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpAux.c
new file mode 100644
index 000000000000..06b9e60c1d75
--- /dev/null
+++ b/textproc/iiimf-x/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpAux.c
@@ -0,0 +1,11 @@
+--- iiimxcf/xiiimp.so/iiimp/iiimpAux.c.orig Sat Dec 6 04:07:05 2003
++++ iiimxcf/xiiimp.so/iiimp/iiimpAux.c Sat Dec 6 04:07:42 2003
+@@ -61,7 +61,7 @@
+ #include <strings.h>
+ #include <ctype.h>
+ #include <sys/param.h>
+-#ifndef linux
++#if !defined(linux) && !defined(__FreeBSD__)
+ #include <synch.h>
+ #endif
+
diff --git a/textproc/iiimf-x/pkg-descr b/textproc/iiimf-x/pkg-descr
new file mode 100644
index 000000000000..ac72b20e8941
--- /dev/null
+++ b/textproc/iiimf-x/pkg-descr
@@ -0,0 +1,21 @@
+IIIMF stands for Internet/Intranet Input Method Framework.
+IIIMF is designed to be the next generation of input method framework
+which provides the following capabilities;
+
+* Multiplatform, platform independent.
+* Multlingual and Full UNICODE support, but satisfactory for native speakers.
+* Windowing System Independent.
+* Multiple language engines concurrently run.
+* Multiuser.
+* Distributed, lightweight clients and scalable server.
+* Extensible in multiple means.
+* Input method protocol efficient enough to be used over low-speed modem
+ connection.
+* Easy input method engine development with plugin API.
+* Easy input method enabling with libiiimcf, even on console apps.
+* Small core part to start from.
+
+WWW: http://www.openi18n.org/subgroups/im/IIIMF/
+
+- Kuang-che Wu
+ kcwu@csie.org
diff --git a/textproc/iiimf-x/pkg-plist b/textproc/iiimf-x/pkg-plist
new file mode 100644
index 000000000000..a3f00a8c9dfb
--- /dev/null
+++ b/textproc/iiimf-x/pkg-plist
@@ -0,0 +1,7 @@
+lib/im/xiiimp.so.2
+lib/im/xiiimp.so
+lib/im/xiiimp.la
+lib/im/xiiimp.a
+lib/im/htt_xbe
+lib/im/httx
+@dirrm lib/im