aboutsummaryrefslogtreecommitdiff
path: root/textproc/kf5-sonnet
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-01-07 14:43:11 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-01-07 14:43:11 +0000
commit24bce6e056c149dd378d4037aece66e49a080a10 (patch)
tree39e124d9784854ef550ebb66d8d0501c1889259a /textproc/kf5-sonnet
parent2018ddae97c2e3406691f0141c1bc14bc6d79587 (diff)
downloadports-24bce6e056c149dd378d4037aece66e49a080a10.tar.gz
ports-24bce6e056c149dd378d4037aece66e49a080a10.zip
textproc/hunspell: update to 1.6.0
- Restore DIST_SUBDIR from r305651 - Adjust license for "or later" clause - Restore GPLv2+/LGPL21+ license files removed upstream as GPLv3+/LGPL3+ only affects Hunspell 2.0 (not currently built) - Unbreak |make makepatch| Changes: https://github.com/hunspell/hunspell/releases/tag/v1.6.0 PR: 215714 Submitted by: sunpoet (based on) Exp-run by: antoine MFH: 2017Q1 Differential Revision: https://reviews.freebsd.org/D8887
Notes
Notes: svn path=/head/; revision=430796
Diffstat (limited to 'textproc/kf5-sonnet')
-rw-r--r--textproc/kf5-sonnet/Makefile3
-rw-r--r--textproc/kf5-sonnet/files/patch-cmake_FindHUNSPELL.cmake12
2 files changed, 14 insertions, 1 deletions
diff --git a/textproc/kf5-sonnet/Makefile b/textproc/kf5-sonnet/Makefile
index bb7efc49215f..1445c919eeb4 100644
--- a/textproc/kf5-sonnet/Makefile
+++ b/textproc/kf5-sonnet/Makefile
@@ -3,13 +3,14 @@
PORTNAME= sonnet
PORTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= textproc kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
COMMENT= KF5 plugin-based spell checking library
LIB_DEPENDS= libaspell.so:textproc/aspell \
- libhunspell-1.5.so:textproc/hunspell
+ libhunspell-1.6.so:textproc/hunspell
USES= cmake:outsource compiler:c++11-lib kde:5 tar:xz
USE_KDE= ecm
diff --git a/textproc/kf5-sonnet/files/patch-cmake_FindHUNSPELL.cmake b/textproc/kf5-sonnet/files/patch-cmake_FindHUNSPELL.cmake
new file mode 100644
index 000000000000..00e5a0848cd8
--- /dev/null
+++ b/textproc/kf5-sonnet/files/patch-cmake_FindHUNSPELL.cmake
@@ -0,0 +1,12 @@
+--- cmake/FindHUNSPELL.cmake.orig 2016-12-03 21:15:34 UTC
++++ cmake/FindHUNSPELL.cmake
+@@ -14,7 +14,8 @@ ENDIF (HUNSPELL_INCLUDE_DIR AND HUNSPELL
+
+ FIND_PATH(HUNSPELL_INCLUDE_DIR hunspell/hunspell.hxx )
+
+-FIND_LIBRARY(HUNSPELL_LIBRARIES NAMES hunspell-1.5 hunspell-1.4 hunspell-1.3 hunspell-1.2)
++FIND_LIBRARY(HUNSPELL_LIBRARIES NAMES hunspell-1.6
++ hunspell-1.5 hunspell-1.4 hunspell-1.3 hunspell-1.2 hunspell)
+
+ # handle the QUIETLY and REQUIRED arguments and set HUNSPELL_FOUND to TRUE if
+ # all listed variables are TRUE