aboutsummaryrefslogtreecommitdiff
path: root/textproc/libfolia
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-06-25 00:23:59 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-06-25 04:01:33 +0000
commit36660836220ec67d969b6ebeb8a048a147c6b6c2 (patch)
tree0e963b53f65c0f59652fd866b878845341010e38 /textproc/libfolia
parentdfecbd271349b127c134f293e9978657b2b034ca (diff)
downloadports-36660836220ec67d969b6ebeb8a048a147c6b6c2.tar.gz
ports-36660836220ec67d969b6ebeb8a048a147c6b6c2.zip
textproc/libfolia: Use upstream release archive and minor fixes
PR: 272176
Diffstat (limited to 'textproc/libfolia')
-rw-r--r--textproc/libfolia/Makefile12
-rw-r--r--textproc/libfolia/distinfo6
-rw-r--r--textproc/libfolia/files/patch-src_Makefile.am11
3 files changed, 9 insertions, 20 deletions
diff --git a/textproc/libfolia/Makefile b/textproc/libfolia/Makefile
index f3b7326175f0..ec4b9c4aacd5 100644
--- a/textproc/libfolia/Makefile
+++ b/textproc/libfolia/Makefile
@@ -1,7 +1,7 @@
PORTNAME= libfolia
-DISTVERSIONPREFIX= v
DISTVERSION= 2.15
CATEGORIES= textproc
+MASTER_SITES= https://github.com/LanguageMachines/${PORTNAME}/releases/download/v${DISTVERSION}/
MAINTAINER= yuri@FreeBSD.org
COMMENT= Library for FoLiA, a format for annotated language resources
@@ -10,20 +10,20 @@ WWW= https://proycon.github.io/folia/
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= autoconf-archive>=0:devel/autoconf-archive
LIB_DEPENDS= libicui18n.so:devel/icu \
libticcutils.so:devel/ticcutils
-USES= autoreconf compiler:c++14-lang gmake gnome libtool pkgconfig
+USES= compiler:c++14-lang gmake gnome libtool pkgconfig
USE_GNOME= libxml2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-static
-USE_GITHUB= yes
-GH_ACCOUNT= LanguageMachines
-
INSTALL_TARGET= install-strip
+post-patch:
+ @${REINPLACE_CMD} -e 's|-g -O3||g' \
+ ${PATCH_WRKSRC}/src/Makefile.in
+
.include <bsd.port.mk>
diff --git a/textproc/libfolia/distinfo b/textproc/libfolia/distinfo
index 14184a233dbb..c49605850d23 100644
--- a/textproc/libfolia/distinfo
+++ b/textproc/libfolia/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1685379963
-SHA256 (LanguageMachines-libfolia-v2.15_GH0.tar.gz) = c62f2707227d3f6b37089a7c83d870c08de318fc5739487a6e2836605328dff1
-SIZE (LanguageMachines-libfolia-v2.15_GH0.tar.gz) = 198072
+TIMESTAMP = 1687518481
+SHA256 (libfolia-2.15.tar.gz) = e6f31069a13fb87a0c3330ef6037c5dd9df43e9e6f1d22d301f158bab03eafe4
+SIZE (libfolia-2.15.tar.gz) = 610180
diff --git a/textproc/libfolia/files/patch-src_Makefile.am b/textproc/libfolia/files/patch-src_Makefile.am
deleted file mode 100644
index 730f0367ae50..000000000000
--- a/textproc/libfolia/files/patch-src_Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
-- remove compiler flags related to debug and optimization
-
---- src/Makefile.am.orig 2023-05-08 10:47:18 UTC
-+++ src/Makefile.am
-@@ -1,5 +1,5 @@
- AM_CPPFLAGS = -I@top_srcdir@/include
--AM_CXXFLAGS = -std=c++14 -g -O3 -W -Wall -pedantic
-+AM_CXXFLAGS = -std=c++14 -W -Wall -pedantic
-
-
- LDADD = libfolia.la