aboutsummaryrefslogtreecommitdiff
path: root/textproc/libmrss/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-01-02 08:42:42 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-01-02 08:42:42 +0000
commita50b2262b4a0b46254708ed4b8fc87a479802c14 (patch)
treea43acd23a4867a3091f7154977c7cbc452b45b4a /textproc/libmrss/Makefile
parent48ba81f6180e995b2f767caa8aeb3abdc7d9e851 (diff)
downloadports-a50b2262b4a0b46254708ed4b8fc87a479802c14.tar.gz
ports-a50b2262b4a0b46254708ed4b8fc87a479802c14.zip
mRss is a C library for parsing, writing and creating RSS files or streams.
Notes
Notes: svn path=/head/; revision=181257
Diffstat (limited to 'textproc/libmrss/Makefile')
-rw-r--r--textproc/libmrss/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/textproc/libmrss/Makefile b/textproc/libmrss/Makefile
new file mode 100644
index 000000000000..2a706fa6a327
--- /dev/null
+++ b/textproc/libmrss/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: libmrss
+# Date created: Jan 2, 2007
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libmrss
+PORTVERSION= 0.16
+CATEGORIES= textproc
+MASTER_SITES= http://www2.autistici.org/bakunin/libmrss/
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= A C library for parsing, writing, and creating RSS
+
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
+LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl \
+ nxml:${PORTSDIR}/textproc/libnxml
+
+GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
+USE_LDCONFIG= yes
+WANT_GNOME= yes
+
+pre-patch:
+ ${gnomehack_PRE_PATCH}
+
+.include <bsd.port.mk>