aboutsummaryrefslogtreecommitdiff
path: root/textproc/libutf8proc
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2016-03-20 16:34:30 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2016-03-20 16:34:30 +0000
commitc33b3f73a26b4a6f294c75f3fdb1c307bda1aed6 (patch)
tree3b7a67eda315e3a2b6ec506e9925c6076a1677d4 /textproc/libutf8proc
parentec8ac903fcbc9ed2b5c61fc29552ecaae061a392 (diff)
downloadports-c33b3f73a26b4a6f294c75f3fdb1c307bda1aed6.tar.gz
ports-c33b3f73a26b4a6f294c75f3fdb1c307bda1aed6.zip
This is the Public software group utf8proc library repackaged as a
conveniance library for NetSurf. This takes the unicode 5 capable version 1.1.6 of the library and converts it to the NetSurf build system. additional API has been added with a normalisation function but there are no data changes from upstream. WWW: http://www.netsurf-browser.org/
Notes
Notes: svn path=/head/; revision=411464
Diffstat (limited to 'textproc/libutf8proc')
-rw-r--r--textproc/libutf8proc/Makefile29
-rw-r--r--textproc/libutf8proc/distinfo2
-rw-r--r--textproc/libutf8proc/files/patch-Makefile10
-rw-r--r--textproc/libutf8proc/files/patch-libutf8proc.pc.in10
-rw-r--r--textproc/libutf8proc/pkg-descr9
-rw-r--r--textproc/libutf8proc/pkg-plist5
6 files changed, 65 insertions, 0 deletions
diff --git a/textproc/libutf8proc/Makefile b/textproc/libutf8proc/Makefile
new file mode 100644
index 000000000000..7eb2da368dd1
--- /dev/null
+++ b/textproc/libutf8proc/Makefile
@@ -0,0 +1,29 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+
+PORTNAME= libutf8proc
+PORTVERSION= 1.3.1
+CATEGORIES= textproc
+MASTER_SITES= http://download.netsurf-browser.org/libs/releases/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= olivierd@FreeBSD.org
+COMMENT= UTF8 Processing library
+
+LICENSE= MIT
+
+BUILD_DEPENDS= netsurf-buildsystem>=1.5:${PORTSDIR}/devel/netsurf-buildsystem
+
+USES= gmake
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//}
+
+MAKE_ENV+= COMPONENT_TYPE="lib-shared"
+
+PLIST_SUB+= VERSION=${PORTVERSION}
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libutf8proc.so*
+
+.include <bsd.port.mk>
diff --git a/textproc/libutf8proc/distinfo b/textproc/libutf8proc/distinfo
new file mode 100644
index 000000000000..5f9017a926d4
--- /dev/null
+++ b/textproc/libutf8proc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libutf8proc-1.3.1-src.tar.gz) = 78e950bfc691182d3b61109b1b4e234399743607231f72a395331a367c2ac675
+SIZE (libutf8proc-1.3.1-src.tar.gz) = 144963
diff --git a/textproc/libutf8proc/files/patch-Makefile b/textproc/libutf8proc/files/patch-Makefile
new file mode 100644
index 000000000000..d003e53f7481
--- /dev/null
+++ b/textproc/libutf8proc/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.orig 2016-01-07 00:18:19 UTC
++++ Makefile
+@@ -46,5 +46,5 @@ endif
+ # Extra installation rules
+ I := /$(INCLUDEDIR)/libutf8proc
+ INSTALL_ITEMS := $(INSTALL_ITEMS) $(I):include/libutf8proc/utf8proc.h
+-INSTALL_ITEMS := $(INSTALL_ITEMS) /$(LIBDIR)/pkgconfig:lib$(COMPONENT).pc.in
+-INSTALL_ITEMS := $(INSTALL_ITEMS) /$(LIBDIR):$(OUTPUT)
++INSTALL_ITEMS := $(INSTALL_ITEMS) /libdata/pkgconfig:lib$(COMPONENT).pc.in
++INSTALL_ITEMS := $(INSTALL_ITEMS) /lib:$(OUTPUT)
diff --git a/textproc/libutf8proc/files/patch-libutf8proc.pc.in b/textproc/libutf8proc/files/patch-libutf8proc.pc.in
new file mode 100644
index 000000000000..4ae04249b66d
--- /dev/null
+++ b/textproc/libutf8proc/files/patch-libutf8proc.pc.in
@@ -0,0 +1,10 @@
+--- libutf8proc.pc.in.orig 2016-01-07 00:18:19 UTC
++++ libutf8proc.pc.in
+@@ -1,6 +1,6 @@
+ prefix=PREFIX
+ exec_prefix=${prefix}
+-libdir=${exec_prefix}/LIBDIR
++libdir=${exec_prefix}/lib
+ includedir=${prefix}/INCLUDEDIR
+
+ Name: libutf8proc
diff --git a/textproc/libutf8proc/pkg-descr b/textproc/libutf8proc/pkg-descr
new file mode 100644
index 000000000000..85e43d017d3f
--- /dev/null
+++ b/textproc/libutf8proc/pkg-descr
@@ -0,0 +1,9 @@
+This is the Public software group utf8proc library repackaged as a
+conveniance library for NetSurf.
+
+This takes the unicode 5 capable version 1.1.6 of the library and
+converts it to the NetSurf build system. additional API has been added
+with a normalisation function but there are no data changes from
+upstream.
+
+WWW: http://www.netsurf-browser.org/
diff --git a/textproc/libutf8proc/pkg-plist b/textproc/libutf8proc/pkg-plist
new file mode 100644
index 000000000000..82ea399fc9c2
--- /dev/null
+++ b/textproc/libutf8proc/pkg-plist
@@ -0,0 +1,5 @@
+include/libutf8proc/utf8proc.h
+lib/libutf8proc.so
+lib/libutf8proc.so.1
+lib/libutf8proc.so.%%VERSION%%
+libdata/pkgconfig/libutf8proc.pc