aboutsummaryrefslogtreecommitdiff
path: root/textproc/libxml++
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-02-25 18:49:50 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-02-25 18:49:50 +0000
commitdb9acc6417fad27b313f26f6151ed0d8c59ab039 (patch)
treeaa78b7a4f750736a2a13d02cb4d198b47fe995c8 /textproc/libxml++
parent765c187ae2ceb0ad5dd41ab6383e58396cc74982 (diff)
downloadports-db9acc6417fad27b313f26f6151ed0d8c59ab039.tar.gz
ports-db9acc6417fad27b313f26f6151ed0d8c59ab039.zip
add libxml++, XML API for C++
Notes
Notes: svn path=/head/; revision=38702
Diffstat (limited to 'textproc/libxml++')
-rw-r--r--textproc/libxml++/Makefile29
-rw-r--r--textproc/libxml++/distinfo1
-rw-r--r--textproc/libxml++/pkg-comment1
-rw-r--r--textproc/libxml++/pkg-descr5
-rw-r--r--textproc/libxml++/pkg-plist6
5 files changed, 42 insertions, 0 deletions
diff --git a/textproc/libxml++/Makefile b/textproc/libxml++/Makefile
new file mode 100644
index 000000000000..2fd0adc70d10
--- /dev/null
+++ b/textproc/libxml++/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# New ports collection makefile for: libxml++
+# Date created: Feb 26, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libxml++
+PORTVERSION= 0.11
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME:S/+/plus/g}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${PERL} -pi -e "s|xml-config|xml2-config|g" ${WRKSRC}/configure
+ @${PERL} -pi -e "s|libxml/|libxml2/|g" ${WRKSRC}/xml++.h
+
+.include <bsd.port.mk>
diff --git a/textproc/libxml++/distinfo b/textproc/libxml++/distinfo
new file mode 100644
index 000000000000..b1fa474487f7
--- /dev/null
+++ b/textproc/libxml++/distinfo
@@ -0,0 +1 @@
+MD5 (libxml++-0.11.tar.gz) = cbe12b128eb73c3c5b2ecbe603e02faa
diff --git a/textproc/libxml++/pkg-comment b/textproc/libxml++/pkg-comment
new file mode 100644
index 000000000000..d1cd9c9f1f2b
--- /dev/null
+++ b/textproc/libxml++/pkg-comment
@@ -0,0 +1 @@
+XML API for C++
diff --git a/textproc/libxml++/pkg-descr b/textproc/libxml++/pkg-descr
new file mode 100644
index 000000000000..d9a4edbf9f77
--- /dev/null
+++ b/textproc/libxml++/pkg-descr
@@ -0,0 +1,5 @@
+libxml++ is a C++ interface for working with XML files, using libxml
+(gnome-xml) to parse and write the actual XML files. It has a simple
+but complete API.
+
+WWW: http://www.ari.lusis.org/xml++/
diff --git a/textproc/libxml++/pkg-plist b/textproc/libxml++/pkg-plist
new file mode 100644
index 000000000000..c8ea8e7b2053
--- /dev/null
+++ b/textproc/libxml++/pkg-plist
@@ -0,0 +1,6 @@
+bin/xml++-config
+include/xml++.h
+lib/libxml++.a
+lib/libxml++.so
+lib/libxml++.so.0
+share/aclocal/libxml++.m4