aboutsummaryrefslogtreecommitdiff
path: root/textproc/libxml2/Makefile
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-11-25 08:31:27 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-11-25 08:31:27 +0000
commit839dc181399e781639c91ec19f6e5ac8df7709b6 (patch)
tree64977aeb94348b9da8f42d032384b31ad7141a81 /textproc/libxml2/Makefile
parentfcb8eff03caab841a9d805927fac3752258d8602 (diff)
downloadports-839dc181399e781639c91ec19f6e5ac8df7709b6.tar.gz
ports-839dc181399e781639c91ec19f6e5ac8df7709b6.zip
- Add STAGEDIR support.
- Use *_CONFIGURE_WITH. - Add workaround for an iconv incompatibility on 10.X and later.
Notes
Notes: svn path=/head/; revision=334822
Diffstat (limited to 'textproc/libxml2/Makefile')
-rw-r--r--textproc/libxml2/Makefile42
1 files changed, 11 insertions, 31 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index d71d04c9cd14..4c737118242f 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -4,7 +4,7 @@
PORTNAME= libxml2
PORTVERSION= 2.8.0
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES?= textproc gnome
MASTER_SITES= ftp://xmlsoft.org/libxml2/ \
http://xmlsoft.org/sources/ \
@@ -15,7 +15,6 @@ MAINTAINER?= gnome@FreeBSD.org
COMMENT?= XML parser library for GNOME
.if !defined(REFERENCE_PORT)
-
USE_CSTD= gnu89
GNU_CONFIGURE= yes
USES= pathfix gmake iconv pkgconfig
@@ -27,50 +26,31 @@ CONFIGURE_ARGS?=--with-iconv=${ICONV_PREFIX} \
--without-python
.if !defined(MASTERDIR)
-MAN1= xml2-config.1 xmllint.1 xmlcatalog.1
-MAN3= libxml.3
-
OPTIONS_DEFINE= SCHEMA THREADS MEM_DEBUG XMLLINT_HIST THREAD_ALLOC
OPTIONS_DEFAULT=SCHEMA THREADS
+
SCHEMA_DESC= XML schema support
+SCHEMA_CONFIGURE_WITH= schemas
THREADS_DESC= Threads support
+THREADS_CONFIGURE_WITH= threads
MEM_DEBUG_DESC= Memory debugging (DEVELOPERS ONLY!)
+MEM_DEBUG_CONFIGURE_WITH= mem-debug
XMLLINT_HIST_DESC= History for xmllint
+XMLLINT_HIST_CONFIGURE_WITH= history
THREAD_ALLOC_DESC= Per-thread memory (DEVELOPERS ONLY!)
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ! ${PORT_OPTIONS:MSCHEMA}
-CONFIGURE_ARGS+= --without-schemas
-.endif
-
-.if ! ${PORT_OPTIONS:MTHREADS}
-CONFIGURE_ARGS+= --without-threads
-.endif
-
-.if ${PORT_OPTIONS:MMEM_DEBUG}
-CONFIGURE_ARGS+= --with-mem-debug
-.endif
-
-.if ${PORT_OPTIONS:MXMLLINT_HIST}
-CONFIGURE_ARGS+= --with-history
-.endif
-
-.if ${PORT_OPTIONS:MTHREAD_ALLOC}
-CONFIGURE_ARGS+= --with-thread-alloc
-.endif
+THREAD_ALLOC_CONFIGURE_WITH= thread-alloc
.endif # !defined(MASTERDIR)
post-patch:
.for d in . doc doc/devhelp doc/examples
@${REINPLACE_CMD} -e '/^install-data-am:/ s|install-data-local||' \
- ${WRKSRC}/${d}/Makefile.in
+ ${WRKSRC}/${d}/Makefile.in
.endfor
.for f in catalog.c xmlcatalog.c xmllint.c doc/xmllint.1
@${REINPLACE_CMD} -e \
- 's|/etc/xml/catalog|${LOCALBASE}/share/xml/catalog|g; \
- s|/etc/sgml/catalog|${LOCALBASE}/share/sgml/catalog|g' ${WRKSRC}/${f}
+ 's|/etc/xml/catalog|${LOCALBASE}/share/xml/catalog|g; \
+ s|/etc/sgml/catalog|${LOCALBASE}/share/sgml/catalog|g' \
+ ${WRKSRC}/${f}
.endfor
# manual patch because WITH_FBSD10_FIX break the python bindings
${FIND} ${WRKSRC} -type f -name configure \