aboutsummaryrefslogtreecommitdiff
path: root/textproc/libxml2/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-10-03 16:32:02 +0000
committerAde Lovett <ade@FreeBSD.org>2000-10-03 16:32:02 +0000
commit92e94c953d960d6d78bd08f732e96f6b29fbd859 (patch)
treeb07576446aed8f1800bdc4400ed8d927a68d6a11 /textproc/libxml2/Makefile
parentc61dcc072932fd5fe8480af8f4387bcbb15fe1f9 (diff)
downloadports-92e94c953d960d6d78bd08f732e96f6b29fbd859.tar.gz
ports-92e94c953d960d6d78bd08f732e96f6b29fbd859.zip
Update to 2.2.4 and enable iconv support.
Notes
Notes: svn path=/head/; revision=33376
Diffstat (limited to 'textproc/libxml2/Makefile')
-rw-r--r--textproc/libxml2/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 1d1589d0a6f7..e88e47c9e2b1 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -6,17 +6,23 @@
#
PORTNAME= libxml2
-PORTVERSION= 2.2.3
+PORTVERSION= 2.2.4
CATEGORIES= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/libxml
MAINTAINER= ade@FreeBSD.org
+LIB_DEPENDS= iconv.1:${PORTSDIR}/converters/iconv
+
+USE_GMAKE= yes
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --without-iconv
INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --with-iconv
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -liconv"
+
MAN1= xmllint.1
MAN4= libxml.4