aboutsummaryrefslogtreecommitdiff
path: root/textproc/libxslt
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2004-07-06 03:02:16 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2004-07-06 03:02:16 +0000
commit1fe0f1a81f1abb233e61bdc77f33ae910a0d3a8e (patch)
treefade10ce12924a4dd9341851c0ccbec9fe1ccf25 /textproc/libxslt
parentffb2455c8b68c23798826962a088b2984bdb17b1 (diff)
downloadports-1fe0f1a81f1abb233e61bdc77f33ae910a0d3a8e.tar.gz
ports-1fe0f1a81f1abb233e61bdc77f33ae910a0d3a8e.zip
Remove Python bingdings here as they going to be reintroduced in
slave port. Tested by: adamw, marcus
Notes
Notes: svn path=/head/; revision=113026
Diffstat (limited to 'textproc/libxslt')
-rw-r--r--textproc/libxslt/Makefile29
-rw-r--r--textproc/libxslt/files/patch-configure8
-rw-r--r--textproc/libxslt/files/patch-python::Makefile.in42
-rw-r--r--textproc/libxslt/files/patch-python::tests::Makefile.in2
-rw-r--r--textproc/libxslt/pkg-plist14
5 files changed, 44 insertions, 51 deletions
diff --git a/textproc/libxslt/Makefile b/textproc/libxslt/Makefile
index e009accdd2f8..7c05a20b25a9 100644
--- a/textproc/libxslt/Makefile
+++ b/textproc/libxslt/Makefile
@@ -7,7 +7,8 @@
PORTNAME= libxslt
PORTVERSION= 1.1.8
-CATEGORIES= textproc gnome
+PORTREVISION= 1
+CATEGORIES?= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.1
DIST_SUBDIR= gnome2
@@ -19,25 +20,20 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
-USE_GNOME= gnomehack gnometarget libxml2
+USE_GNOME?= gnomehack lthack gnometarget libxml2
USE_REINPLACE= yes
-CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
+CONFIGURE_ARGS?= --with-html-dir=${PREFIX}/share/doc \
+ --without-python
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.if defined(MASTERDIR)
+_SLAVE_PORT= yes
+.else
MAN3= libexslt.3 libxslt.3
MAN1= xsltproc.1
OPTIONS= MEM_DEBUG "Enable memory debugging" off
-
-.if !defined(WITHOUT_PYTHON)
-USE_PYTHON= yes
-PLIST_SUB+= PYTHON:=""
-CONFIGURE_ARGS+= --with-python=${LOCALBASE}
-.else
-CONFIGURE_ARGS+= --without-python
-PLIST_SUB+= PYTHON:="@comment "
-PKGNAMESUFFIX= -nopython
.endif
.include <bsd.port.pre.mk>
@@ -46,6 +42,7 @@ PKGNAMESUFFIX= -nopython
CONFIGURE_ARGS+= --with-mem-debug
.endif
+.if !defined(_SLAVE_PORT)
.if exists(${LOCALBASE}/lib/libgcrypt.so)
WITH_GCRYPT= yes
.endif
@@ -58,19 +55,13 @@ pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "Libxslt has the following additional tunables:"
@${ECHO_MSG} ""
- @${ECHO_MSG} " WITHOUT_PYTHON=yes Turns off python support"
@${ECHO_MSG} " WITH_GCRYPT=yes Turns on libgcrypt support"
@${ECHO_MSG} ""
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|[$$](bindir)/xsltproc|../xsltproc/xsltproc|g ; \
s|[$$](bindir)/xmllint|../xmllint/xmllint|g' \
${WRKSRC}/doc/Makefile.in
-.if !defined(WITHOUT_PYTHON)
-post-install:
- @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
- @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
-.endif
-
.include <bsd.port.post.mk>
diff --git a/textproc/libxslt/files/patch-configure b/textproc/libxslt/files/patch-configure
index e644cf75e11d..8345e15deb87 100644
--- a/textproc/libxslt/files/patch-configure
+++ b/textproc/libxslt/files/patch-configure
@@ -1,13 +1,5 @@
--- configure.orig Fri Sep 12 08:23:19 2003
+++ configure Fri Sep 12 15:29:42 2003
-@@ -8644,6 +8644,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
@@ -10300,7 +10301,7 @@
fi
if test "$with_python" != ""
diff --git a/textproc/libxslt/files/patch-python::Makefile.in b/textproc/libxslt/files/patch-python::Makefile.in
index ce298bb2a576..02358baf99c6 100644
--- a/textproc/libxslt/files/patch-python::Makefile.in
+++ b/textproc/libxslt/files/patch-python::Makefile.in
@@ -1,14 +1,38 @@
-
-$FreeBSD$
-
---- python/Makefile.in.orig Mon Apr 15 21:07:35 2002
-+++ python/Makefile.in Thu Apr 18 14:23:11 2002
-@@ -129,7 +129,7 @@
- -I$(top_srcdir)
-
+--- python/Makefile.in.orig Fri Jul 2 13:29:57 2004
++++ python/Makefile.in Fri Jul 2 13:34:44 2004
+@@ -49,9 +49,7 @@
+ am__installdirs = $(DESTDIR)$(pythondir)
+ pythonLTLIBRARIES_INSTALL = $(INSTALL)
+ LTLIBRARIES = $(python_LTLIBRARIES)
+-@WITH_PYTHON_TRUE@am__DEPENDENCIES_1 = \
+-@WITH_PYTHON_TRUE@ $(top_builddir)/libxslt/libxslt.la \
+-@WITH_PYTHON_TRUE@ $(top_builddir)/libexslt/libexslt.la
++@WITH_PYTHON_TRUE@am__DEPENDENCIES_1 =
+ @WITH_PYTHON_TRUE@libxsltmod_la_DEPENDENCIES = $(am__DEPENDENCIES_1)
+ am__libxsltmod_la_SOURCES_DIST = libxslt.c types.c libxslt-py.c
+ @WITH_PYTHON_TRUE@am_libxsltmod_la_OBJECTS = libxslt.lo types.lo \
+@@ -237,7 +235,7 @@
+ -I$(top_srcdir) \
+ -I../libexslt
-DOCS_DIR = $(datadir)/doc/libxslt-python-$(LIBXSLT_VERSION)
-+DOCS_DIR = $(datadir)/doc/libxslt-python
++DOCS_DIR = $(datadir)/doc/py-libxslt
# libxsltclass.txt is generated
DOCS = TODO
+ EXTRA_DIST = \
+@@ -250,12 +248,11 @@
+ libxslt-python-api.xml \
+ $(DOCS)
+
+-libxsltmod_la_LDFLAGS = -module -avoid-version -L$(top_builddir)/libxslt/.libs \
+- -L$(top_builddir)/libexslt/.libs
++libxsltmod_la_LDFLAGS = -module -avoid-version
+
+ @WITH_PYTHON_TRUE@mylibs = \
+-@WITH_PYTHON_TRUE@ $(top_builddir)/libxslt/libxslt.la \
+-@WITH_PYTHON_TRUE@ $(top_builddir)/libexslt/libexslt.la
++@WITH_PYTHON_TRUE@ -lxslt \
++@WITH_PYTHON_TRUE@ -lexslt
+ @WITH_PYTHON_TRUE@python_LTLIBRARIES = libxsltmod.la
+ @WITH_PYTHON_TRUE@libxsltmod_la_SOURCES = libxslt.c types.c libxslt-py.c
diff --git a/textproc/libxslt/files/patch-python::tests::Makefile.in b/textproc/libxslt/files/patch-python::tests::Makefile.in
index 80a928dd169d..7abaa6ee5739 100644
--- a/textproc/libxslt/files/patch-python::tests::Makefile.in
+++ b/textproc/libxslt/files/patch-python::tests::Makefile.in
@@ -5,7 +5,7 @@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
-EXAMPLE_DIR = $(datadir)/doc/libxslt-python-$(LIBXSLT_VERSION)/examples
-+EXAMPLE_DIR = $(datadir)/doc/libxslt-python/examples
++EXAMPLE_DIR = $(datadir)/examples/py-libxslt
TESTSPY = \
basic.py \
exslt.py \
diff --git a/textproc/libxslt/pkg-plist b/textproc/libxslt/pkg-plist
index 1693203762f0..08bc5f7dbaa0 100644
--- a/textproc/libxslt/pkg-plist
+++ b/textproc/libxslt/pkg-plist
@@ -30,21 +30,9 @@ lib/libexslt.so.8
lib/libxslt.a
lib/libxslt.so
lib/libxslt.so.2
-%%PYTHON:%%lib/%%PYTHON_VERSION%%/site-packages/libxslt.py
-%%PYTHON:%%lib/%%PYTHON_VERSION%%/site-packages/libxslt.pyc
-%%PYTHON:%%lib/%%PYTHON_VERSION%%/site-packages/libxslt.pyo
-%%PYTHON:%%lib/%%PYTHON_VERSION%%/site-packages/libxsltmod.so
libdata/pkgconfig/libexslt.pc
libdata/pkgconfig/libxslt.pc
share/aclocal/libxslt.m4
-%%PYTHON:%%%%DOCSDIR%%-python/TODO
-%%PYTHON:%%%%DOCSDIR%%-python/examples/basic.py
-%%PYTHON:%%%%DOCSDIR%%-python/examples/exslt.py
-%%PYTHON:%%%%DOCSDIR%%-python/examples/extelem.py
-%%PYTHON:%%%%DOCSDIR%%-python/examples/extfunc.py
-%%PYTHON:%%%%DOCSDIR%%-python/examples/pyxsltproc.py
-%%PYTHON:%%%%DOCSDIR%%-python/examples/test.xml
-%%PYTHON:%%%%DOCSDIR%%-python/examples/test.xsl
%%DOCSDIR%%/html/API.html
%%DOCSDIR%%/html/APIchunk0.html
%%DOCSDIR%%/html/APIchunk1.html
@@ -124,8 +112,6 @@ share/aclocal/libxslt.m4
@dirrm %%DOCSDIR%%/html/tutorial
@dirrm %%DOCSDIR%%/html/EXSLT
@dirrm %%DOCSDIR%%/html
-%%PYTHON:%%@dirrm %%DOCSDIR%%-python/examples
-%%PYTHON:%%@dirrm %%DOCSDIR%%-python
@dirrm %%DOCSDIR%%
@dirrm include/libxslt
@dirrm include/libexslt