aboutsummaryrefslogtreecommitdiff
path: root/textproc/lttoolbox/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-28 17:47:02 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-28 17:47:02 +0000
commitc7e0c5c34c60044d029b4729edd9edba760080eb (patch)
tree9a09b76f0be6bbace36dcae67faf23fe1eaa2594 /textproc/lttoolbox/Makefile
parentff7976e8ce8797bb8a53e914e8d62ae575a534a3 (diff)
downloadports-c7e0c5c34c60044d029b4729edd9edba760080eb.tar.gz
ports-c7e0c5c34c60044d029b4729edd9edba760080eb.zip
lttoolbox is a toolbox for lexical processing, morphological analysis
and generation of words. The analysis is the process of splitting of words splitting a word (e.g. cats) into its lemma 'cat' and the grammatical information <n><pl>. The generation is the opposite process. The package is split into three programs, lt-comp, the compiler, lt-proc, the processor, and lt-expand, which generates all possible mappings between surface forms and lexical forms in the dictionary. WWW: http://wiki.apertium.org/wiki/Lttoolbox PR: ports/137134 Submitted by: Mykola Dzham <freebsd at levsha.org.ua>
Notes
Notes: svn path=/head/; revision=238542
Diffstat (limited to 'textproc/lttoolbox/Makefile')
-rw-r--r--textproc/lttoolbox/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/textproc/lttoolbox/Makefile b/textproc/lttoolbox/Makefile
new file mode 100644
index 000000000000..695485d1505f
--- /dev/null
+++ b/textproc/lttoolbox/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: lttoolbox
+# Date created: 14 April 2009
+# Whom: Mykola Dzham <freebsd@levsha.org.ua>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lttoolbox
+PORTVERSION= 3.1.1
+CATEGORIES= textproc
+MASTER_SITES= SF/apertium
+
+MAINTAINER= freebsd@levsha.org.ua
+COMMENT= A tool for lexical, morphological analysis and generation of words
+
+LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
+
+GNU_CONFIGURE= yes
+
+USE_LDCONFIG= yes
+USE_GNOME= gnomehack pkgconfig
+
+MAN1= lt-comp.1 lt-expand.1 lt-proc.1 lt-tmxcomp.1 lt-tmxproc.1
+
+.include <bsd.port.mk>