aboutsummaryrefslogtreecommitdiff
path: root/textproc/ltxml/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-07-23 18:07:48 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-07-23 18:07:48 +0000
commit0974cce33f0ee04849f5fef4a5eb1f2a4ddee0c7 (patch)
treec9384ce4bf05bb376dea59a595a13ae1c094984f /textproc/ltxml/Makefile
parentce5cd66858a6cb7ffc7e3675c415b10953706814 (diff)
downloadports-0974cce33f0ee04849f5fef4a5eb1f2a4ddee0c7.tar.gz
ports-0974cce33f0ee04849f5fef4a5eb1f2a4ddee0c7.zip
Update to 1.2.6
PR: ports/69491 Submitted by: Radim Kolar <hsn@netmag.cz>
Notes
Notes: svn path=/head/; revision=114503
Diffstat (limited to 'textproc/ltxml/Makefile')
-rw-r--r--textproc/ltxml/Makefile24
1 files changed, 18 insertions, 6 deletions
diff --git a/textproc/ltxml/Makefile b/textproc/ltxml/Makefile
index 4833610efc4a..1fa7c1397b06 100644
--- a/textproc/ltxml/Makefile
+++ b/textproc/ltxml/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ltxml
-PORTVERSION= 1.2.5
-PORTREVISION= 3
+PORTVERSION= 1.2.6
CATEGORIES= textproc
MASTER_SITES= ftp://ftp.cogsci.ed.ac.uk/pub/LTXML/
@@ -20,6 +19,7 @@ USE_PERL5= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-zlib=/usr --enable-multi-byte
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= ltxml.1 xmlnorm.1 pesis.1 sgcount.1 sggrep.1 sgmlsb.1 \
sgmlseg.1 sgmltoken.1 sgmltrans.1 sgrpg.1 textonly.1 \
@@ -30,13 +30,25 @@ PROGRAMS= getindex intersect knit nslshowddb nslwhere pesis sgcount \
sggrep sgmlsb sgmlseg sgmltrans sgrpg sgsort simple simpleq \
textonly unknit xmlnorm
-post-patch:
- @${PERL} -pi -e 's|CFLAGS=.*$$|CFLAGS=\$$CFLAGS|g ; \
- s|CXXFLAGS=.*$$|CXXFLAGS=\$$CXXFLAGS|g' ${WRKSRC}/configure
+.include <bsd.port.pre.mk>
+.ifdef WITH_OPTIMIZED_CFLAGS
+CFLAGS+= -Wuninitialized -ffast-math -finline-functions -fomit-frame-pointer -fexpensive-optimizations -O3
+.endif
+
+pre-everything::
+.ifndef(WITH_OPTIMIZED_CFLAGS)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> You can enable extra optimizations by defining WITH_OPTIMIZED_CFLAGS'
+ @${ECHO_MSG} "===> For example, 'make WITH_OPTIMIZED_CFLAGS=yes'"
+.endif
post-install:
.for file in ${PROGRAMS:S/sgmlseg//}
${STRIP_CMD} ${PREFIX}/bin/${file}
.endfor
-.include <bsd.port.mk>
+post-patch:
+ @${PERL} -pi -e 's|CFLAGS=.*$$|CFLAGS=\$$CFLAGS|g ; \
+ s|CXXFLAGS=.*$$|CXXFLAGS=\$$CXXFLAGS|g' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>