aboutsummaryrefslogtreecommitdiff
path: root/textproc/markdown-mode.el
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2011-08-30 14:47:15 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2011-08-30 14:47:15 +0000
commita6061aed8cdf0dd9cc34a784f15812d687732380 (patch)
tree00841260f725a0273a7c94a05eb1b3a009a27dba /textproc/markdown-mode.el
parent577be98a0c21c20f51c070adce984ae6d7e281a0 (diff)
downloadports-a6061aed8cdf0dd9cc34a784f15812d687732380.tar.gz
ports-a6061aed8cdf0dd9cc34a784f15812d687732380.zip
Add markdown-mode.el: an Emacs major mode for editing Markdown-formatted
text files.
Notes
Notes: svn path=/head/; revision=280766
Diffstat (limited to 'textproc/markdown-mode.el')
-rw-r--r--textproc/markdown-mode.el/Makefile35
-rw-r--r--textproc/markdown-mode.el/distinfo2
-rw-r--r--textproc/markdown-mode.el/pkg-descr4
-rw-r--r--textproc/markdown-mode.el/pkg-message12
-rw-r--r--textproc/markdown-mode.el/pkg-plist2
5 files changed, 55 insertions, 0 deletions
diff --git a/textproc/markdown-mode.el/Makefile b/textproc/markdown-mode.el/Makefile
new file mode 100644
index 000000000000..e8fded987a3b
--- /dev/null
+++ b/textproc/markdown-mode.el/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: markdown-mode.el
+# Date created: 30 Ago 2011
+# Whom: olgeni@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= markdown-mode.el
+PORTVERSION= 1.8.1
+CATEGORIES= textproc
+MASTER_SITES= http://jblevins.org/projects/markdown-mode/
+DISTNAME= markdown-mode.el
+EXTRACT_SUFX= # empty
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+EXTRACT_ONLY= # empty
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= Emacs/XEmacs major mode for editing Markdown-formatted text
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+EMACSLISPDIR= ${PREFIX}/share/emacs/site-lisp
+XEMACSLISPDIR= ${PREFIX}/lib/xemacs/site-lisp
+
+do-install:
+ @${MKDIR} ${EMACSLISPDIR}
+ @${MKDIR} ${XEMACSLISPDIR}
+ @${INSTALL_DATA} ${_DISTDIR}/${DISTNAME} ${EMACSLISPDIR}/markdown-mode.el
+ @${LN} -sf ${EMACSLISPDIR}/markdown-mode.el ${XEMACSLISPDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/textproc/markdown-mode.el/distinfo b/textproc/markdown-mode.el/distinfo
new file mode 100644
index 000000000000..97dc3af51183
--- /dev/null
+++ b/textproc/markdown-mode.el/distinfo
@@ -0,0 +1,2 @@
+SHA256 (markdown-mode.el-1.8.1/markdown-mode.el) = ea606dff279df0f804ac6cc849248ca85c41065bbac728b7976b9f4279289f33
+SIZE (markdown-mode.el-1.8.1/markdown-mode.el) = 75777
diff --git a/textproc/markdown-mode.el/pkg-descr b/textproc/markdown-mode.el/pkg-descr
new file mode 100644
index 000000000000..90752f6ce0ce
--- /dev/null
+++ b/textproc/markdown-mode.el/pkg-descr
@@ -0,0 +1,4 @@
+markdown-mode is a major mode for editing Markdown-formatted
+text files in GNU Emacs.
+
+WWW: http://jblevins.org/projects/markdown-mode/
diff --git a/textproc/markdown-mode.el/pkg-message b/textproc/markdown-mode.el/pkg-message
new file mode 100644
index 000000000000..a8330d28466f
--- /dev/null
+++ b/textproc/markdown-mode.el/pkg-message
@@ -0,0 +1,12 @@
+========================================================================
+
+To use markdown-mode in Emacs/XEmacs, add the following lines to
+your ~/.emacs replacing "text" with your preferred markdown extension.
+
+(autoload 'markdown-mode "markdown-mode.el"
+ "Major mode for editing Markdown files" t)
+
+(setq auto-mode-alist
+ (cons '("\\.text" . markdown-mode) auto-mode-alist))
+
+========================================================================
diff --git a/textproc/markdown-mode.el/pkg-plist b/textproc/markdown-mode.el/pkg-plist
new file mode 100644
index 000000000000..72a0a78d874e
--- /dev/null
+++ b/textproc/markdown-mode.el/pkg-plist
@@ -0,0 +1,2 @@
+%%LIB32DIR%%/xemacs/site-lisp/markdown-mode.el
+share/emacs/site-lisp/markdown-mode.el