aboutsummaryrefslogtreecommitdiff
path: root/textproc/minify/Makefile
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-03-24 17:16:59 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-03-24 20:54:55 +0000
commit0b8a364cd65e263ff9891c83664c4d1b582845bf (patch)
tree98c63c6f1f612d2d7ec2e2581aa6ff7b73e0eba5 /textproc/minify/Makefile
parenta36ce35c89cc28bce2038f3d79882f709eb75abe (diff)
downloadports-0b8a364cd65e263ff9891c83664c4d1b582845bf.tar.gz
ports-0b8a364cd65e263ff9891c83664c4d1b582845bf.zip
textproc/minify: fix build on riscv64
Bump golang.org/x/sys dependency to a version new enough to support riscv64-freebsd. Sponsored by: Berliner Linux User Group e.V. Approved by: portmgr (build fix blanket)
Diffstat (limited to 'textproc/minify/Makefile')
-rw-r--r--textproc/minify/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/textproc/minify/Makefile b/textproc/minify/Makefile
index ccf14c66358f..a415433f4f22 100644
--- a/textproc/minify/Makefile
+++ b/textproc/minify/Makefile
@@ -1,6 +1,6 @@
PORTNAME= minify
PORTVERSION= 2.12.4
-PORTREVISION= 5
+PORTREVISION= 6
DISTVERSIONPREFIX= v
CATEGORIES= textproc www
@@ -12,10 +12,16 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= go:modules
+USE_GITHUB= nodefault
+GH_TUPLE= golang:sys:v0.6.0:sys
GO_MODULE= github.com/tdewolff/minify/v2
GO_TARGET= ./cmd/minify
PLIST_FILES= bin/minify
+pre-patch:
+ ${RM} -r ${WRKSRC}/vendor/golang.org/x/sys
+ ${LN} -s ${WRKDIR}/sys-* ${WRKSRC}/vendor/golang.org/x/sys
+
.include <bsd.port.mk>