aboutsummaryrefslogtreecommitdiff
path: root/textproc/modlogan/files
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-10-03 17:22:04 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-10-03 17:22:04 +0000
commit259327933b4c32dff5eabb310a8a73c60f2a2e0e (patch)
treee55e95e6bd90cbe4307df816dfc6c3a3e5205217 /textproc/modlogan/files
parentfe7d25ef4819ce15a55ddff508f7d10c0f9a6524 (diff)
downloadports-259327933b4c32dff5eabb310a8a73c60f2a2e0e.tar.gz
ports-259327933b4c32dff5eabb310a8a73c60f2a2e0e.zip
Update to 0.7.4.
Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=48407
Diffstat (limited to 'textproc/modlogan/files')
-rw-r--r--textproc/modlogan/files/patch-configure17
-rw-r--r--textproc/modlogan/files/patch-fix_segfault57
-rw-r--r--textproc/modlogan/files/patch-libtdl:Makefile.in11
3 files changed, 57 insertions, 28 deletions
diff --git a/textproc/modlogan/files/patch-configure b/textproc/modlogan/files/patch-configure
index ada6176f91e3..09a4c013ed79 100644
--- a/textproc/modlogan/files/patch-configure
+++ b/textproc/modlogan/files/patch-configure
@@ -1,13 +1,5 @@
--- configure.orig Wed Sep 5 16:56:33 2001
+++ configure Thu Sep 6 14:00:42 2001
-@@ -260,7 +260,6 @@
- : ${ac_max_here_lines=38}
-
- ac_unique_file="src/main.c"
--ac_subdirs_all="$ac_subdirs_all libltdl"
- # Factoring default headers for most tests.
- ac_includes_default="\
- #include <stdio.h>
@@ -7610,6 +7609,9 @@
# PORTME does your system automatically load deplibs for dlopen()?
libltdl_cv_sys_dlopen_deplibs=unknown
@@ -18,15 +10,6 @@
linux*)
libltdl_cv_sys_dlopen_deplibs=yes
;;
-@@ -11850,7 +11852,7 @@
-
- CFLAGS="${ac_save_CFLAGS}" # don't use CFLAGS from libtool
-
--subdirs="$subdirs libltdl"
-+subdirs="$subdirs"
-
- echo "$as_me:11855: checking for dmalloc.h" >&5
- echo $ECHO_N "checking for dmalloc.h... $ECHO_C" >&6
@@ -14476,7 +14478,9 @@
if test "$gt_cv_func_gettext_libintl" = "yes"; then
INTLLIBS='-lintl'
diff --git a/textproc/modlogan/files/patch-fix_segfault b/textproc/modlogan/files/patch-fix_segfault
new file mode 100644
index 000000000000..4f957af033d4
--- /dev/null
+++ b/textproc/modlogan/files/patch-fix_segfault
@@ -0,0 +1,57 @@
+Index: mconfig.c
+===================================================================
+RCS file: /cvsroot/modlogan/modlogan/src/mconfig.c,v
+retrieving revision 1.40
+diff -c -r1.40 mconfig.c
+*** src/mconfig.c 2001/09/23 22:54:00 1.40
+--- src/mconfig.c 2001/09/24 09:29:37
+***************
+*** 665,670 ****
+--- 665,672 ----
+ int mconfig_free(mconfig *conf) {
+ if (!conf) return -1;
+
++ mplugins_free(conf);
++
+ if (conf->outputdir) free(conf->outputdir);
+
+ #ifdef HAVE_LIBADNS
+***************
+*** 672,678 ****
+ if (conf->adns) free(conf->adns);
+ if (conf->query_hash) mhash_free(conf->query_hash);
+ #endif
+- mplugins_free(conf);
+ mlist_free(conf->loadplugins);
+ mlist_free(conf->includepath);
+
+--- 674,679 ----
+Index: misc.c
+===================================================================
+RCS file: /cvsroot/modlogan/modlogan/src/misc.c,v
+retrieving revision 1.13
+diff -c -r1.13 misc.c
+*** src/misc.c 2001/09/04 22:47:23 1.13
+--- src/misc.c 2001/09/24 09:29:37
+***************
+*** 278,283 ****
+--- 278,285 ----
+ /* x and y denote the position in source respective destination string */
+ register int x, y;
+ unsigned char *str;
++
++ if (!s) return NULL;
+
+ /* allocate memory for encoded string */
+ str = (unsigned char *) malloc(3 * strlen(s) + 1);
+***************
+*** 307,312 ****
+--- 309,316 ----
+ /* work pointers */
+ unsigned char *data;
+ unsigned char *dest;
++
++ if (!s) return NULL;
+
+ /* allocate memory for decoded string */
+ str = (unsigned char *) malloc(strlen(s) + 1);
diff --git a/textproc/modlogan/files/patch-libtdl:Makefile.in b/textproc/modlogan/files/patch-libtdl:Makefile.in
deleted file mode 100644
index 6182c4e2ea4a..000000000000
--- a/textproc/modlogan/files/patch-libtdl:Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- libltdl/Makefile.in.orig Sat Sep 15 19:24:49 2001
-+++ libltdl/Makefile.in Sun Sep 16 11:27:00 2001
-@@ -83,7 +83,7 @@
-
- AUTOMAKE_OPTIONS = no-dependencies foreign
-
--mkinstalldirs = $(SHELL) $(top_srcdir)/../mkinstalldirs
-+mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
-
- @INSTALL_LTDL_TRUE@include_HEADERS = ltdl.h
- @INSTALL_LTDL_TRUE@lib_LTLIBRARIES = libltdl.la