aboutsummaryrefslogtreecommitdiff
path: root/textproc/openfts
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /textproc/openfts
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'textproc/openfts')
-rw-r--r--textproc/openfts/Makefile2
-rw-r--r--textproc/openfts/pkg-plist42
2 files changed, 16 insertions, 28 deletions
diff --git a/textproc/openfts/Makefile b/textproc/openfts/Makefile
index 6dfd7a9e13db..f0ecf8d1a93c 100644
--- a/textproc/openfts/Makefile
+++ b/textproc/openfts/Makefile
@@ -2,7 +2,7 @@
PORTNAME= openfts
PORTVERSION= 0.40
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc perl5
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/OpenFTS-perl%2C%20v${PORTVERSION}
DISTNAME= Search-OpenFTS-${PORTVERSION}
diff --git a/textproc/openfts/pkg-plist b/textproc/openfts/pkg-plist
index 3eac270d506c..13e8d7d986bc 100644
--- a/textproc/openfts/pkg-plist
+++ b/textproc/openfts/pkg-plist
@@ -7,22 +7,21 @@
%%PERL5_MAN3%%/Search::OpenFTS::Index.3.gz
%%PERL5_MAN3%%/Search::OpenFTS::Morph::ISpell.3.gz
%%PERL5_MAN3%%/Search::OpenFTS::Parser.3.gz
-%%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS/Base.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS/Dict/PorterEng.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS/Dict/Snowball.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS/Dict/Synonym.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS/Dict/UnknownDict.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS/Index.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS/Morph/ISpell.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS/Parser.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/.packlist
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Dict/PorterEng/PorterEng.so
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Dict/PorterEng/autosplit.ix
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Morph/ISpell/ISpell.so
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Morph/ISpell/autosplit.ix
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Parser/Parser.so
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Parser/autosplit.ix
+%%SITE_ARCH%%/Search/OpenFTS.pm
+%%SITE_ARCH%%/Search/OpenFTS/Base.pm
+%%SITE_ARCH%%/Search/OpenFTS/Dict/PorterEng.pm
+%%SITE_ARCH%%/Search/OpenFTS/Dict/Snowball.pm
+%%SITE_ARCH%%/Search/OpenFTS/Dict/Synonym.pm
+%%SITE_ARCH%%/Search/OpenFTS/Dict/UnknownDict.pm
+%%SITE_ARCH%%/Search/OpenFTS/Index.pm
+%%SITE_ARCH%%/Search/OpenFTS/Morph/ISpell.pm
+%%SITE_ARCH%%/Search/OpenFTS/Parser.pm
+%%SITE_ARCH%%/auto/Search/OpenFTS/Dict/PorterEng/PorterEng.so
+%%SITE_ARCH%%/auto/Search/OpenFTS/Dict/PorterEng/autosplit.ix
+%%SITE_ARCH%%/auto/Search/OpenFTS/Morph/ISpell/ISpell.so
+%%SITE_ARCH%%/auto/Search/OpenFTS/Morph/ISpell/autosplit.ix
+%%SITE_ARCH%%/auto/Search/OpenFTS/Parser/Parser.so
+%%SITE_ARCH%%/auto/Search/OpenFTS/Parser/autosplit.ix
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Dict/DecimalDict.pm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Dict/EngStem.pm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Dict/IntegerDict.pm
@@ -43,14 +42,3 @@
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/parser
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/Dict
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Parser
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Morph/ISpell
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Morph
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Dict/PorterEng
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Dict
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS/Morph
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS/Dict
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Search