aboutsummaryrefslogtreecommitdiff
path: root/textproc/openjade
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-02-27 23:03:36 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-02-27 23:03:36 +0000
commita8c5a561cb20c6ea792ef063c957d0b63b0d4a46 (patch)
tree77c95b5a247da81a8e339e98882f558ecfb4a971 /textproc/openjade
parent6852d7588d4506e3a64d93b2a8ca9368173042a8 (diff)
downloadports-a8c5a561cb20c6ea792ef063c957d0b63b0d4a46.tar.gz
ports-a8c5a561cb20c6ea792ef063c957d0b63b0d4a46.zip
o Sanitize CFLAGS following example of palm/prc-tools-gcc. Remove
both all -m machine and -O > -O1 optimizations such as (-O[s2-9]+|-m[0-9a-zA-Z]+(=[0-9a-zA-Z]*)?|-O[s2-9]+) since openjade built with some of these optimizations core dumps when building some of the /usr/doc files o Use INSTALLS_SHLIB=yes instead of a post-install ldconfig line o "UN"echo post-install (prefix lines with @). Cleaner o Also, fix openjade's complain that it does not find builtins.dls, point it in the right direction with CONFIGURE_ARGS+=--datadir o Bump PORTREVISION since there is an improvement fix Approved by: MAINTAINER
Notes
Notes: svn path=/head/; revision=38869
Diffstat (limited to 'textproc/openjade')
-rw-r--r--textproc/openjade/Makefile25
1 files changed, 20 insertions, 5 deletions
diff --git a/textproc/openjade/Makefile b/textproc/openjade/Makefile
index 5d5b21cd0fa1..6cefe4199019 100644
--- a/textproc/openjade/Makefile
+++ b/textproc/openjade/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openjade
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,14 +17,28 @@ MAINTAINER= kuriyama@FreeBSD.org
USE_GMAKE= YES
USE_LIBTOOL= YES
CONFIGURE_ENV= CXXFLAGS="${CFLAGS}"
-CONFIGURE_ARGS= --enable-default-catalog=${PREFIX}/share/sgml/catalog
+CONFIGURE_ARGS= --enable-default-catalog=${PREFIX}/share/sgml/catalog \
+ --datadir=${PREFIX}/share/sgml/openjade
+INSTALLS_SHLIB= yes
pre-install:
@find ${WRKSRC} \( -name \*.orig -o -name \*~ \) -exec ${RM} -f \{} \;
post-install:
- ${MKDIR} ${PREFIX}/share/sgml/openjade
- ${INSTALL_DATA} ${WRKSRC}/dsssl/* ${PREFIX}/share/sgml/openjade
- ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m $(PREFIX)/lib
+ @${MKDIR} ${PREFIX}/share/sgml/openjade
+ @${INSTALL_DATA} ${WRKSRC}/dsssl/* ${PREFIX}/share/sgml/openjade
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# This port is cannot be CFLAGS safe, using optimizations such as
+# 'march=-mpentium -Os' produces core dumps with certain input files
+# Therefore, we'd better remove all machine optimizations and any -O
+# other than -O{0,1,}. Idea taken from palm/prc-tools-gcc.
+# The following sed does not reproduce the awk result. Odd.
+# ${SED} -e 's/-m[0-9a-zA-Z]+(=[0-9a-zA-Z]*)?//g' -e 's/-O[s2-9]+//g'
+CFLAGS!= ${ECHO} "${CFLAGS}" | ${AWK} 'BEGIN \
+ { RS="-m[0-9a-zA-Z]+(=[0-9a-zA-Z]*)?|-O[s2-9]+" ; \
+ ORS="" } ; \
+ { if (RT == "") { print $0 } else print }'
+
+.include <bsd.port.post.mk>