aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-CSS-Simple
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /textproc/p5-CSS-Simple
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'textproc/p5-CSS-Simple')
-rw-r--r--textproc/p5-CSS-Simple/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/textproc/p5-CSS-Simple/Makefile b/textproc/p5-CSS-Simple/Makefile
index 8dabcd8bdfee..0394b2a369e6 100644
--- a/textproc/p5-CSS-Simple/Makefile
+++ b/textproc/p5-CSS-Simple/Makefile
@@ -3,6 +3,7 @@
PORTNAME= CSS-Simple
PORTVERSION= 3211
+PORTREVISION= 1
CATEGORIES= textproc www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -21,9 +22,5 @@ USE_PERL5= configure
PLIST_FILES= %%SITE_PERL%%/CSS/Simple.pm \
%%PERL5_MAN3%%/CSS::Simple.3.gz \
- %%SITE_PERL%%/%%PERL_ARCH%%/auto/CSS/Simple/.packlist
-PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/CSS/Simple \
- %%SITE_PERL%%/%%PERL_ARCH%%/auto/CSS \
- %%SITE_PERL%%/CSS
.include <bsd.port.mk>