aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Parse-FixedLength/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-10-27 14:21:15 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-10-27 14:21:15 +0000
commitfd04a76751578f8c361abc1bfb8ea5ddd4ed171a (patch)
treece2e2311bf060ddc3ee27fcfdc2b719810312ee8 /textproc/p5-Parse-FixedLength/Makefile
parent2c42ab7d995159f8cfdfc70acf42f96a86f17e1f (diff)
downloadports-fd04a76751578f8c361abc1bfb8ea5ddd4ed171a.tar.gz
ports-fd04a76751578f8c361abc1bfb8ea5ddd4ed171a.zip
Add textproc/p5-Parse-FixedLength 5.35, a Perl module to parse a string
containing fixed length fields into component parts.
Notes
Notes: svn path=/head/; revision=146485
Diffstat (limited to 'textproc/p5-Parse-FixedLength/Makefile')
-rw-r--r--textproc/p5-Parse-FixedLength/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/textproc/p5-Parse-FixedLength/Makefile b/textproc/p5-Parse-FixedLength/Makefile
new file mode 100644
index 000000000000..68adb5e3a915
--- /dev/null
+++ b/textproc/p5-Parse-FixedLength/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: textproc/p5-Parse-FixedLength
+# Date created: 27 October 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Parse-FixedLength
+PORTVERSION= 5.35
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Parse
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Parse a string containing fixed length fields into component parts
+
+PERL_CONFIGURE= yes
+
+MAN3= Parse::FixedLength.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>