aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Perl-Lint/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-03-14 15:52:28 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-03-14 15:52:28 +0000
commit6b4d04d57bffbfbb3389cc6edad47dc132da60cd (patch)
treef4e93dfbca0b4789bd46b31a25429996b43f70c4 /textproc/p5-Perl-Lint/Makefile
parenteefe55b85bad325adad7d983e67cd4a8cd79eb4f (diff)
downloadports-6b4d04d57bffbfbb3389cc6edad47dc132da60cd.tar.gz
ports-6b4d04d57bffbfbb3389cc6edad47dc132da60cd.zip
Install examples.
Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=411096
Diffstat (limited to 'textproc/p5-Perl-Lint/Makefile')
-rw-r--r--textproc/p5-Perl-Lint/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/textproc/p5-Perl-Lint/Makefile b/textproc/p5-Perl-Lint/Makefile
index eeb04cf352f1..8d81d3fcb402 100644
--- a/textproc/p5-Perl-Lint/Makefile
+++ b/textproc/p5-Perl-Lint/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Perl-Lint
PORTVERSION= 0.23
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:MOZNION
@@ -31,6 +31,14 @@ TEST_DEPENDS= p5-Text-TestBase>=0:${PORTSDIR}/textproc/p5-Text-TestBase
USES= perl5
USE_PERL5= modbuildtiny
+OPTIONS_DEFINE= EXAMPLES
+
+PORTEXAMPLES= lint.pl lint_string.pl
+
+post-install-EXAMPLES-on:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/eg/|} ${STAGEDIR}${EXAMPLESDIR}
+
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} >= 502000