aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-PerlPoint-Package
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-06-08 10:03:57 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-06-08 10:03:57 +0000
commit5ae350cd7e6b6cd85a700d5d22b83798acc54229 (patch)
tree1c805b069a17cda5c0c321d3f70c4a735f76f07e /textproc/p5-PerlPoint-Package
parent40d9db5aa8d1bdce179c4e5aad0fc55ffea8e8a4 (diff)
downloadports-5ae350cd7e6b6cd85a700d5d22b83798acc54229.tar.gz
ports-5ae350cd7e6b6cd85a700d5d22b83798acc54229.zip
Add p5-PerlPoint-Package 0.39, PerlPoint is both a presentation and a
documentation toolset.
Notes
Notes: svn path=/head/; revision=111075
Diffstat (limited to 'textproc/p5-PerlPoint-Package')
-rw-r--r--textproc/p5-PerlPoint-Package/Makefile44
-rw-r--r--textproc/p5-PerlPoint-Package/distinfo2
-rw-r--r--textproc/p5-PerlPoint-Package/pkg-descr12
-rw-r--r--textproc/p5-PerlPoint-Package/pkg-plist14
4 files changed, 72 insertions, 0 deletions
diff --git a/textproc/p5-PerlPoint-Package/Makefile b/textproc/p5-PerlPoint-Package/Makefile
new file mode 100644
index 000000000000..316d7fa38edd
--- /dev/null
+++ b/textproc/p5-PerlPoint-Package/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: p5-PerlPoint-Package
+# Date created: 8 Jun 2004
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= PerlPoint-Package
+PORTVERSION= 0.39
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= PerlPoint
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= PerlPoint is both a presentation and a documentation toolset
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN1= pp2sdf.1
+MAN3= PerlPoint::Anchors.3 \
+ PerlPoint::Backend.3 \
+ PerlPoint::Constants.3 \
+ PerlPoint::Parser.3 \
+ PerlPoint::Tags.3 \
+ PerlPoint::Tags::Basic.3 \
+ PerlPoint::Tags::CPPP.3 \
+ PerlPoint::Tags::SDF.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
+ ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.endif
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-PerlPoint-Package/distinfo b/textproc/p5-PerlPoint-Package/distinfo
new file mode 100644
index 000000000000..acfe5ad62aa2
--- /dev/null
+++ b/textproc/p5-PerlPoint-Package/distinfo
@@ -0,0 +1,2 @@
+MD5 (PerlPoint-Package-0.39.tgz) = fcf51794d231d21b73a2247ae2b04c01
+SIZE (PerlPoint-Package-0.39.tgz) = 331300
diff --git a/textproc/p5-PerlPoint-Package/pkg-descr b/textproc/p5-PerlPoint-Package/pkg-descr
new file mode 100644
index 000000000000..06d5356e72ef
--- /dev/null
+++ b/textproc/p5-PerlPoint-Package/pkg-descr
@@ -0,0 +1,12 @@
+PerlPoint is both a presentation and a documentation toolset. More precise, its
+a toolset to generate presentations and documentations. You will write a simple
+text and start a converter to make the final documents from this source. The
+final format is your choice, depending on the used converter. So you can make a
+presentation, speaker notes, handouts, an internet documentation and a brochure
+all from the same text source, but looking very individual.
+
+Because of this two step architecture PerlPoint authors deal both with the text
+format and several converters. The text source describes structure and contents
+of your document, while a converter adds layout. Let's start.
+
+WWW: http://search.cpan.org/dist/PerlPoint-Package/
diff --git a/textproc/p5-PerlPoint-Package/pkg-plist b/textproc/p5-PerlPoint-Package/pkg-plist
new file mode 100644
index 000000000000..a943958ac8d4
--- /dev/null
+++ b/textproc/p5-PerlPoint-Package/pkg-plist
@@ -0,0 +1,14 @@
+bin/pp2sdf
+%%SITE_PERL%%/PerlPoint/Anchors.pm
+%%SITE_PERL%%/PerlPoint/Backend.pm
+%%SITE_PERL%%/PerlPoint/Constants.pm
+%%SITE_PERL%%/PerlPoint/Parser.pm
+%%SITE_PERL%%/PerlPoint/Tags.pm
+%%SITE_PERL%%/PerlPoint/Tags/Basic.pm
+%%SITE_PERL%%/PerlPoint/Tags/CPPP.pm
+%%SITE_PERL%%/PerlPoint/Tags/SDF.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/PerlPoint/Package/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/PerlPoint/Package
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/PerlPoint 2>/dev/null || true
+@dirrm %%SITE_PERL%%/PerlPoint/Tags
+@unexec rmdir %D/%%SITE_PERL%%/PerlPoint 2>/dev/null || true