aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Plagger
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2006-08-22 09:20:26 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2006-08-22 09:20:26 +0000
commit008bee4237d5fd5e7989a16609f377e1308f79b8 (patch)
tree61425f9cc10628db3aa7418b5f1c183df13ac77f /textproc/p5-Plagger
parentb56f39a4b0d242f6db9d4782857fe62e33cb2cad (diff)
downloadports-008bee4237d5fd5e7989a16609f377e1308f79b8.tar.gz
ports-008bee4237d5fd5e7989a16609f377e1308f79b8.zip
Plagger is a pluggable RSS/Atom feed aggregator written in
Perl. Everything is implemented as a small plugin and you can mash them up together using Plagger core API and plugin hooks. You can think of Plagger as a blosxom or qpsmtpd for RSS aggregator. WWW: http://plagger.org/ WARNING: This port depends on thousands of ports spececially with full options.
Notes
Notes: svn path=/head/; revision=171172
Diffstat (limited to 'textproc/p5-Plagger')
-rw-r--r--textproc/p5-Plagger/Makefile335
-rw-r--r--textproc/p5-Plagger/distinfo3
-rw-r--r--textproc/p5-Plagger/pkg-descr6
-rw-r--r--textproc/p5-Plagger/pkg-plist229
4 files changed, 573 insertions, 0 deletions
diff --git a/textproc/p5-Plagger/Makefile b/textproc/p5-Plagger/Makefile
new file mode 100644
index 000000000000..2e8304a8e304
--- /dev/null
+++ b/textproc/p5-Plagger/Makefile
@@ -0,0 +1,335 @@
+# New ports collection makefile for: plagger
+# Date created: 22 August 2006
+# Whom: sumikawa@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Plagger
+PORTVERSION= 0.7.8
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/M/MI/MIYAGAWA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sumikawa@FreeBSD.org
+COMMENT= A pluggable RSS/Atom feed aggregator written in Perl
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/DateTime/Format/Mail.pm:${PORTSDIR}/devel/p5-DateTime-Format-Mail \
+ ${SITE_PERL}/DateTime/Format/Strptime.pm:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
+ ${SITE_PERL}/DateTime/Format/W3CDTF.pm:${PORTSDIR}/devel/p5-DateTime-Format-W3CDTF \
+ ${SITE_PERL}/Cache.pm:${PORTSDIR}/devel/p5-Cache \
+ ${SITE_PERL}/Cache/Cache.pm:${PORTSDIR}/devel/p5-Cache-Cache \
+ ${SITE_PERL}/File/Find/Rule.pm:${PORTSDIR}/devel/p5-File-Find-Rule \
+ ${SITE_PERL}/File/HomeDir.pm:${PORTSDIR}/devel/p5-File-HomeDir \
+ ${SITE_PERL}/Module/Install.pm:${PORTSDIR}/devel/p5-Module-Install \
+ ${SITE_PERL}/Module/Pluggable/Fast.pm:${PORTSDIR}/devel/p5-Module-Pluggable-Fast \
+ ${SITE_PERL}/Term/Encoding.pm:${PORTSDIR}/devel/p5-Term-Encoding \
+ ${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-require \
+ ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
+ ${SITE_PERL}/MIME/Types.pm:${PORTSDIR}/mail/p5-MIME-Types \
+ ${SITE_PERL}/Text/Tags.pm:${PORTSDIR}/textproc/p5-Text-Tags \
+ ${SITE_PERL}/XML/Feed.pm:${PORTSDIR}/textproc/p5-XML-Feed \
+ ${SITE_PERL}/XML/RSS/LibXML.pm:${PORTSDIR}/textproc/p5-XML-RSS-LibXML \
+ ${SITE_PERL}/${PERL_ARCH}/Template/Toolkit.pod:${PORTSDIR}/www/p5-Template-Toolkit \
+ ${SITE_PERL}/Template/Provider/Encoding.pm:${PORTSDIR}/www/p5-Template-Provider-Encoding \
+ ${SITE_PERL}/HTML/ResolveLink.pm:${PORTSDIR}/www/p5-HTML-ResolveLink \
+ ${SITE_PERL}/URI/Fetch.pm:${PORTSDIR}/www/p5-URI-Fetch
+
+OPTIONS= PODTESTING "POD Testing Support" off \
+ LIBERALXML "Liberal XML parsing Support" on \
+ XPATH "XPath Support" on \
+ PUBLISHEXCEL "Publish::Excel Support" off \
+ FILTERPIPE "Filter::Pipe Support" off \
+ PUBLISHPLANET "Publish::Planet Support" off \
+ AUTHORNAME "Filter::ExtractAuthorName Support" off \
+ PUBLISHMT "Publish::MT Support" off \
+ ROMANIZE "Filter::Romanize Support" off \
+ SUBSCOPML "Subscription::OPML Support" on \
+ FLICKRSEARCH "CustomFeed::FlickrSearch Support" off \
+ PALMDOC "Publish::PalmDoc Support" off \
+ FILTERPPT "Filter::TTP Support" off \
+ KINOSEARCH "Search::KinoSearch Support" off \
+ PUBDELICIOUS "Publish::Delicious Support" off \
+ HATENARSS "Subscription::HatenaRSS Support" off \
+ NOTIFYIRC "Notify::IRC Support" off \
+ IMAGEINFO "Filter::ImageInfo Support" off \
+ PUBLISHIMAP "Publish::IMAP Support" off \
+ BLOGLINES "Subscription::Bloglines Support" off \
+ CUSFEEDMIXI "CustomFeed::Mixi Support" off \
+ NTFYNETSEND "Notify::NetSend Support" off \
+ FILHTMLSCRB "Filter::HTMLScrubber Support" off
+# The below options are not supported yet due to missing depending modules
+# BETTERENCODING "Better Encoding detection Support" on \
+# COOKIESHARING "Cookie sharing with Firefox Support" off \
+# CUSTOMSVNLOG "CustomFeed::SVNLog Support" off \
+# PUBLISHCSV "Publish::CSV Support" off \
+# JAVASCRIPT "Publish::JavaScript Support" off \
+# EMOTICON "Filter::Emoticon Support" off \
+# HATENA "Filter::Hatena Support" off \
+# RULEFRESH "Rule::Fresh Support" on \
+# SUBSCRDBI "Subscription::DBI Support" off \
+# NOTIFYBEEP "Notify::Beep Support" off \
+# PUBLISHGMAIL "Publish::Gmail Support" on \
+# SUBSCRFOAF "Subscription::FOAF Support" off \
+# ESTRAIER "Search::Estraier Support" off \
+# PROFANITY "Filter::Profanity Support" off \
+# AGRXANGO "Aggregator::Xango Support" off \
+# GUESSLANGUAGE "Filter::GuessLanguage Support" off \
+# LIVEDOOR "Subscription::LivedoorReader Support" off \
+# PUBLISHPDF "Publish::PDF Support" off \
+# BABELFISH "Filter::Babelfish Support" off \
+# PUBLISHSWF "Publish::SWF Support" off \
+# PLANETINI "Subscription::PlanetINI Support" off \
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PODTESTING)
+BUILD_DEPENDS+= ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
+ ${SITE_PERL}/Test/Pod/Coverage.pm:${PORTSDIR}/devel/p5-Test-Pod-Coverage
+.endif
+
+.if !defined(WITHOUT_LIBERALXML)
+BUILD_DEPENDS+= ${SITE_PERL}/XML/Liberal.pm:${PORTSDIR}/textproc/p5-XML-Liberal \
+ ${SITE_PERL}/XML/RSS/Liberal.pm:${PORTSDIR}/textproc/p5-XML-RSS-Liberal
+.endif
+
+.if !defined(WITHOUT_XPATH)
+BUILD_DEPENDS+= ${SITE_PERL}/HTML/TreeBuilder/XPath.pm:${PORTSDIR}/www/p5-HTML-TreeBuilder-XPath
+.endif
+
+.if defined(WITH_PUBLISHEXCEL)
+BUILD_DEPENDS+= ${SITE_PERL}/Spreadsheet/WriteExcel.pm:${PORTSDIR}/textproc/p5-Spreadsheet-WriteExcel
+.endif
+
+.if defined(WITH_FILTERPIPE)
+BUILD_DEPENDS+= ${SITE_PERL}/IPC/Run.pm:${PORTSDIR}/devel/p5-IPC-Run
+.endif
+
+.if defined(WITH_PUBLISHPLANET)
+BUILD_DEPENDS+= ${SITE_PERL}/File/Copy/Recursive.pm:${PORTSDIR}/devel/p5-File-Copy-Recursive \
+ ${SITE_PERL}/HTML/Scrubber.pm:${PORTSDIR}/www/p5-HTML-Scrubber
+.endif
+
+.if defined(WITH_AUTHORNAME)
+BUILD_DEPENDS+= ${SITE_PERL}/Email/Address.pm:${PORTSDIR}/mail/p5-Email-Address
+.endif
+
+.if defined(WITH_PUBLISHMT)
+BUILD_DEPENDS+= ${SITE_PERL}/Net/MovableType.pm:${PORTSDIR}/net/p5-Net-MovableType
+.endif
+
+.if defined(WITH_ROMANIZE)
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Text/Kakasi.pm:${PORTSDIR}/japanese/p5-Text-Kakasi
+.endif
+
+.if !defined(WITHOUT_SUBSCOPML)
+BUILD_DEPENDS+= ${SITE_PERL}/XML/OPML.pm:${PORTSDIR}/textproc/p5-XML-OPML
+.endif
+
+.if defined(WITH_FLICKRSEARCH)
+BUILD_DEPENDS+= ${SITE_PERL}/Flickr/API.pm:${PORTSDIR}/www/p5-Flickr-API \
+ ${SITE_PERL}/DateTime/Format/Epoch.pm:${PORTSDIR}/devel/p5-DateTime-Format-Epoch
+.endif
+
+.if defined(WITH_PALMDOC)
+BUILD_DEPENDS+= ${SITE_PERL}/Palm/PalmDoc.pm:${PORTSDIR}/palm/p5-Palm-PalmDoc
+.endif
+
+.if defined(WITH_FILTERPPT)
+BUILD_DEPENDS+= ${SITE_PERL}/URI/Find.pm:${PORTSDIR}/textproc/p5-URI-Find
+.endif
+
+.if defined(WITH_KINOSEARCH)
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/KinoSearch.pm:${PORTSDIR}/textproc/p5-KinoSearch
+.endif
+
+.if defined(WITH_PUBDELICIOUS)
+BUILD_DEPENDS+= ${SITE_PERL}/Net/Delicious.pm:${PORTSDIR}/net/p5-Net-Delicious
+.endif
+
+.if defined(WITH_HATENARSS)
+BUILD_DEPENDS+= ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize
+.endif
+
+.if defined(WITH_NOTIFYIRC)
+BUILD_DEPENDS+= ${SITE_PERL}/POE/Component/IRC.pm:${PORTSDIR}/irc/p5-POE-Component-IRC \
+ ${SITE_PERL}/POE/Component/IKC.pm:${PORTSDIR}/devel/p5-POE-Component-IKC
+.endif
+
+.if defined(WITH_IMAGEINFO)
+BUILD_DEPENDS+= ${SITE_PERL}/Image/Info.pm:${PORTSDIR}/graphics/p5-Image-Info
+.endif
+
+.if defined(WITH_PUBLISHIMAP)
+BUILD_DEPENDS+= ${SITE_PERL}/Mail/IMAPClient.pm:${PORTSDIR}/mail/p5-Mail-IMAPClient
+.endif
+
+.if defined(WITH_BLOGLINES)
+BUILD_DEPENDS+= ${SITE_PERL}/WebService/Bloglines.pm:${PORTSDIR}/www/p5-WebService-Bloglines
+.endif
+
+.if defined(WITH_CUSFEEDMIXI)
+BUILD_DEPENDS+= ${SITE_PERL}/WWW/Mixi.pm:${PORTSDIR}/www/p5-WWW-Mixi
+.endif
+
+.if defined(WITH_NTFYNETSEND)
+BUILD_DEPENDS+= ${SITE_PERL}/Net/NetSend.pm:${PORTSDIR}/net-im/p5-Net-NetSend
+.endif
+
+.if defined(WITH_FILHTMLSCRB)
+BUILD_DEPENDS+= ${SITE_PERL}/HTML/Scrubber.pm:${PORTSDIR}/www/p5-HTML-Scrubber
+.endif
+
+RUN_DEPENDS= ${BUILD_DEPENDS}
+PERL_CONFIGURE= yes
+
+MAN3= Plagger.3 Plagger::Cookies.3 \
+ Plagger::Plugin::Aggregator::Null.3 \
+ Plagger::Plugin::Aggregator::Simple.3 \
+ Plagger::Plugin::Bundle::Planet.3 \
+ Plagger::Plugin::CustomFeed::2chSearch.3 \
+ Plagger::Plugin::CustomFeed::AmazonAssociateReportJP.3 \
+ Plagger::Plugin::CustomFeed::BloglinesCitations.3 \
+ Plagger::Plugin::CustomFeed::Debug.3 \
+ Plagger::Plugin::CustomFeed::FlickrSearch.3 \
+ Plagger::Plugin::CustomFeed::Frepa.3 \
+ Plagger::Plugin::CustomFeed::GoogleNews.3 \
+ Plagger::Plugin::CustomFeed::Mailman.3 \
+ Plagger::Plugin::CustomFeed::Mixi.3 \
+ Plagger::Plugin::CustomFeed::MixiDiarySearch.3 \
+ Plagger::Plugin::CustomFeed::POP3.3 \
+ Plagger::Plugin::CustomFeed::PerlMonks.3 \
+ Plagger::Plugin::CustomFeed::SVNLog.3 \
+ Plagger::Plugin::CustomFeed::Simple.3 \
+ Plagger::Plugin::CustomFeed::Yahoo360JP.3 \
+ Plagger::Plugin::CustomFeed::YouTube.3 \
+ Plagger::Plugin::CustomFeed::iTunesRecentPlay.3 \
+ Plagger::Plugin::Filter::2chNewsokuTitle.3 \
+ Plagger::Plugin::Filter::2chRSSContent.3 \
+ Plagger::Plugin::Filter::AtomLinkRelated.3 \
+ Plagger::Plugin::Filter::Babelfish.3 \
+ Plagger::Plugin::Filter::Base.3 \
+ Plagger::Plugin::Filter::BlogPet.3 \
+ Plagger::Plugin::Filter::BloglinesContentNormalize.3 \
+ Plagger::Plugin::Filter::BreakEntriesToFeeds.3 \
+ Plagger::Plugin::Filter::BulkfeedsTerms.3 \
+ Plagger::Plugin::Filter::CompositeFeed.3 \
+ Plagger::Plugin::Filter::Delicious.3 \
+ Plagger::Plugin::Filter::DeliciousFeedTags.3 \
+ Plagger::Plugin::Filter::Emoticon.3 \
+ Plagger::Plugin::Filter::EntryFullText.3 \
+ Plagger::Plugin::Filter::ExtractAuthorName.3 \
+ Plagger::Plugin::Filter::FeedBurnerPermalink.3 \
+ Plagger::Plugin::Filter::FeedFlareStripper.3 \
+ Plagger::Plugin::Filter::FetchEnclosure.3 \
+ Plagger::Plugin::Filter::FetchEnclosure::Curl.3 \
+ Plagger::Plugin::Filter::FetchEnclosure::ParallelUA.3 \
+ Plagger::Plugin::Filter::FetchEnclosure::Wget.3 \
+ Plagger::Plugin::Filter::FindEnclosures.3 \
+ Plagger::Plugin::Filter::FloatingDateTime.3 \
+ Plagger::Plugin::Filter::GuessLanguage.3 \
+ Plagger::Plugin::Filter::HEADEnclosureMetadata.3 \
+ Plagger::Plugin::Filter::HTMLScrubber.3 \
+ Plagger::Plugin::Filter::HatenaBookmarkTag.3 \
+ Plagger::Plugin::Filter::HatenaBookmarkUsersCount.3 \
+ Plagger::Plugin::Filter::HatenaDiaryKeywordLink.3 \
+ Plagger::Plugin::Filter::HatenaDiaryKeywordUnlink.3 \
+ Plagger::Plugin::Filter::HatenaFormat.3 \
+ Plagger::Plugin::Filter::HatenaKeywordTag.3 \
+ Plagger::Plugin::Filter::ImageInfo.3 \
+ Plagger::Plugin::Filter::LivedoorKeywordUnlink.3 \
+ Plagger::Plugin::Filter::Markdown.3 \
+ Plagger::Plugin::Filter::POPFile.3 \
+ Plagger::Plugin::Filter::Pipe.3 \
+ Plagger::Plugin::Filter::Profanity.3 \
+ Plagger::Plugin::Filter::RSSLiberalDateTime.3 \
+ Plagger::Plugin::Filter::RSSTimeZoneString.3 \
+ Plagger::Plugin::Filter::Regexp.3 \
+ Plagger::Plugin::Filter::ResolveRelativeLink.3 \
+ Plagger::Plugin::Filter::RewriteEnclosureURL.3 \
+ Plagger::Plugin::Filter::Rule.3 \
+ Plagger::Plugin::Filter::SpamAssassin.3 \
+ Plagger::Plugin::Filter::StripRSSAd.3 \
+ Plagger::Plugin::Filter::StripTagsFromTitle.3 \
+ Plagger::Plugin::Filter::TTP.3 \
+ Plagger::Plugin::Filter::TagsToTitle.3 \
+ Plagger::Plugin::Filter::Thumbnail.3 \
+ Plagger::Plugin::Filter::TruePermalink.3 \
+ Plagger::Plugin::Filter::tDiaryComment.3 \
+ Plagger::Plugin::Notify::Balloon.3 \
+ Plagger::Plugin::Notify::Beep.3 \
+ Plagger::Plugin::Notify::Campfire.3 \
+ Plagger::Plugin::Notify::Eject.3 \
+ Plagger::Plugin::Notify::Eject::darwin.3 \
+ Plagger::Plugin::Notify::Eject::freebsd.3 \
+ Plagger::Plugin::Notify::Eject::linux.3 \
+ Plagger::Plugin::Notify::Eject::mswin32.3 \
+ Plagger::Plugin::Notify::IRC.3 \
+ Plagger::Plugin::Notify::MSAgent.3 \
+ Plagger::Plugin::Notify::NetSend.3 \
+ Plagger::Plugin::Notify::SSTP.3 \
+ Plagger::Plugin::Notify::Tiarra.3 \
+ Plagger::Plugin::Notify::UpdatePing.3 \
+ Plagger::Plugin::Publish::2chdat.3 \
+ Plagger::Plugin::Publish::CSV.3 \
+ Plagger::Plugin::Publish::Delicious.3 \
+ Plagger::Plugin::Publish::Excel.3 \
+ Plagger::Plugin::Publish::FOAFRoll.3 \
+ Plagger::Plugin::Publish::Feed.3 \
+ Plagger::Plugin::Publish::Gmail.3 \
+ Plagger::Plugin::Publish::HatenaBookmark.3 \
+ Plagger::Plugin::Publish::IMAP.3 \
+ Plagger::Plugin::Publish::JavaScript.3 \
+ Plagger::Plugin::Publish::LivedoorClip.3 \
+ Plagger::Plugin::Publish::MT.3 \
+ Plagger::Plugin::Publish::MTWidget.3 \
+ Plagger::Plugin::Publish::Maildir.3 \
+ Plagger::Plugin::Publish::OPML.3 \
+ Plagger::Plugin::Publish::OutlineText.3 \
+ Plagger::Plugin::Publish::PDF.3 \
+ Plagger::Plugin::Publish::PalmDoc.3 \
+ Plagger::Plugin::Publish::Pipe.3 \
+ Plagger::Plugin::Publish::Planet.3 \
+ Plagger::Plugin::Publish::Playlog.3 \
+ Plagger::Plugin::Publish::PowerPoint.3 \
+ Plagger::Plugin::Publish::SWF.3 \
+ Plagger::Plugin::Publish::Speech::MacOSX.3 \
+ Plagger::Plugin::Search::Estraier.3 \
+ Plagger::Plugin::Search::KinoSearch.3 \
+ Plagger::Plugin::Search::Namazu.3 \
+ Plagger::Plugin::Search::Rast.3 \
+ Plagger::Plugin::Search::Spotlight.3 \
+ Plagger::Plugin::Subscription::Bloglines.3 \
+ Plagger::Plugin::Subscription::Bookmarks.3 \
+ Plagger::Plugin::Subscription::Config.3 \
+ Plagger::Plugin::Subscription::DBI.3 \
+ Plagger::Plugin::Subscription::FOAF.3 \
+ Plagger::Plugin::Subscription::Feed.3 \
+ Plagger::Plugin::Subscription::File.3 \
+ Plagger::Plugin::Subscription::HatenaGroup.3 \
+ Plagger::Plugin::Subscription::HatenaRSS.3 \
+ Plagger::Plugin::Subscription::LivedoorReader.3 \
+ Plagger::Plugin::Subscription::OPML.3 \
+ Plagger::Plugin::Subscription::Odeo.3 \
+ Plagger::Plugin::Subscription::PingServer.3 \
+ Plagger::Plugin::Subscription::Planet.3 \
+ Plagger::Plugin::Subscription::PlanetINI.3 \
+ Plagger::Plugin::Subscription::XOXO.3 \
+ Plagger::Plugin::Subscription::XPath.3 \
+ Plagger::Plugin::UserAgent::AuthenRequest.3 \
+ Plagger::Plugin::UserAgent::RequestHeader.3 \
+ Plagger::Plugin::Widget::BloglinesSubscription.3 \
+ Plagger::Plugin::Widget::BulkfeedsSpamReport.3 \
+ Plagger::Plugin::Widget::Delicious.3 \
+ Plagger::Plugin::Widget::HatenaBookmarkUsersCount.3 \
+ Plagger::Plugin::Widget::Simple.3 \
+ Plagger::Rule::Deduped.3 \
+ Plagger::Rule::Fresh.3 \
+ Plagger::Rule::URLBL.3 \
+
+post-patch:
+ ${PERL} -pi -e '$$_ = "" if m|auto_install|' ${WRKSRC}/Makefile.PL \
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Plagger/distinfo b/textproc/p5-Plagger/distinfo
new file mode 100644
index 000000000000..219d7d7f684e
--- /dev/null
+++ b/textproc/p5-Plagger/distinfo
@@ -0,0 +1,3 @@
+MD5 (Plagger-0.7.8.tar.gz) = 30d3d245cc216ca306b2c2b97010bff7
+SHA256 (Plagger-0.7.8.tar.gz) = ff9995f3cd3d84e77090852a083509fb539ca0f161d0288039d21897c3ccc90f
+SIZE (Plagger-0.7.8.tar.gz) = 258201
diff --git a/textproc/p5-Plagger/pkg-descr b/textproc/p5-Plagger/pkg-descr
new file mode 100644
index 000000000000..dc4aa28d43af
--- /dev/null
+++ b/textproc/p5-Plagger/pkg-descr
@@ -0,0 +1,6 @@
+Plagger is a pluggable RSS/Atom feed aggregator written in
+Perl. Everything is implemented as a small plugin and you can mash
+them up together using Plagger core API and plugin hooks. You can
+think of Plagger as a blosxom or qpsmtpd for RSS aggregator.
+
+WWW: http://plagger.org/
diff --git a/textproc/p5-Plagger/pkg-plist b/textproc/p5-Plagger/pkg-plist
new file mode 100644
index 000000000000..5c45020c00cc
--- /dev/null
+++ b/textproc/p5-Plagger/pkg-plist
@@ -0,0 +1,229 @@
+bin/plagger
+bin/plagger-ircbot
+%%SITE_PERL%%/Plagger.pm
+%%SITE_PERL%%/Plagger/Cache.pm
+%%SITE_PERL%%/Plagger/Cache/Null.pm
+%%SITE_PERL%%/Plagger/CacheProxy.pm
+%%SITE_PERL%%/Plagger/ConfigLoader.pm
+%%SITE_PERL%%/Plagger/Cookies.pm
+%%SITE_PERL%%/Plagger/Crypt.pm
+%%SITE_PERL%%/Plagger/Crypt/Base64.pm
+%%SITE_PERL%%/Plagger/Date.pm
+%%SITE_PERL%%/Plagger/Enclosure.pm
+%%SITE_PERL%%/Plagger/Entry.pm
+%%SITE_PERL%%/Plagger/Feed.pm
+%%SITE_PERL%%/Plagger/Mechanize.pm
+%%SITE_PERL%%/Plagger/Operator.pm
+%%SITE_PERL%%/Plagger/Plugin.pm
+%%SITE_PERL%%/Plagger/Plugin/Aggregator/Null.pm
+%%SITE_PERL%%/Plagger/Plugin/Aggregator/Simple.pm
+%%SITE_PERL%%/Plagger/Plugin/Aggregator/Xango.pm
+%%SITE_PERL%%/Plagger/Plugin/Bundle/Planet.pm
+%%SITE_PERL%%/Plagger/Plugin/CustomFeed/2chSearch.pm
+%%SITE_PERL%%/Plagger/Plugin/CustomFeed/AmazonAssociateReportJP.pm
+%%SITE_PERL%%/Plagger/Plugin/CustomFeed/BloglinesCitations.pm
+%%SITE_PERL%%/Plagger/Plugin/CustomFeed/Debug.pm
+%%SITE_PERL%%/Plagger/Plugin/CustomFeed/FlickrSearch.pm
+%%SITE_PERL%%/Plagger/Plugin/CustomFeed/Frepa.pm
+%%SITE_PERL%%/Plagger/Plugin/CustomFeed/Frepa/FriendDiary.pm
+%%SITE_PERL%%/Plagger/Plugin/CustomFeed/Frepa/FriendStatus.pm
+%%SITE_PERL%%/Plagger/Plugin/CustomFeed/Frepa/RecentComment.pm
+%%SITE_PERL%%/Plagger/Plugin/CustomFeed/GoogleNews.pm
+%%SITE_PERL%%/Plagger/Plugin/CustomFeed/Mailman.pm
+%%SITE_PERL%%/Plagger/Plugin/CustomFeed/Mixi.pm
+%%SITE_PERL%%/Plagger/Plugin/CustomFeed/MixiDiarySearch.pm
+%%SITE_PERL%%/Plagger/Plugin/CustomFeed/POP3.pm
+%%SITE_PERL%%/Plagger/Plugin/CustomFeed/PerlMonks.pm
+%%SITE_PERL%%/Plagger/Plugin/CustomFeed/SVNLog.pm
+%%SITE_PERL%%/Plagger/Plugin/CustomFeed/Simple.pm
+%%SITE_PERL%%/Plagger/Plugin/CustomFeed/Yahoo360JP.pm
+%%SITE_PERL%%/Plagger/Plugin/CustomFeed/YouTube.pm
+%%SITE_PERL%%/Plagger/Plugin/CustomFeed/iTunesRecentPlay.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/2chNewsokuTitle.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/2chRSSContent.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/AtomLinkRelated.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/Babelfish.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/Base.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/BlogPet.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/BloglinesContentNormalize.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/BreakEntriesToFeeds.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/BulkfeedsTerms.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/CompositeFeed.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/Delicious.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/DeliciousFeedTags.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/Emoticon.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/EntryFullText.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/ExtractAuthorName.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/FeedBurnerPermalink.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/FeedFlareStripper.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/FetchEnclosure.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/FetchEnclosure/Curl.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/FetchEnclosure/ParallelUA.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/FetchEnclosure/Wget.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/FetchEnclosure/Xango.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/FindEnclosures.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/FloatingDateTime.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/GuessLanguage.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/HEADEnclosureMetadata.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/HTMLScrubber.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/HatenaBookmarkTag.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/HatenaBookmarkUsersCount.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/HatenaDiaryKeywordLink.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/HatenaDiaryKeywordUnlink.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/HatenaFormat.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/HatenaKeywordTag.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/ImageInfo.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/LivedoorKeywordUnlink.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/Markdown.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/POPFile.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/Pipe.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/Profanity.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/RSSLiberalDateTime.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/RSSTimeZoneString.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/Regexp.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/ResolveRelativeLink.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/RewriteEnclosureURL.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/Romanize.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/Romanize/Japanese.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/Rule.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/SpamAssassin.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/StripRSSAd.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/StripTagsFromTitle.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/TTP.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/TagsToTitle.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/Thumbnail.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/TruePermalink.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/URLBL.pm
+%%SITE_PERL%%/Plagger/Plugin/Filter/tDiaryComment.pm
+%%SITE_PERL%%/Plagger/Plugin/Notify/Balloon.pm
+%%SITE_PERL%%/Plagger/Plugin/Notify/Beep.pm
+%%SITE_PERL%%/Plagger/Plugin/Notify/Campfire.pm
+%%SITE_PERL%%/Plagger/Plugin/Notify/Eject.pm
+%%SITE_PERL%%/Plagger/Plugin/Notify/Eject/darwin.pm
+%%SITE_PERL%%/Plagger/Plugin/Notify/Eject/freebsd.pm
+%%SITE_PERL%%/Plagger/Plugin/Notify/Eject/linux.pm
+%%SITE_PERL%%/Plagger/Plugin/Notify/Eject/mswin32.pm
+%%SITE_PERL%%/Plagger/Plugin/Notify/Growl.pm
+%%SITE_PERL%%/Plagger/Plugin/Notify/IRC.pm
+%%SITE_PERL%%/Plagger/Plugin/Notify/MSAgent.pm
+%%SITE_PERL%%/Plagger/Plugin/Notify/NetSend.pm
+%%SITE_PERL%%/Plagger/Plugin/Notify/SSTP.pm
+%%SITE_PERL%%/Plagger/Plugin/Notify/Tiarra.pm
+%%SITE_PERL%%/Plagger/Plugin/Notify/UpdatePing.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/2chdat.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/CHTML.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/CSV.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/Debug.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/Delicious.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/Excel.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/FOAFRoll.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/Feed.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/Gmail.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/HatenaBookmark.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/IMAP.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/JavaScript.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/LivedoorClip.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/MT.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/MTWidget.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/Maildir.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/OPML.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/OutlineText.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/PDF.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/PSP.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/PalmDoc.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/Pipe.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/Planet.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/Playlog.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/PowerPoint.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/SWF.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/Speech.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/Speech/MacOSX.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/Speech/Win32.pm
+%%SITE_PERL%%/Plagger/Plugin/Publish/Takahashi.pm
+%%SITE_PERL%%/Plagger/Plugin/Search/Estraier.pm
+%%SITE_PERL%%/Plagger/Plugin/Search/KinoSearch.pm
+%%SITE_PERL%%/Plagger/Plugin/Search/Namazu.pm
+%%SITE_PERL%%/Plagger/Plugin/Search/Rast.pm
+%%SITE_PERL%%/Plagger/Plugin/Search/Spotlight.pm
+%%SITE_PERL%%/Plagger/Plugin/SmartFeed.pm
+%%SITE_PERL%%/Plagger/Plugin/SmartFeed/All.pm
+%%SITE_PERL%%/Plagger/Plugin/Subscription/2chThreadList.pm
+%%SITE_PERL%%/Plagger/Plugin/Subscription/Bloglines.pm
+%%SITE_PERL%%/Plagger/Plugin/Subscription/Bookmarks.pm
+%%SITE_PERL%%/Plagger/Plugin/Subscription/Bookmarks/InternetExplorer.pm
+%%SITE_PERL%%/Plagger/Plugin/Subscription/Bookmarks/Mozilla.pm
+%%SITE_PERL%%/Plagger/Plugin/Subscription/Bookmarks/Safari.pm
+%%SITE_PERL%%/Plagger/Plugin/Subscription/Config.pm
+%%SITE_PERL%%/Plagger/Plugin/Subscription/DBI.pm
+%%SITE_PERL%%/Plagger/Plugin/Subscription/FOAF.pm
+%%SITE_PERL%%/Plagger/Plugin/Subscription/Feed.pm
+%%SITE_PERL%%/Plagger/Plugin/Subscription/File.pm
+%%SITE_PERL%%/Plagger/Plugin/Subscription/HatenaGroup.pm
+%%SITE_PERL%%/Plagger/Plugin/Subscription/HatenaRSS.pm
+%%SITE_PERL%%/Plagger/Plugin/Subscription/LivedoorReader.pm
+%%SITE_PERL%%/Plagger/Plugin/Subscription/OPML.pm
+%%SITE_PERL%%/Plagger/Plugin/Subscription/Odeo.pm
+%%SITE_PERL%%/Plagger/Plugin/Subscription/PingServer.pm
+%%SITE_PERL%%/Plagger/Plugin/Subscription/Planet.pm
+%%SITE_PERL%%/Plagger/Plugin/Subscription/PlanetINI.pm
+%%SITE_PERL%%/Plagger/Plugin/Subscription/XOXO.pm
+%%SITE_PERL%%/Plagger/Plugin/Subscription/XPath.pm
+%%SITE_PERL%%/Plagger/Plugin/UserAgent/AuthenRequest.pm
+%%SITE_PERL%%/Plagger/Plugin/UserAgent/RequestHeader.pm
+%%SITE_PERL%%/Plagger/Plugin/Widget/BloglinesSubscription.pm
+%%SITE_PERL%%/Plagger/Plugin/Widget/BulkfeedsSpamReport.pm
+%%SITE_PERL%%/Plagger/Plugin/Widget/Delicious.pm
+%%SITE_PERL%%/Plagger/Plugin/Widget/HatenaBookmark.pm
+%%SITE_PERL%%/Plagger/Plugin/Widget/HatenaBookmarkUsersCount.pm
+%%SITE_PERL%%/Plagger/Plugin/Widget/Simple.pm
+%%SITE_PERL%%/Plagger/Rule.pm
+%%SITE_PERL%%/Plagger/Rule/Always.pm
+%%SITE_PERL%%/Plagger/Rule/DateTimeCron.pm
+%%SITE_PERL%%/Plagger/Rule/Deduped.pm
+%%SITE_PERL%%/Plagger/Rule/Deduped/Base.pm
+%%SITE_PERL%%/Plagger/Rule/Deduped/DB_File.pm
+%%SITE_PERL%%/Plagger/Rule/EntryTag.pm
+%%SITE_PERL%%/Plagger/Rule/Expression.pm
+%%SITE_PERL%%/Plagger/Rule/FeedAttr.pm
+%%SITE_PERL%%/Plagger/Rule/FeedType.pm
+%%SITE_PERL%%/Plagger/Rule/Fresh.pm
+%%SITE_PERL%%/Plagger/Rule/Rating.pm
+%%SITE_PERL%%/Plagger/Rule/URLBL.pm
+%%SITE_PERL%%/Plagger/Rules.pm
+%%SITE_PERL%%/Plagger/Subscription.pm
+%%SITE_PERL%%/Plagger/TT/Plagger/Util.pm
+%%SITE_PERL%%/Plagger/Tag.pm
+%%SITE_PERL%%/Plagger/Template.pm
+%%SITE_PERL%%/Plagger/Thing.pm
+%%SITE_PERL%%/Plagger/Update.pm
+%%SITE_PERL%%/Plagger/UserAgent.pm
+%%SITE_PERL%%/Plagger/Util.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Plagger/.packlist
+@dirrm %%SITE_PERL%%/Plagger/TT/Plagger
+@dirrm %%SITE_PERL%%/Plagger/TT
+@dirrm %%SITE_PERL%%/Plagger/Rule/Deduped
+@dirrm %%SITE_PERL%%/Plagger/Rule
+@dirrm %%SITE_PERL%%/Plagger/Plugin/Widget
+@dirrm %%SITE_PERL%%/Plagger/Plugin/UserAgent
+@dirrm %%SITE_PERL%%/Plagger/Plugin/Subscription/Bookmarks
+@dirrm %%SITE_PERL%%/Plagger/Plugin/Subscription
+@dirrm %%SITE_PERL%%/Plagger/Plugin/SmartFeed
+@dirrm %%SITE_PERL%%/Plagger/Plugin/Search
+@dirrm %%SITE_PERL%%/Plagger/Plugin/Publish/Speech
+@dirrm %%SITE_PERL%%/Plagger/Plugin/Publish
+@dirrm %%SITE_PERL%%/Plagger/Plugin/Notify/Eject
+@dirrm %%SITE_PERL%%/Plagger/Plugin/Notify
+@dirrm %%SITE_PERL%%/Plagger/Plugin/Filter/Romanize
+@dirrm %%SITE_PERL%%/Plagger/Plugin/Filter/FetchEnclosure
+@dirrm %%SITE_PERL%%/Plagger/Plugin/Filter
+@dirrm %%SITE_PERL%%/Plagger/Plugin/CustomFeed/Frepa
+@dirrm %%SITE_PERL%%/Plagger/Plugin/CustomFeed
+@dirrm %%SITE_PERL%%/Plagger/Plugin/Bundle
+@dirrm %%SITE_PERL%%/Plagger/Plugin/Aggregator
+@dirrm %%SITE_PERL%%/Plagger/Plugin
+@dirrm %%SITE_PERL%%/Plagger/Crypt
+@dirrm %%SITE_PERL%%/Plagger/Cache
+@dirrm %%SITE_PERL%%/Plagger
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plagger
+
+