aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-RDFStore
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-01-22 12:48:01 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-01-22 12:48:01 +0000
commit7799bea937b4f41f4c39efe75e8b71cc22697be2 (patch)
tree0f9e326d123d64903adb6f9bc78b869c250b7993 /textproc/p5-RDFStore
parent10bae222c718ef58149ba67e320296df43e49ccb (diff)
downloadports-7799bea937b4f41f4c39efe75e8b71cc22697be2.tar.gz
ports-7799bea937b4f41f4c39efe75e8b71cc22697be2.zip
- Unbreak on amd64.
- Remove unused dependencies. - Pass maintainer to perl@.
Notes
Notes: svn path=/head/; revision=248358
Diffstat (limited to 'textproc/p5-RDFStore')
-rw-r--r--textproc/p5-RDFStore/Makefile13
-rw-r--r--textproc/p5-RDFStore/files/patch-Makefile.PL24
2 files changed, 27 insertions, 10 deletions
diff --git a/textproc/p5-RDFStore/Makefile b/textproc/p5-RDFStore/Makefile
index 5fca1d4a0daf..6c3a97694afe 100644
--- a/textproc/p5-RDFStore/Makefile
+++ b/textproc/p5-RDFStore/Makefile
@@ -7,17 +7,16 @@
PORTNAME= RDFStore
PORTVERSION= 0.51
+PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= skv@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Perl API for RDF Storage
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
- ${SITE_PERL}/Digest.pm:${PORTSDIR}/security/p5-Digest \
${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -45,10 +44,4 @@ pre-configure:
@${ECHO} "LIB=${BDB_LIB_DIR}" >> ${WRKSRC}/arch_conf.in
@${ECHO} "DBNAME=-l${BDB_LIB_NAME}" >> ${WRKSRC}/arch_conf.in
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == amd64
-BROKEN= does not compile on ${ARCH}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/p5-RDFStore/files/patch-Makefile.PL b/textproc/p5-RDFStore/files/patch-Makefile.PL
new file mode 100644
index 000000000000..5ee9e23f62ba
--- /dev/null
+++ b/textproc/p5-RDFStore/files/patch-Makefile.PL
@@ -0,0 +1,24 @@
+--- Makefile.PL.orig 2006-06-19 19:10:21.000000000 +0900
++++ Makefile.PL 2010-01-22 12:28:28.161357031 +0900
+@@ -816,9 +816,6 @@
+ };
+ };
+
+-# build client libdbms library first
+-`(cd dbms/libdbms; make clean; make)`;
+-
+
+ WriteMakefile(
+ #DIR => [ 'RDFNode' ],
+@@ -839,6 +836,11 @@
+ ) : ()
+ );
+
++# build client libdbms library first
++chomp(my $_CCCDLFLAGS=`make -VCCCDLFLAGS`);
++chomp(my $_CFLAGS=`make -VCFLAGS`);
++print `cd dbms/libdbms; make clean; make CFLAGS="${_CFLAGS} ${_CCCDLFLAGS}"`;
++
+ sub MY::post_initialize {
+ print <<EOT;
+