aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-SGMLSpm
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-06-21 18:08:36 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-06-21 18:08:36 +0000
commit61c5387e0d9bde54193e189c8d19f0255fc2e90f (patch)
tree56517e19e5d32eb3acc63a1c873faf64666ac2ba /textproc/p5-SGMLSpm
parent804081c3dc2a98c5e76c93896b9b68aa544ff74f (diff)
downloadports-61c5387e0d9bde54193e189c8d19f0255fc2e90f.tar.gz
ports-61c5387e0d9bde54193e189c8d19f0255fc2e90f.zip
Fix perl path with shebangfix.
Assign maintainer to perl@ [1] Convert to PORT_OPTIONS DOCS and EXAMPLE and remove duplicate DOCS block. Trim makefile header Approved by: ak@ (perl@) [1]
Notes
Notes: svn path=/head/; revision=321491
Diffstat (limited to 'textproc/p5-SGMLSpm')
-rw-r--r--textproc/p5-SGMLSpm/Makefile29
1 files changed, 14 insertions, 15 deletions
diff --git a/textproc/p5-SGMLSpm/Makefile b/textproc/p5-SGMLSpm/Makefile
index 8fe5908e2742..4bf8c728c4dc 100644
--- a/textproc/p5-SGMLSpm/Makefile
+++ b/textproc/p5-SGMLSpm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: SGMLSpm
-# Date created: 4 May 2004
-# Whom: Brian Candler <B.Candler@pobox.com>
-#
+# Created by: Brian Candler <B.Candler@pobox.com>
# $FreeBSD$
-#
PORTNAME= SGMLSpm
PORTVERSION= 1.03
@@ -14,35 +10,38 @@ MASTER_SITE_SUBDIR= SGMLS
PKGNAMEPREFIX= p5-
DISTNAME= ${PORTNAME}-${PORTVERSION}ii
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module for postprocessing the output from sgmls and nsgmls
USE_PERL5_RUN= yes
+USES= shebangfix
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+SHEBANG_FILES= sgmlspl.pl \
+ DOC/HTML/SGMLSpm/sample.pl \
+ DOC/HTML/SGMLSpm/example.html
+
INSTALL_TARGET= install BINDIR=${PREFIX}/bin \
PERL5DIR=${SITE_PERL} SPECDIR=${EXAMPLESDIR}
-.ifndef(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= *
INSTALL_TARGET+=docs install_html HTMLDIR=${DOCSDIR}
.endif
-.ifdef(NOPORTEXAMPLES)
+
+.if ${PORT_OPTIONS:MEXAMPLES}
EXTRA_PATCHES= ${PATCHDIR}/noportexamples-patch-Makefile
.endif
pre-su-install:
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.endif
-.ifndef(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}
.endif
-.ifndef(NOPORTDOCS)
-PORTDOCS= *
-INSTALL_TARGET+=docs install_html HTMLDIR=${DOCSDIR}
-.endif
-
.include <bsd.port.mk>